Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54601 - genkernel doesn't work with kernel2.6.x koutput
Summary: genkernel doesn't work with kernel2.6.x koutput
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-21 00:02 UTC by Justin Metcalfe
Modified: 2004-10-03 22:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Metcalfe 2004-06-21 00:02:53 UTC
When i try to compile a 2.6.x kernel with koutput enabled, genkernel fails because it can't find the bzImage to copy.

Reproducible: Always
Steps to Reproduce:
1. enable koutput using config-kernel (config-kernel --make-koutput=current)
2. compile kernel using genkernel

Actual Results:  
genkernel errors out saying that it can't find bzImage

Expected Results:  
bzImage should be found and genkernel should handle it all correctly.

This bug makes sense since genkernel is probably looking for bzImage in
/usr/src/linuxblahblah.  Genkernel should look for the kernel image in the
kernel output folder specified.
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2004-07-03 13:18:41 UTC
``kernel image in the kernel output folder specified'' - Where is it specified so genkernel could know where to look in?
Comment 2 Justin Metcalfe 2004-07-03 19:44:42 UTC
I don't really know how the new koutput system works, so I don't really know.  I wish the system were more well-documented.  I just used config-kernel to do it all.  
Comment 3 Martin Parm 2004-07-24 03:00:31 UTC
When using config-kernel to set koutput you get an environment variable KBUILD_OUTPUT_PREFIX. It is written in /etc/env.d/05kernel.
However I don't know how it is used in the kernel build process. Just setting it and doing

  make mrproper oldconfig dep bzImage

seems to ignore it.
Comment 4 Iain Buchanan 2004-08-23 18:03:10 UTC
I've just discovered this 'feature'!  I also noticed there haven't been any comments for about a month.  Any idea on how to get around it / new genkernel version?  Or should I just go back to the old way, and set
$ config-kernel --allow-writable=yes
Comment 5 Doug Goldstein gentoo-dev 2004-10-03 22:28:54 UTC
koutput is depreciated and no longer used maintained. This is because of the build system fixes that the kernel developers commited to the 2.6.6 kernel. As as result, it is no longer supported by Gentoo Mobile team.

Below is the post to gentoo-dev mailing list by the creator of the koutput system.

Hey all,

Been busy with lots of other things, and dreading sending this anyway,
but I wanted to clear things up Re: the koutput/kbuild stuff that I'd
worked on to fix some problems previously related to 2.6 kernel build
issues.

Unfortunately, the fix that was 95% implemented, and had the beginnings
of code in the tree got ham-strung by a combination of kernel stuff
changing under my/our feet, and Real Life (tm) things coming in at just
the wrong time.

As a result, the kmod.eclass, and config-kernel have several problems,
and are only 1/2 implemented anyway. Sooo, don't use kmod.eclass. Just
don't. config-kernel i will be package.masking as well soon. I know
there are a few ebuilds out there that currently use kmod.eclass for a
few things. I'll be contacting those maintainers over the next few days
to address things with them, and get them sorted out with how to get
things working with 2.6.6 and newer kernels. If you get any bugs from
people complaining about such and such ebuild not working with koutput,
assing or CC me, and i'll deal with it. Thanks.

Sorry for any confusion folks.

-pete