Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 545710 - sys-libs/ncurses: build failure with /bin/sh != bash
Summary: sys-libs/ncurses: build failure with /bin/sh != bash
Status: RESOLVED DUPLICATE of bug 545532
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2015-04-06 09:57 UTC by Rémi Cardona
Modified: 2015-04-06 20:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2015-04-06 09:57:40 UTC
The generated to level Makefile looks it lost its first 30 or so lines and of course is no longer a valid Makefile:

    Makefile:1: *** recipe commences before first target.  Stop.


Reproducible: Always

Steps to Reproduce:
1. Point /bin/sh to 'dash' (setting CONFIG_SHELL in make.conf is not even needed)
2. emerge -1 ncurses
Comment 1 Rémi Cardona gentoo-dev 2015-04-06 10:02:10 UTC
I tried putting an "eautoreconf" call in the src_prepare() prepare phase, but that fails as ncurses' configure.in uses custom macros (AC_DIVERT_HELP) that are not shipped. Digging around, it seems that those macros are only available as autoconf patches on Thomas E. Dickey's autoconf page [1].

For now, the usual tricks are not working :(

[1] http://invisible-island.net/autoconf/autoconf.html (search for AC_DIVERT_HELP there)
Comment 2 SpanKY gentoo-dev 2015-04-06 20:06:24 UTC

*** This bug has been marked as a duplicate of bug 545532 ***