Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 545376 - sys-cluster/galera-25.3.10 - src_configure(): Checking for C library pthread... no // Error: pthread library not found
Summary: sys-cluster/galera-25.3.10 - src_configure(): Checking for C library pthread....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 544378
  Show dependency tree
 
Reported: 2015-04-03 04:45 UTC by Jeroen Roovers (RETIRED)
Modified: 2015-11-22 21:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-cluster:galera-25.3.10:20150328-072608.log.xz (20150328-072608.log.xz,1000 bytes, application/x-xz)
2015-04-03 04:45 UTC, Jeroen Roovers (RETIRED)
Details
config.log (config.log,1.37 KB, text/plain)
2015-04-07 04:31 UTC, Jeroen Roovers (RETIRED)
Details
sys-cluster:galera-25.3.10:20150408-041135.log (20150408-041135.log,18.99 KB, text/plain)
2015-04-08 04:21 UTC, Jeroen Roovers (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2015-04-03 04:45:52 UTC
Created attachment 400454 [details]
sys-cluster:galera-25.3.10:20150328-072608.log.xz

Fri  3 Apr 06:45:06 CEST 2015
emerge --info sys-cluster/galera
Portage 2.2.14 (python 3.4.1-final-0, default/linux/hppa/13.0, gcc-4.8.4, glibc-2.19-r1, 3.18.7-gentoo-JeR parisc64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.18.7-gentoo-JeR-parisc64-PA8800_-Mako-with-gentoo-2.2
KiB Mem:     8231416 total,   1133104 free
KiB Swap:    2101676 total,   2063296 free
Timestamp of tree: Fri, 03 Apr 2015 03:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 hppa2.0-unknown-linux-gnu [enabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p53
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.2.5-r6, 3.3.5-r1, 3.4.1
dev-util/ccache:          3.1.9-r4
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.11
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6-r1, 1.12.6, 1.13.4
sys-devel/binutils:       2.22-r1, 2.23.1, 2.23.2, 2.24-r3
sys-devel/gcc:            4.6.3, 4.6.4, 4.7.2-r1, 4.7.3-r1, 4.8.1-r1, 4.8.3, 4.8.4, 4.9.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.6
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo JeR
ACCEPT_KEYWORDS="hppa"
ACCEPT_LICENSE="*"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -Wformat=2 -O2 -pipe -Wno-comment"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/distcc/bin /usr/share/gnupg/qualified.txt /var/bind /var/spool/torque /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -Wformat=2 -O2 -pipe"
DISTDIR="/world/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n --autounmask=n"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs buildpkg cgroup compressdebug config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news notitles parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-mschedule=8000 -march=2.0 -ggdb -Wall -Wformat=2 -O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/gentoo/ http://gentoo.mneisen.org/ http://mirror.netcologne.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://mirror.leaseweb.com/gentoo/ http://gentoo.tiscali.nl/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,--no-keep-memory"
MAKEOPTS="-j6"
PKGDIR="/keeps/gentoo/packages/karsten"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/world/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
USE="256-color X acl alsa amr anacron apng argyllcms audit bash-completion beautifulsoup3 berkdb bfio bittorrent botan bzip2 cairo canberra cli consolekit coverage cracklib crossdev crypt cups custom-cflags cxx dane dbus declarative dirac directfb distinct-l dlz doc dot dri emacs exceptions exif expat fbcon filecaps firefox firmware foomaticdb fortran frontend-optional g-sorcery gbm gdbm geoip geoloc glep gles1 gles2 gost gpg gpm graphite gsm gstreamer gtk gudev guile hddtemp hppa hwdb iconv idn imlib inotify ipv6 jadetex javascript jingle jit jpeg jpeg2k json kdrive kmod ladspa lasi launch-frontend libav libcaca libcanberra libevent libopts libsoxr libusb libwww lua lzma lzo mad mng mod modplug modules mp3 multislot multitarget munge nagios ncurses netlink nfs nls nptl objc objc++ objc-gc offensive openexr opengl openmp openrc openvg opus oqgraph osmesa oss pam pcre pcre16 php pic pkcs11 png pnm policykit python qt qt3support qt4 readline realtime regression-test rtmp samba sbc schroedinger sctp session smi socks5 speex spell spidermonkey sqlite ssl svg tcl tcpd test tga theora threads tiff tk tokyocabinet truetype unicode unwind v4l vim-syntax vorbis vpx wayland wcwidth x264 x265 xa xattr xcb xft xhtml xkb xml2 xvfb xvid zlib" ALSA_CARDS="ad1889 usb-audio" APACHE2_MODULES="authz_host dir mime alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="nfs syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev joystick keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio magellan microtouch mutouch palmax penmount spaceorb summa tek4957 tslib ur98 void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en nl he" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4 php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="stifb dummy" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2015-04-03 13:04:33 UTC
--- ./ChangeLog
+++ ./ChangeLog
@@ -4,0 +5,3 @@
+  03 Apr 2015; Brian Evans <grknight@gentoo.org> galera-25.3.5.ebuild:
+  Add append-flags -D_REENTRANT wrt bug 545376
+
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2015-04-06 07:34:46 UTC
(In reply to Brian Evans from comment #1)
> --- ./ChangeLog
> +++ ./ChangeLog
> @@ -4,0 +5,3 @@
> +  03 Apr 2015; Brian Evans <grknight@gentoo.org> galera-25.3.5.ebuild:
> +  Add append-flags -D_REENTRANT wrt bug 545376

1) I'm not sure that's the right fix.
2) 25.3.10 still fails.
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2015-04-06 13:35:52 UTC
Please post the config.log that is generated in $S

Sconstruct says:

if not conf.CheckLib('pthread'):
    print 'Error: pthread library not found'
    Exit(1)


On amd64:

scons: Configure: Checking for C library pthread... 
.sconf_temp/conftest_0.c <-
  |
  |
  |
  |int
  |main() {
  |  
  |return 0;
  |}
  |
x86_64-pc-linux-gnu-gcc -o .sconf_temp/conftest_0.o -c -O2 -march=native -pipe -fomit-frame-pointer -mno-tls-direct-seg-refs -std=c99 -fno-strict-aliasing -pipe -DNDEBUG -m64 -Wall -Wextra -Wno-unused-parameter -pthread -D_XOPEN_SOURCE=600 -DHAVE_COMMON_H -I. -Iasio -Icommon -Igalerautils/src -Igcomm/src -Igcomm/src/gcomm -Igcache/src -Igcs/src -Iwsdb/src -Igalera/src .sconf_temp/conftest_0.c
x86_64-pc-linux-gnu-gcc -o .sconf_temp/conftest_0 -m64 -Wl,-melf_x86_64 -Wl,-O1 -Wl,--as-needed .sconf_temp/conftest_0.o -lpthread
scons: Configure: yes
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2015-04-07 04:31:33 UTC
Created attachment 400744 [details]
config.log
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2015-04-07 21:00:22 UTC
Added a patch to remove all hardware specific CFLAGS.

Please retest again.
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2015-04-08 04:21:29 UTC
Created attachment 400802 [details]
sys-cluster:galera-25.3.10:20150408-041135.log

./chromium/build_config.h:129:2: error: #error Please add support for your architecture in build/build_config.h

That file lays out support for amd64, x86, ARM, MIPS and PPC. It doesn't look like it's trying to figure out what architecture it's being compiled for very well - it just looks for some keywords and sets some variables. In the case of __PPC64__, for instance, it magically knows the system must be bigendian. It shouldn't be hard to teach it to do this properly, I guess. But it's still scons.
Comment 7 Brian Evans Gentoo Infrastructure gentoo-dev 2015-04-08 13:39:23 UTC
(In reply to Jeroen Roovers from comment #6)
> Created attachment 400802 [details]
> sys-cluster:galera-25.3.10:20150408-041135.log
> 
> ./chromium/build_config.h:129:2: error: #error Please add support for your
> architecture in build/build_config.h
> 
> That file lays out support for amd64, x86, ARM, MIPS and PPC. It doesn't
> look like it's trying to figure out what architecture it's being compiled
> for very well - it just looks for some keywords and sets some variables. In
> the case of __PPC64__, for instance, it magically knows the system must be
> bigendian. It shouldn't be hard to teach it to do this properly, I guess.
> But it's still scons.

The sad part is.. they borrowed this code from chromium and the only part that is used outside that file is

chromium/aligned_memory.h:#if defined(__GNUC__) && !defined(ARCH_CPU_X86_FAMILY)

The only define that is used is COMPILER_GCC.

So I can patch out that error and have no ill effects.

Then again,
#if defined(__GNUC__) && !defined(ARCH_CPU_X86_FAMILY)
    CHROMIUM_COMPILE_ASSERT(ALIGNOF(T) <= 16, crbug_115612);
#endif

will probably trigger an error since CHROMIUM_COMPILE_ASSERT does not seem to be defined anywhere :(
Comment 8 SpanKY gentoo-dev 2015-05-27 14:17:26 UTC
(In reply to Brian Evans from comment #1)

please revert that as the bug lies in gcc (see bug 543114)
Comment 9 Brian Evans Gentoo Infrastructure gentoo-dev 2015-05-27 16:37:09 UTC
(In reply to SpanKY from comment #8)
> (In reply to Brian Evans from comment #1)
> 
> please revert that as the bug lies in gcc (see bug 543114)

This part is reverted.. still need to investigate the other definition.
Comment 10 Brian Evans Gentoo Infrastructure gentoo-dev 2015-09-15 14:12:53 UTC
I've added galera-25.3.12 and patched out the #error preprocessor since that section is only used as:

#if defined(__GNUC__) && !defined(ARCH_CPU_X86_FAMILY)
    CHROMIUM_COMPILE_ASSERT(ALIGNOF(T) <= 16, crbug_115612);
#endif

I found the assert and it does a simple check.

If that fails, then there will be no support.

Please retry
Comment 11 Brian Evans Gentoo Infrastructure gentoo-dev 2015-11-22 21:14:05 UTC
No response for test request and I believe all problems are resolved.

Reopen if there are still issues