Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 545352 - Features request: sys-apps/portage support use of * in atoms for all package.* files
Summary: Features request: sys-apps/portage support use of * in atoms for all package....
Status: RESOLVED INVALID
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-02 19:27 UTC by Lagu
Modified: 2015-05-31 05:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lagu 2015-04-02 19:27:58 UTC
Hi, i have some recomendations for portage:

1) enable * in package.* for specefied packages

ex. in package.accept_keywords/foo add
    =media-video/libav-10.* 

actually the * only can be used in packages without specifications (type media-video/lib*) but we can't specify a version, and i see some bugs have temp solutions type */* in this conf files, and with this we can't avoid that type of thing, and i a lot of overlays the update packages are listed as foo-1-r1 foo-1-r2 and we most be searching that things.

2) Conflicts with packages in general, add an option in verbose mode, example for can see the orignal package request an feature or conflict, ex:

foo1 depends of foo2 and it depends of foo3

foo3 is blocking a fuu package, we will see that message, but we don't know foo 3 depends of foo1, and we mos start searching with all depencies to know what package we most change, is very annoying and the same with version conflicts when example i wan't to install a newer version of mesa.

3) An option for portage can rebuild automatically circular dependencies, or portage ask to the user because we in this case most disable a use, build, enable the use and rebuild one package, and next rebuild the other with the all uses enabled.

4) When portage say, add ### lines to package.use example, portage add this lines to any file (if we update with etc-update), if portage can ask o create a new file in the directories. 

Thx
Comment 1 Zac Medico gentoo-dev 2015-04-08 16:00:21 UTC
(In reply to Lagu from comment #0)
> ex. in package.accept_keywords/foo add
>     =media-video/libav-10.* 

The problem is that the above is not considered a valid atom. The specification (PMS) says that the version part before the '*' must be a valid version, and a valid version never ends with a '.'. So, "=media-video/libav-10*" would be the closest valid atom.
Comment 2 Brian Dolbec gentoo-dev 2015-04-08 16:02:31 UTC
Please file separate bugs for each feature request.  That way they can be dealt with on an individual basis.  But I suspect several of them (#2, #3) would be duplicates of other existing bugs, not necessarily feature request bugs, but the same problem none the less.

#4) there is a discussion about that already in out portage development mail list.

I've changed the summary of this one to the first request.
Comment 3 SpanKY gentoo-dev 2015-05-31 05:30:25 UTC
per comment #1