Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54522 - uf-view doesn't compile
Summary: uf-view doesn't compile
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Desktop Misc. Team
Depends on: 54627
  Show dependency tree
Reported: 2004-06-20 06:22 UTC by Matthias Muthmann
Modified: 2004-07-05 09:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Muthmann 2004-06-20 06:22:48 UTC
When I try to emerge uf-view, I get this output:

sh-2.05b# emerge uf-view
Calculating dependencies ...done!
>>> emerge (1 of 1) x11-misc/uf-view-2.2 to /
>>> md5 src_uri ;-) uf-view-2.2.tar.gz
>>> Unpacking source...
>>> Unpacking uf-view-2.2.tar.gz to /var/tmp/portage/uf-view-2.2/work
>>> Source unpacked.
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... found
checking for working autoconf... found
checking for working automake-1.4... found
checking for working autoheader... found
checking for working makeinfo... found
checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 libgnomeui-2.0 gnome-vfs-2.0 gnome-desktop-2.0... yes
checking UF_CFLAGS... -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0 -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gnome-desktop-2.0 -I/usr/include/startup-notification-1.0
checking UF_LIBS... -Wl,--export-dynamic -pthread -L/usr/X11R6/lib -lgnome-desktop-2 -lgnomeui-2 -lSM -lICE -lstartup-notification-1 -lbonoboui-2 -lxml2 -lpthread -lz -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lbonobo-2 -lgconf-2 -lgnomevfs-2 -lbonobo-activation -lORBit-2 -lgobject-2.0 -lgthread-2.0 -lm -lgmodule-2.0 -ldl -lglib-2.0
checking for i686-pc-linux-gnu-gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for catalogs to be installed...  az cs de fr no pl pt_BR ru sk sv vi wa
configure: creating ./config.status
config.status: creating Makefile
config.status: creating uf-view.spec
config.status: creating data/Makefile
config.status: creating po/
config.status: creating config.h
config.status: executing default-1 commands
config.status: executing default-2 commands
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2'
Making all in po
make[2]: Entering directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2/po'
Making all in data
make[2]: Entering directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2/data'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2/data'
make[2]: Entering directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2'
gcc -DHAVE_CONFIG_H -I. -I. -I. -DGNOMELOCALEDIR=\""/usr/share/locale"\"                -DDATADIR=\""/usr/share"\"                           -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0 -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gnome-desktop-2.0 -I/usr/include/startup-notification-1.0      -march=athlon-tbird -O3 -pipe -fomit-frame-pointer -mmmx -m3dnow -c uf-gui.c
gcc -DHAVE_CONFIG_H -I. -I. -I. -DGNOMELOCALEDIR=\""/usr/share/locale"\"                -DDATADIR=\""/usr/share"\"                           -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0 -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/gnome-desktop-2.0 -I/usr/include/startup-notification-1.0      -march=athlon-tbird -O3 -pipe -fomit-frame-pointer -mmmx -m3dnow -c uf-view.c
In file included from uf-gui.c:16:
/usr/include/gnome-desktop-2.0/libgnome/gnome-desktop-item.h:216: error: syntax error before '*' token
/usr/include/gnome-desktop-2.0/libgnome/gnome-desktop-item.h:218: error: syntax error before '*' token
uf-gui.c: In function `create_prefs':
uf-gui.c:170: warning: assignment makes pointer from integer without a cast
distcc[18243] ERROR: compile on localhost failed
make[2]: *** [uf-gui.o] Error 1
make[2]: *** Waiting for unfinished jobs....
distcc[18245] (dcc_connect_timed) ERROR: Connection to failed: No route to host
distcc[18245] (dcc_build_somewhere) Warning: failed to distribute to, running locally instead
In file included from uf-view.c:5:
/usr/include/gnome-desktop-2.0/libgnome/gnome-desktop-item.h:216: error: syntax error before '*' token
distcc[18245] ERROR: compile on localhost failed
make[2]: *** [uf-view.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/uf-view-2.2/work/uf-view-2.2'
make: *** [all-recursive-am] Error 2

!!! ERROR: x11-misc/uf-view-2.2 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure

Reproducible: Always
Steps to Reproduce:
1. enmerge uf-view

Actual Results:  
Compile errors

Expected Results:  

The distcc errors were because the other computer was not running at this time.

Portage 2.0.50-r8 (default-x86-1.4, gcc-3.3.3, glibc-, 2.6.7)
System uname: 2.6.7 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.4.16
distcc 2.13 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=athlon-tbird -O3 -pipe -fomit-frame-pointer -mmmx -m3dnow"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-tbird -O3 -pipe -fomit-frame-pointer -mmmx -m3dnow"
FEATURES="autoaddcvs ccache distcc sandbox"
USE="3dnow X alsa apm arts avi berkdb cdr crypt cups dga directfb encode evo f77
fbcon foomaticdb gb gd gdbm ggi gif gtk gtk2 icq imlib java jikes jpeg kde
kerberos lcms libg++ libwww mad matroska matrox mga mikmod mmx motif mozilla
moznocompose moznoirc moznomail mpeg ncurses nls oggvorbis opengl oss pda pdflib
perl pic png ppds python qt qtmt quicktime readline scanner sdl slang spell ssl
svga tcltk tcpd tetex theora tiff truetype usb video_cards_matrox x86 xface xml2
xmms xv zlib"
Comment 1 Matthias Muthmann 2004-06-20 06:31:39 UTC
I think, I just found a solution for the bug. I just tried to install the latest version with the same ebuild and it worked fine. So a version update should fix the problem.
Comment 2 Steve Clement 2004-06-21 06:13:45 UTC
Filed new bug for uf-view 2.4:
Because 2.4 compiles...
Comment 3 foser (RETIRED) gentoo-dev 2004-06-21 16:52:06 UTC
not gnome
Comment 4 Markus Nigbur (RETIRED) gentoo-dev 2004-07-03 06:28:30 UTC
try the ~arch version.
Comment 5 Matthias Muthmann 2004-07-05 09:50:18 UTC
The ~arch version compiles and works fine. Thanks!