Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54503 - Kernel Panic in interrupt handler
Summary: Kernel Panic in interrupt handler
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2004-06-20 03:16 UTC by Don Scorgie
Modified: 2004-08-16 00:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

kernel config file (.config,25.38 KB, text/plain)
2004-06-20 03:18 UTC, Don Scorgie

Note You need to log in before you can comment on or make changes to this bug.
Description Don Scorgie 2004-06-20 03:16:01 UTC
When trying to boot from a gentoo kernel (versions 2.6.5, 2.6.5-r1 and 2.6.7 tested), the following appears (Hand typed, please excuse any errors):
[<c0103d11>] kernel_thread_helper + 0x5/0x14
code 39 42 20 7e 1a 8b 15 80 e1 4a c0 8d 42 01 81 e2 ff 0f 00 00
Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing
I'm not sure if this is the same as bug #48315 (it seems similar), but no touchpad here.

I have tried several config (config by hand and with genkernel) with the same result.

A reboot fixes this (i.e. the message appears and pressing the reboot button on the computer makes the system work right) but when it cold-starts the kernel panics again.

A vanilla kernel with a similar config (as near as possible) seems to work alright.

I'll attach my kernel config file.

Reproducible: Always
Steps to Reproduce:
1. Shutdown the computer (Not a restart)
2. Power on
3. Select Gentoo from GRUB menu

Actual Results:  
The kernel panics

Expected Results:  
Boot properly

Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-, 2.6.7)
System uname: 2.6.7 i686 AMD Athlon(TM) XP 2600+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X acpi alsa apm arts avi berkdb bonobo cdr crypt cups curl dga
divx4linux dvd emacs encode esd evo flac flash foomaticdb gdbm gif gnome gpm gtk
gtk2 gtkhtml imlib java jpeg libg++ libwww mad mikmod mmx motif mozilla mpeg msn
nas ncurses nls oggvorbis opengl oss pam pda pdflib perl png python quicktime
readline sdl slang spell ssl svga tcpd theora tiff truetype usb videos x86 xml2
xmms xv xvid zlib"
Comment 1 Don Scorgie 2004-06-20 03:18:15 UTC
Created attachment 33616 [details]
kernel config file

My kernel .config file (Made using menu config) for the gentoo kernel
Comment 2 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-06-21 00:47:13 UTC
Can you report this to as you can reproduce this with a
stock kernel.
Comment 3 Don Scorgie 2004-06-21 05:13:21 UTC
The problem is that I can't reproduce it with a stock kernel (To the best of my knowledge).

Comment 4 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-06-21 11:14:51 UTC
Please enable CONFIG_KALLSYMS which should show you exactly where the 
panic is happening.

Also, can you try the 2.6.7-r2 release that just got pushed to the servers?
Comment 5 Don Scorgie 2004-06-23 10:15:22 UTC
I have tried with gentoo-dev-sources-2.6.7-r5.  It is still happening.  The following is what is displayed on screen when this happens (again, hand typed so please excuse any typos):
[<c0236103>] i8042_interrupt+0xb3/0x160
[<c0107dba>] handle_IRQ_event+0x3a/0x70
[<c0108101>] do_IRQ+0x91/0x130
[<c0106474>] common_interrupt+0x18/0x20
[<c0110a04>] delay_tsc+0x14/0x20
[<c020b1b2>] __delay+0x12/0x20
[<c0231b7c>] atkbd_command+0xbc/0x1e0
[<c0231f9e>] atkbd_probe+0x3e/0x120
[<c0232661>] atkbd_connect+0x371/0x3e0
[<c0235496>] serio_find_dev+0x56/0x60
[<c02358b6>] serio_register_port+0x26/0x40
[<c047fb98>] i8042_register_port+0x68/0x90
[<c047fd00>] i8042_init+0x80/0x1c0
[<c047f8df>] serio_init+0x1f/0x80
[<c046c6dc>] do_initcalls+0x2c/0xc0
[<c01279f7>] init_workqueues+0x17/0x60
[<c0100410>] init+0x0/0x170
[<c010044a>] init+0x3a/0x170
[<c0103d03>] kernel_thread_helper+0x0/0x14
[<c0103d11>] kernel_thread_helper+0x5/0x14
code 39 42 20 7e 1a 8b 15 80 e1 4a c0 8d 42 01 81 e2 ff 0f 00 00
Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing
It then just sits there for ever (as far as I can tell - at least 30 mins).
The above is with CONFIG_KALLSYMS = y

If you need anything more, please let me know
Comment 6 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-06-24 16:45:02 UTC
So, using the same exact .config file with a clean kernel, this
does not happen?  I don't see how, as we don't modify any files near this
code path...
Comment 7 Don Scorgie 2004-06-25 08:10:39 UTC
Using exactly the same config file on a stock, clean kernel does not produce an error.

Both have exactly the same grub menu entry.

Sorry, I don't know what else to tell you.

Comment 8 Tim Yamin (RETIRED) gentoo-dev 2004-07-29 12:52:54 UTC
Do you want to try with CONFIG_PREEMPT=n, no ACPI support and "noapic" passed to the kernel from GRUB?

Comment 9 Don Scorgie 2004-08-15 04:15:33 UTC

I have just tried the following
Using gentoo kernel 2.6.7-r13, I built:
1. A new kernel using the previous .config file
2. A new kernel with preemptive disabled (CONFIG_PREEMPT=n)
3. A new kernel with preemptive disabled and all forms of power
management disabled (No ACPI or APM support)

I also tried passing "noapic" from the GRUB command line in all three cases.

None of these seem to have any effect on the problem.

Comment 10 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-08-16 00:36:29 UTC
Can you try the 2.6.8 kernel that's released?