Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54490 - xine-lib-1_rc4-r1 doesn't want to build
Summary: xine-lib-1_rc4-r1 doesn't want to build
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-19 21:45 UTC by Robert Muchacki (RETIRED)
Modified: 2004-06-24 12:31 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Muchacki (RETIRED) gentoo-dev 2004-06-19 21:45:20 UTC
During the building of xine-lib-1_rc4-r1 I get this error:

_faad.so -o .libs/xineplug_decode_faad.so
.libs/hcr.o: file not recognized: File format not recognized
collect2: ld returned 1 exit status
make[4]: *** [xineplug_decode_faad.la] B??d 1

Here is my emerge --info:

gamma root # emerge --info
Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r0, 2.6.5-gentoo-r1)
=================================================================
System uname: 2.6.5-gentoo-r1 i686 AMD Athlon(tm) XP 3100+
Gentoo Base System version 1.4.16
distcc 2.13 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -mfpmath=sse -msse -mmmx -m3dnow -O3 -pipe -fomit-frame-pointer -fexpensive-optimizations"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -mfpmath=sse -msse -mmmx -m3dnow -O3 -pipe -fomit-frame-pointer -fexpensive-optimizations"
DISTDIR="/hda4/portage/distfiles"
FEATURES="autoaddcvs ccache fixpackages sandbox"
GENTOO_MIRRORS="http://gentoo.zie.pg.gda.pl ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/hda4/tmp"
PORTDIR="/hda4/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.pl/gentoo-portage"
USE="3dnow X Xaw3d aalib accessibility acpi alsa apm arts avi berkdb bonobo cddb cdr crypt cscope cups directfb dvd encode esd faad fbcon fbdev ffmpeg fftw foomaticdb gb gdbm ggi gif gnome gnomedb gpm gstreamer gtk gtkhtml guile imagemagick imlib imlib2 jabber jpeg kde ldap libg++ libwww mbox mikmod mmx motif mozilla mpeg ncurses nls nvidia oggvorbis opengl oss pam pdflib perl png postgres python qt quicktime radeon readline sdl slang spell sse ssl svga tcltk tcpd tiff transcode truetype usb x86 xface xml2 xmms xv xvid zlib"


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Chris White (RETIRED) gentoo-dev 2004-06-19 22:39:28 UTC
 * Caching service dependencies...
>>> media-libs/xine-lib-1_rc4-r1 merged.
>>> Recording media-libs/xine-lib in "world" favorites file...

Nope, no issues here.  Anyone else want to confirm this?
Comment 2 Hagabard 2004-06-20 03:22:52 UTC
Mine fails for a different reason (same reason it's had for a month or two, i've just given up on xine and switched back to mplayer for now)

Command line:  
CFLAGS="-mcpu=athlon-xp" USE="aalib dvd directfb speex theora" MAKEOPTS="" emerge gxine
(since i want gxine, but it dies on xine-lib for any other xine front end)

 gcc -DHAVE_CONFIG_H -I. -I. -I../../../.. -I../../../.. -I../../../../include -I../../../../include -I../../../../src -I../../../../src/xine-engine -I../../../../src/xine-engine -I../../../../src/xine-utils -I../../../../src/input -I../../../../src/input -mcpu=athlon-xp -fno-stack-protector -mno-sse2 -DSIMPLE_IDCT -DHAVE_AV_CONFIG_H -DRUNTIME_CPUDETECT -DUSE_FASTMEMCPY -DCONFIG_RISKY -DCONFIG_DECODERS -DXINE_MPEG_ENCODER -DCONFIG_ZLIB -Wall -DNDEBUG -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -Wpointer-arith -Wnested-externs -Wcast-align -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -mcpu=athlon-xp -fno-stack-protector -mno-sse2 -MT dsputil_mmx.lo -MD -MP -MF .deps/dsputil_mmx.Tpo -c dsputil_mmx.c -o .libs/dsputil_mmx.o
dsputil_mmx.c: In function `h263_h_loop_filter_mmx':
dsputil_mmx.c:633: error: can't find a register in class `GENERAL_REGS' while reloading `asm'
dsputil_mmx.c: In function `dsputil_init_mmx':
dsputil_mmx.c:2135: warning: unused variable `dct_algo'
dsputil_mmx.c: At top level:
dsputil_mmx_rnd.h:363: warning: `avg_no_rnd_pixels8_l2_mmx' defined but not used
dsputil_mmx_rnd.h:410: warning: `avg_no_rnd_pixels16_l2_mmx' defined but not used
dsputil_mmx_avg.h:57: warning: `put_pixels8_l2_3dnow' defined but not used
dsputil_mmx_avg.h:129: warning: `put_pixels16_l2_3dnow' defined but not used
dsputil_mmx_avg.h:57: warning: `put_pixels8_l2_mmx2' defined but not used
dsputil_mmx_avg.h:129: warning: `put_pixels16_l2_mmx2' defined but not used
dsputil_mmx.c:1995: warning: `try_8x8basis_mmx' defined but not used
dsputil_mmx.c:2043: warning: `add_8x8basis_mmx' defined but not used
make[5]: *** [dsputil_mmx.lo] Error 1
make[5]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a/src/libffmpeg/libavcodec/i386'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a/src/libffmpeg/libavcodec'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a/src/libffmpeg'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a'
make: *** [all] Error 2

!!! ERROR: media-libs/xine-lib-1_rc4-r1 failed.
!!! Function src_compile, Line 122, Exitcode 2
!!! Parallel make failed



Portage 2.0.50-r7 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3_pre20040420-r0, 2.6.5-gentoo-r1)
=================================================================
System uname: 2.6.5-gentoo-r1 i686 AMD Athlon(tm) XP 2200+
Gentoo Base System version 1.4.15
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-mcpu=athlon-xp"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=athlon-xp"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo ftp://gentoo.mirror.pair.com/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="3dnow X aalib alsa apm arts avi berkdb cdr crypt cups directfb encode esd foomaticdb gdbm gif gnome gphoto2 gpm gtk gtk2 imlib java jpeg kde ldap libg++ libwww mad mikmod mmx motif mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline ruby sdl slang spell ssl svga tcltk tcpd truetype x86 xml2 xmms xv zlib"

Comment 3 Chris White (RETIRED) gentoo-dev 2004-06-20 22:09:04 UTC
Hmm, Hagabard: did you try without the mmx build flag?  MMX is pentium, why would you have that enabled on an athlon-xp system?  See if that works.
Comment 4 merwan kashouty 2004-06-21 00:00:46 UTC
hagabard try #MAKEOPTS="-j1" emerge xine-lib
Comment 5 Martin Eisenhardt 2004-06-21 07:38:11 UTC
Hello,

I can confirm this bug for various xine-ebuilds. I've tested xine-lib-1_rc4-r1 and xine-lib-1_rc4 so far, with exactly the same results (see below). It might be the case that changes in the ebuilds and/or the code over the last two weeks introduced this bug - I was able to install a machine some 3 weeks ago, without any problems (as far as xine-lib is concerned, that is ... ;-)

And: yes, I tried the MAKEOPTS="-j1" suggestion, and it did not change the results.

Here is the output from the emerge command:

<snip>

ic_predict.c: In function `flt_round':
ic_predict.c:55: warning: dereferencing type-punned pointer will break strict-aliasing rules
ic_predict.c:55: warning: dereferencing type-punned pointer will break strict-aliasing rules
ic_predict.c:55: warning: dereferencing type-punned pointer will break strict-aliasing rules
ic_predict.c:57: warning: dereferencing type-punned pointer will break strict-aliasing rules
ic_predict.c: In function `quant_pred':
ic_predict.c:64: warning: dereferencing type-punned pointer will break strict-aliasing rules
ic_predict.c: In function `inv_quant_pred':
ic_predict.c:74: warning: dereferencing type-punned pointer will break strict-aliasing rules
ic_predict.c: In function `ic_predict':
ic_predict.c:81: error: insn does not satisfy its constraints:
(insn 634 515 228 6 0x4039f840 (set (reg/v:SF 29 emm0 [72])
        (const_double:SF 0 [0x0] 0.0 [0x0.0p+0])) 61 {*movsf_1} (nil)
    (nil))
ic_predict.c:81: internal compiler error: in build_def_use, at regrename.c:782
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /tmp/ccloMFVT.out file, please attach this to your bugreport.
make[4]: *** [ic_predict.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4/work/xine-lib-1-rc4/src/libfaad'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4/work/xine-lib-1-rc4/src/libfaad'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4/work/xine-lib-1-rc4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4/work/xine-lib-1-rc4'
make: *** [all] Error 2

!!! ERROR: media-libs/xine-lib-1_rc4 failed.
!!! Function src_compile, Line 117, Exitcode 2
!!! Parallel make failed

</snip>

emerge info:
<snip>
Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r0, 2.6.5-gentoo-r1)
=================================================================
System uname: 2.6.5-gentoo-r1 i686 Intel(R) Pentium(R) III Mobile CPU       866MHz
Gentoo Base System version 1.4.16
distcc 2.14 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=pentium3 -mfpmath=sse -mmmx -msse -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -mcpu=pentium3 -mfpmath=sse -mmmx -msse -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distcc sandbox"
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo http://212.219.247.21/sites/www.ibiblio.org/gentoo/ http://212.219.247.10/sites/www.ibiblio.org/gentoo/ http://212.219.247.12/sites/www.ibiblio.org/gentoo/"
MAKEOPTS="-j20"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://cipinf2.cip.uni-bayreuth.de/gentoo-portage"
USE="X acpi apache2 apm arts avi berkdb cdr crypt cups doc dvd emacs encode esd foomaticdb gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 icc imagemagick imap imlib java jpeg kde libg++ libwww mad mikmod motif mozilla mpeg mpi mysql ncurses nls odbc oggvorbis opengl oss pam pdflib perl plotutils png python qt quicktime readline ruby samba scanner sdl slang spell sse ssl svga tcpd tetex tiff tk truetype unicode usb wxwindows x86 xml2 xmms xv zlib"
</snip>

You might notice that my system is based on a PIII, so the problem is not restricted to AMD CPUs, chipsets and/or other hardware.

Looking forward to your replies!

Thanks in advance!

Best regards
Martin Eisenhardt
Comment 6 Tuan Van (RETIRED) gentoo-dev 2004-06-21 11:45:30 UTC
Please try this:
1. disable ccache.
2. change your CFLAGS="-O2 -march=pentium3 -pipe"
Comment 7 Martin Eisenhardt 2004-06-22 03:07:30 UTC
Hello,

that last suggestion actually worked for me, but I cannot say whether disabling ccache or the altered CCFLAGS made the difference. Thanks!

Nevertheless, this behavior of the xine ebuild should be considered a bug and fixed as soon as possible. Just my 2 cents ...

Kind regards
Martin Eisenhardt
Comment 8 Hagabard 2004-06-22 12:23:33 UTC
root # CFLAGS="-mcpu=athlon-xp" USE="aalib dvd directfb speex theora -mmx" MAKEOPTS="-j1" emerge xine-lib

Results: same as above
Comment 9 Detro 2004-06-22 14:21:52 UTC
CFLAGS="-mcpu=7450 -Os -pipe -fsigned-char -maltivec -mabi=altivec -mpowerpc-gfxopt":
-------------------------------------------------------

gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../include -I../../include -I../../src -I../../src/xine-engine -I../../src/xine-engine -I../../src/xine-utils -I../../src/input -I../../src/input -mcpu=7450 -Os -pipe -fsigned-char -mpowerpc-gfxopt -Wa,-m7400 -O3 -pipe -fomit-frame-pointer -fexpensive-optimizations -fschedule-insns2 -fno-strict-aliasing -ffast-math -funroll-loops -funroll-all-loops -finline-functions -Wall -DNDEBUG -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -Wpointer-arith -Wnested-externs -Wcast-align -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -mcpu=7450 -Os -pipe -fsigned-char -mpowerpc-gfxopt -MT idct_altivec.lo -MD -MP -MF .deps/idct_altivec.Tpo -c idct_altivec.c  -fPIC -DPIC -o .libs/idct_altivec.o
idct_altivec.c:629: error: syntax error before "signed"
idct_altivec.c:630: error: `vector' undeclared here (not in a function)
idct_altivec.c:630: error: syntax error before "signed"
idct_altivec.c:630: error: initializer element is not constant
idct_altivec.c:630: error: (near initialization for `constants[0]')
idct_altivec.c:631: error: `vector' undeclared here (not in a function)
idct_altivec.c:631: error: syntax error before "signed"
idct_altivec.c:631: error: initializer element is not constant
idct_altivec.c:631: error: (near initialization for `constants[1]')
idct_altivec.c:632: error: `vector' undeclared here (not in a function)
idct_altivec.c:632: error: syntax error before "signed"
idct_altivec.c:632: error: initializer element is not constant
idct_altivec.c:632: error: (near initialization for `constants[2]')
idct_altivec.c:633: error: `vector' undeclared here (not in a function)
idct_altivec.c:633: error: syntax error before "signed"
idct_altivec.c:633: error: initializer element is not constant
idct_altivec.c:633: error: (near initialization for `constants[3]')
idct_altivec.c:634: error: `vector' undeclared here (not in a function)
idct_altivec.c:634: error: syntax error before "signed"
idct_altivec.c:635: error: initializer element is not constant
idct_altivec.c:635: error: (near initialization for `constants[4]')
idct_altivec.c:637: error: syntax error before "signed"
idct_altivec.c:639: warning: no previous prototype for `mpeg2_idct_copy_altivec'
idct_altivec.c: In function `mpeg2_idct_copy_altivec':
idct_altivec.c:640: error: `vector' undeclared (first use in this function)
idct_altivec.c:640: error: (Each undeclared identifier is reported only once
idct_altivec.c:640: error: for each function it appears in.)
idct_altivec.c:640: error: syntax error before "unsigned"
idct_altivec.c:642: error: `c4' undeclared (first use in this function)
idct_altivec.c:642: warning: implicit declaration of function `vec_splat'
idct_altivec.c:642: error: `a0' undeclared (first use in this function)
idct_altivec.c:642: error: `a1' undeclared (first use in this function)
idct_altivec.c:642: error: `a2' undeclared (first use in this function)
idct_altivec.c:642: error: `mc4' undeclared (first use in this function)
idct_altivec.c:642: error: `ma2' undeclared (first use in this function)
idct_altivec.c:642: error: `bias' undeclared (first use in this function)
idct_altivec.c:642: error: syntax error before "signed"
idct_altivec.c:642: error: `zero' undeclared (first use in this function)
idct_altivec.c:642: warning: implicit declaration of function `vec_splat_s16'
idct_altivec.c:642: error: `shift' undeclared (first use in this function)
idct_altivec.c:642: warning: implicit declaration of function `vec_splat_u16'
idct_altivec.c:642: error: `vx0' undeclared (first use in this function)
idct_altivec.c:642: warning: implicit declaration of function `vec_mradds'
idct_altivec.c:642: warning: implicit declaration of function `vec_sl'
idct_altivec.c:642: error: `block' undeclared (first use in this function)
idct_altivec.c:642: error: `vx1' undeclared (first use in this function)
idct_altivec.c:642: error: `vx2' undeclared (first use in this function)
idct_altivec.c:642: error: `vx3' undeclared (first use in this function)
idct_altivec.c:642: error: `vx4' undeclared (first use in this function)
idct_altivec.c:642: error: `vx5' undeclared (first use in this function)
idct_altivec.c:642: error: `vx6' undeclared (first use in this function)
idct_altivec.c:642: error: `vx7' undeclared (first use in this function)
idct_altivec.c:642: error: `t1' undeclared (first use in this function)
idct_altivec.c:642: error: `t8' undeclared (first use in this function)
idct_altivec.c:642: warning: implicit declaration of function `vec_subs'
idct_altivec.c:642: error: `t7' undeclared (first use in this function)
idct_altivec.c:642: error: `t3' undeclared (first use in this function)
idct_altivec.c:642: error: `t5' undeclared (first use in this function)
idct_altivec.c:642: warning: implicit declaration of function `vec_adds'
idct_altivec.c:642: error: `t0' undeclared (first use in this function)
idct_altivec.c:642: error: `t2' undeclared (first use in this function)
idct_altivec.c:642: error: `t4' undeclared (first use in this function)
idct_altivec.c:642: error: `t6' undeclared (first use in this function)
idct_altivec.c:642: error: `vy0' undeclared (first use in this function)
idct_altivec.c:642: error: `vy7' undeclared (first use in this function)
idct_altivec.c:642: error: `vy1' undeclared (first use in this function)
idct_altivec.c:642: error: `vy6' undeclared (first use in this function)
idct_altivec.c:642: error: `vy2' undeclared (first use in this function)
idct_altivec.c:642: error: `vy5' undeclared (first use in this function)
idct_altivec.c:642: error: `vy3' undeclared (first use in this function)
idct_altivec.c:642: error: `vy4' undeclared (first use in this function)
idct_altivec.c:642: warning: implicit declaration of function `vec_mergeh'
idct_altivec.c:642: warning: implicit declaration of function `vec_mergel'
idct_altivec.c:642: warning: implicit declaration of function `vec_sra'
idct_altivec.c:649: error: `tmp' undeclared (first use in this function)
idct_altivec.c:649: warning: implicit declaration of function `vec_packsu'
idct_altivec.c:649: warning: implicit declaration of function `vec_ste'
idct_altivec.c:649: error: syntax error before "unsigned"
idct_altivec.c:649: error: syntax error before "unsigned"
idct_altivec.c:649: error: `dest' undeclared (first use in this function)
idct_altivec.c:649: error: `stride' undeclared (first use in this function)
idct_altivec.c:650: error: syntax error before "unsigned"
idct_altivec.c:650: error: syntax error before "unsigned"
idct_altivec.c:651: error: syntax error before "unsigned"
idct_altivec.c:651: error: syntax error before "unsigned"
idct_altivec.c:652: error: syntax error before "unsigned"
idct_altivec.c:652: error: syntax error before "unsigned"
idct_altivec.c:653: error: syntax error before "unsigned"
idct_altivec.c:653: error: syntax error before "unsigned"
idct_altivec.c:654: error: syntax error before "unsigned"
idct_altivec.c:654: error: syntax error before "unsigned"
idct_altivec.c:655: error: syntax error before "unsigned"
idct_altivec.c:655: error: syntax error before "unsigned"
idct_altivec.c:656: error: syntax error before "unsigned"
idct_altivec.c:656: error: syntax error before "unsigned"
idct_altivec.c:657: warning: implicit declaration of function `memset'
idct_altivec.c: At top level:
idct_altivec.c:660: error: syntax error before "signed"
idct_altivec.c:662: warning: no previous prototype for `mpeg2_idct_add_altivec'
idct_altivec.c: In function `mpeg2_idct_add_altivec':
idct_altivec.c:663: error: `vector' undeclared (first use in this function)
idct_altivec.c:663: error: syntax error before "unsigned"
idct_altivec.c:669: error: `c4' undeclared (first use in this function)
idct_altivec.c:669: error: `a0' undeclared (first use in this function)
idct_altivec.c:669: error: `a1' undeclared (first use in this function)
idct_altivec.c:669: error: `a2' undeclared (first use in this function)
idct_altivec.c:669: error: `mc4' undeclared (first use in this function)
idct_altivec.c:669: error: `ma2' undeclared (first use in this function)
idct_altivec.c:669: error: `bias' undeclared (first use in this function)
idct_altivec.c:669: error: syntax error before "signed"
idct_altivec.c:669: error: `zero' undeclared (first use in this function)
idct_altivec.c:669: error: `shift' undeclared (first use in this function)
idct_altivec.c:669: error: `vx0' undeclared (first use in this function)
idct_altivec.c:669: error: `block' undeclared (first use in this function)
idct_altivec.c:669: error: `vx1' undeclared (first use in this function)
idct_altivec.c:669: error: `vx2' undeclared (first use in this function)
idct_altivec.c:669: error: `vx3' undeclared (first use in this function)
idct_altivec.c:669: error: `vx4' undeclared (first use in this function)
idct_altivec.c:669: error: `vx5' undeclared (first use in this function)
idct_altivec.c:669: error: `vx6' undeclared (first use in this function)
idct_altivec.c:669: error: `vx7' undeclared (first use in this function)
idct_altivec.c:669: error: `t1' undeclared (first use in this function)
idct_altivec.c:669: error: `t8' undeclared (first use in this function)
idct_altivec.c:669: error: `t7' undeclared (first use in this function)
idct_altivec.c:669: error: `t3' undeclared (first use in this function)
idct_altivec.c:669: error: `t5' undeclared (first use in this function)
idct_altivec.c:669: error: `t0' undeclared (first use in this function)
idct_altivec.c:669: error: `t2' undeclared (first use in this function)
idct_altivec.c:669: error: `t4' undeclared (first use in this function)
idct_altivec.c:669: error: `t6' undeclared (first use in this function)
idct_altivec.c:669: error: `vy0' undeclared (first use in this function)
idct_altivec.c:669: error: `vy7' undeclared (first use in this function)
idct_altivec.c:669: error: `vy1' undeclared (first use in this function)
idct_altivec.c:669: error: `vy6' undeclared (first use in this function)
idct_altivec.c:669: error: `vy2' undeclared (first use in this function)
idct_altivec.c:669: error: `vy5' undeclared (first use in this function)
idct_altivec.c:669: error: `vy3' undeclared (first use in this function)
idct_altivec.c:669: error: `vy4' undeclared (first use in this function)
idct_altivec.c:671: error: `p0' undeclared (first use in this function)
idct_altivec.c:671: warning: implicit declaration of function `vec_lvsl'
idct_altivec.c:671: error: `dest' undeclared (first use in this function)
idct_altivec.c:672: error: `p1' undeclared (first use in this function)
idct_altivec.c:672: error: `stride' undeclared (first use in this function)
idct_altivec.c:673: error: `p' undeclared (first use in this function)
idct_altivec.c:673: warning: implicit declaration of function `vec_splat_u8'
idct_altivec.c:674: error: `perm0' undeclared (first use in this function)
idct_altivec.c:675: error: `perm1' undeclared (first use in this function)
idct_altivec.c:686: error: `tmp' undeclared (first use in this function)
idct_altivec.c:686: warning: implicit declaration of function `vec_ld'
idct_altivec.c:686: error: `tmp2' undeclared (first use in this function)
idct_altivec.c:686: error: syntax error before "signed"
idct_altivec.c:686: error: `tmp3' undeclared (first use in this function)
idct_altivec.c:686: error: syntax error before "unsigned"
idct_altivec.c:686: error: syntax error before "unsigned"
idct_altivec.c:687: error: syntax error before "signed"
idct_altivec.c:687: error: syntax error before "unsigned"
idct_altivec.c:687: error: syntax error before "unsigned"
idct_altivec.c:688: error: syntax error before "signed"
idct_altivec.c:688: error: syntax error before "unsigned"
idct_altivec.c:688: error: syntax error before "unsigned"
idct_altivec.c:689: error: syntax error before "signed"
idct_altivec.c:689: error: syntax error before "unsigned"
idct_altivec.c:689: error: syntax error before "unsigned"
idct_altivec.c:690: error: syntax error before "signed"
idct_altivec.c:690: error: syntax error before "unsigned"
idct_altivec.c:690: error: syntax error before "unsigned"
idct_altivec.c:691: error: syntax error before "signed"
idct_altivec.c:691: error: syntax error before "unsigned"
idct_altivec.c:691: error: syntax error before "unsigned"
idct_altivec.c:692: error: syntax error before "signed"
idct_altivec.c:692: error: syntax error before "unsigned"
idct_altivec.c:692: error: syntax error before "unsigned"
idct_altivec.c:693: error: syntax error before "signed"
idct_altivec.c:693: error: syntax error before "unsigned"
idct_altivec.c:693: error: syntax error before "unsigned"
make[3]: *** [idct_altivec.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a/src/libmpeg2'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/xine-lib-1_rc4-r1/work/xine-lib-1-rc4a'
make: *** [all] Error 2

!!! ERROR: media-libs/xine-lib-1_rc4-r1 failed.
!!! Function src_compile, Line 122, Exitcode 2
!!! Parallel make failed
---------------------------------------------------

Problem with altivec compatibility.
Same problems with:
CFLAGS="-mcpu=7450 -pipe"
Comment 10 Tuan Van (RETIRED) gentoo-dev 2004-06-22 14:57:47 UTC
A. Smith:
Your bug looks like bug #45393
Please try CFLAGS="-mtune=7450 -pipe"
Comment 11 SpanKY gentoo-dev 2004-06-23 07:30:36 UTC
too many people have posted *unrelated* bugs here

most (if not all) have been reported + fixed elsewhere ... go search bugzilla

as for the original bug here, Robert, please re-open with info relating to whether
this is MAKEOPTS related
Comment 12 Robert Muchacki (RETIRED) gentoo-dev 2004-06-24 12:31:41 UTC
MAKEOPTS="" emerge xine-lib-1_rc4-r1 works fine.