Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54474 - Mouse goes crazy (moves all over the screen and clicks) when I click buttons in XMMS or it changes songs.
Summary: Mouse goes crazy (moves all over the screen and clicks) when I click buttons ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Jeremy Huddleston (RETIRED)
Depends on:
Reported: 2004-06-19 18:28 UTC by Ian Ellis
Modified: 2004-06-28 15:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

cat /proc/interrupts (Interrupts,459 bytes, text/plain)
2004-06-26 23:03 UTC, Ian Ellis

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Ellis 2004-06-19 18:28:52 UTC
When I click on buttons in XMMS or change the song in the playlist, the mouse moves around the screen very quickly and simulates some mouse clicks.  It sometimes does this when I'm using the mouse and XMMS changes songs on its own.  I often have to push buttons on the keyboard to get it back.

Reproducible: Sometimes
Steps to Reproduce:
1.install gentoo-dev-sources and XMMS, may need to do this on an Asus A7N8X-E Deluxe with a mouse on PS/2 (may also need the ATI drivers and such mentioned in Additional Information)
2. Start XMMS and click on some buttons, try paying a few songs.
3. At some point in there the mouse should suddenly move all about and may open/close a few windows.

Actual Results:  
The mouse goes crazy, moves all around, often to the upper-right corner of the
screen.  XMMS does do what it's supposed to, this is just a little "bonus."

Expected Results:  
The program should have performed the operation related to the button push/song
change, but without the mouse craziness.

I didn't have this problem before so I will give some very detailed information
about my system as I don't think it just has to do with XMMS.

I recently changed my motherboard out, switching it from an Asus A7V333 to an
Asus A7N8X-E Deluxe.  At the same time I upgraded my kernel from
gentoo-sources-2.4.25 to gentoo-dev-sources-2.6.5-r1.  I was and still am using
built-in kernel drivers for everything, not genkernel.  I am using on-board
sound (nVidia) with alsa drivers.  Before I was using on-board CMedia sound,
also with alsa drivers.  At the time of this motherboard change/kernel upgrade
is when I began experiencing problems with the mouse.  I reinstalled fresh
thinking that may fix the problem (guess I'm still thinking like a Windoze user)
but it didn't change the problem.

My desktop environment is KDE 3.2.2, using xfree-4.3.0-r5.  However, I also
experienced this problem with xorg-x11-6.7.0.

I am using an ATI Radeon 9500 Pro with the most recent ATI drivers (3.9.0-r1).

I attempted changing the mouse in XF86Config from /dev/mouse to /dev/psaux but
the problem remained.

I do not believe this is a problem with my mouse itself because it doesn't do
this when XMMS is off.  I haven't tried this with a USB mouse.
Comment 1 Jeremy Huddleston (RETIRED) gentoo-dev 2004-06-22 13:49:22 UTC
My guess is that your sound card and the mouse are sharing an IRQ.  Please give me the output of:

cat /proc/interrupts

Please try 'mpg321' or 'zinf' or another media player to see if that causes the same problem.

Please try a USB mouse.

Please see if there is a BIOS upgrade availible for your motherboard.
Comment 2 Ian Ellis 2004-06-26 23:03:38 UTC
Created attachment 34252 [details]
cat /proc/interrupts
Comment 3 Ian Ellis 2004-06-26 23:17:54 UTC
I tried Kplayer and had the same problem.  The mouse moved around and opened a couple terminal windows on its own when I began playing the third song.

I checked for a bios update and I am using the most recent bios version (1008).

I have also upgraded to the most recent gentoo-dev-sources (2.6.7-r6) and updated my XMMS (1.2.10-r5) and the problem still remains.

I tried using my mouse as USB (it's native USB, I just use an adapter that came with it for PS/2) and didn't have a problem.  I would leave it as USB except that for the life of me I can't get the scroll wheel working in that mode.
Comment 4 Jeremy Huddleston (RETIRED) gentoo-dev 2004-06-28 00:12:53 UTC
yeah, it sounds like an IRQ conflict...

Myt advice is to use the USB mouse or edit your BIOS settings to change IRQ assignments or move the sound card to a different PCI slot.

As for getting the mouse wheel to work... you should be able to get some help there in the forums... but here's my mouse section from /etc/X11/xorg.conf (or /etc/X11/XF86Config if you use xfree):

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping" "4 5"

This should work for almost all 3-button wheel mice on USB.
Comment 5 Ian Ellis 2004-06-28 13:47:42 UTC
Okies, thanks for the help.  I had that config in my XF86Config-4 for the mouse.  After a bit of research I found that I needed to enable OHCI HCD support in my kernel to get the scroll wheel to work with USB.  As for the PS/2 problem it seems like nVidia must have some special workaround for that in their Windoze drivers since I never encountered it using this setup in Windoze XP.
Comment 6 Jeremy Huddleston (RETIRED) gentoo-dev 2004-06-28 15:26:11 UTC
hmm... aother guess might be that you have 'Plug And Play OS' set to Yes in bios... that should be set to No so your bios handles the PnP.