Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54454 - bitchx-1.1 fails to compile w/ gcc-3.4
Summary: bitchx-1.1 fails to compile w/ gcc-3.4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Packages in net-irc
Depends on:
Reported: 2004-06-19 14:17 UTC by alexis georges
Modified: 2004-06-29 06:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

portage log for emerge bitchx (2031-bitchx-1.1.log,66.93 KB, text/plain)
2004-06-19 14:18 UTC, alexis georges

Note You need to log in before you can comment on or make changes to this bug.
Description alexis georges 2004-06-19 14:17:03 UTC
Tried compiling bitchx-1.1 but emerge fails. i attached the whole log (from portage) which contains everything up to the error..
i am running with ~amd64, although amd64 gives the same thing..the gcc version is 3.4..
i tried setting CFLAGS="" but the same thing happens

Reproducible: Always
Steps to Reproduce:
Comment 1 alexis georges 2004-06-19 14:18:08 UTC
Created attachment 33588 [details]
portage log for emerge bitchx
Comment 2 Sven Wegener gentoo-dev 2004-06-19 14:43:55 UTC
This is gcc-3.4 related bug, it also fails to compile on x86.

I'll take care of this.
Comment 3 Sven Wegener gentoo-dev 2004-06-19 15:04:30 UTC
I just commited a fix for this to CVS. Should be on your local rsync mirror
in about one hour. Please resync, try again and report back. Thanks.
Comment 4 alexis georges 2004-06-19 15:43:28 UTC
yes, this time it compiled successfully with your patch
thanks a lot
Comment 5 Sven Wegener gentoo-dev 2004-06-19 15:51:59 UTC