Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 543824 - gcc-4.8 with gold fails to build: version `GLIBCXX_3.4.20' not found
Summary: gcc-4.8 with gold fails to build: version `GLIBCXX_3.4.20' not found
Status: RESOLVED DUPLICATE of bug 357173
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-19 21:43 UTC by xpue
Modified: 2015-05-12 12:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (gcc_build.log.gz,96.27 KB, application/gzip)
2015-03-19 21:44 UTC, xpue
Details
emerge --info (emerge_info.txt,3.90 KB, text/plain)
2015-03-19 21:45 UTC, xpue
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xpue 2015-03-19 21:43:52 UTC
gcc-4.8 with gold fails to build: version `GLIBCXX_3.4.20' not found

Reproducible: Always
Comment 1 xpue 2015-03-19 21:44:48 UTC
Created attachment 399278 [details]
build.log.gz
Comment 2 xpue 2015-03-19 21:45:12 UTC
Created attachment 399280 [details]
emerge --info
Comment 3 SpanKY gentoo-dev 2015-03-26 04:41:57 UTC
pretty sure the underlying issue is the same as the existing oldie

when i hacked this locally, simply changing the rpath var in the build made it work.  but i haven't unwound the mess to see exactly how it plays out in the build.  i'm afraid the bootstrap is relying on the implicit LD_LIBRARY_PATH lookup ...

*** This bug has been marked as a duplicate of bug 357173 ***