Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54342 - [TRACKER] beep-media-player works with xmms-* plugins
Summary: [TRACKER] beep-media-player works with xmms-* plugins
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords: Tracker
: 63162 68772 (view as bug list)
Depends on: 54709 66832 67888
Blocks:
  Show dependency tree
 
Reported: 2004-06-18 11:04 UTC by Marcin Kryczek (RETIRED)
Modified: 2017-01-19 18:46 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
beep-media-player-0.9.6.1-r1.patch (beep-media-player-0.9.6.1-r1.patch,427 bytes, patch)
2004-06-18 11:06 UTC, Marcin Kryczek (RETIRED)
Details | Diff
beep-media-player-0.9.7.ebuild (beep-media-player-0.9.7.ebuild,2.27 KB, text/plain)
2004-06-18 11:08 UTC, Marcin Kryczek (RETIRED)
Details
xmms-shell-0.99.3-r3.patch (xmms-shell-0.99.3-r3.patch,751 bytes, patch)
2004-06-18 11:09 UTC, Marcin Kryczek (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Kryczek (RETIRED) gentoo-dev 2004-06-18 11:04:51 UTC
beep-media-player has API from xmms, so it can make use from xmms-* plugins (well - i'm not sure if all plugins will work). usually the simple changes are enought to port plugin for bmp. i've already made port of xmms-shell (in attachment). unfortunatly bmp in version 0.9.6-r1 makes some strange stuff with it's includes (it keeps includes in 2 separate directories. update for 0.9.7 or attached patch for 0.9.6-r1 ebuild is needed).
i can port more (maybe even all) plugins for bmp, but i need feedback from developers. please - look at patch for xmms-shell and tell me what do you think about using 'xmms' USE flag in such context?
Comment 1 Marcin Kryczek (RETIRED) gentoo-dev 2004-06-18 11:06:49 UTC
Created attachment 33510 [details, diff]
beep-media-player-0.9.6.1-r1.patch

patch for adding symlinks to correct directory
Comment 2 Marcin Kryczek (RETIRED) gentoo-dev 2004-06-18 11:08:11 UTC
Created attachment 33511 [details]
beep-media-player-0.9.7.ebuild

new version of bmp (previous patch not needed here, since it's already fixed)
Comment 3 Marcin Kryczek (RETIRED) gentoo-dev 2004-06-18 11:09:25 UTC
Created attachment 33512 [details, diff]
xmms-shell-0.99.3-r3.patch

patch for xmms-shell ebuild to support beep-media-player if USE="-xmms" is set
Comment 4 Marcin Kryczek (RETIRED) gentoo-dev 2004-06-18 11:14:00 UTC
by mistake i've posted reversed patches;/ sorry about that
just change all '+' to '-' and '-' to '+' or patch with -R instead of -N;>
Comment 5 Jeremy Huddleston (RETIRED) gentoo-dev 2004-06-18 11:31:38 UTC
Not all the xmms-* plugins actually work with beep... this has been something that has been worrying me for a while now... I'd like to have a virtual/xmms that beep, xmms, and noxmms satisfy, but not all plugins work with all of them...
Comment 6 Marcin Kryczek (RETIRED) gentoo-dev 2004-06-19 06:22:25 UTC
hmm - but something surelly has to be done here. i'm going to use BMP but i want few plugins. virtual isn't good idea, since i've noticed, that this xmms-shell compiled with BMP's headers cousing segm. fault with xmms. maybe create some common headers for all three players? do you think it's possible?
another idea is to add 'bmp' and 'noxmms' in global USE flags and port those plugins, which can works with bmp and noxxms. but it'll couse terrible mess in these packages (propably it would be impossible to compile one plugins to work with more than one of that packages)
Comment 7 Giacomo Perale 2004-06-21 08:17:23 UTC
http://forums.gentoo.org/viewtopic.php?t=179921&highlight=

a few weeks ago I modified the old ebuilds to reflect changes in CVS since january... maybe they can be useful, cause I see that some of the configure options and USE in the old ebuild now aren't supported.

AFAIK developers have changed some of the include files, so xmms plugins doesn't compile against beep media player, even if beep can use them with a few problems (for example, viewing properties of musepack files crashes the program). Maybe it would be desirable to ask beep developers what are they planning.
Comment 8 Jeremy Huddleston (RETIRED) gentoo-dev 2004-09-12 22:11:05 UTC
*** Bug 63162 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Huddleston (RETIRED) gentoo-dev 2004-09-24 11:47:06 UTC
I think we should have an xmms-plugin eclass which handles two options... one is simply patching the source code of an xmms plugin to work for bmp (xmms-config -> bmp-config where found) and the other is having two source tarballs... one for xmms and the other for bmp...

then based on the 'xmms' and 'bmp' USE flags being set, we can build the desired plugin...
Comment 10 Jeremy Huddleston (RETIRED) gentoo-dev 2004-10-19 14:17:29 UTC
I'm working on this eclass now.
Comment 11 Jeremy Huddleston (RETIRED) gentoo-dev 2004-10-19 16:08:39 UTC
Ok, I've added an initial version of xmms-plugins.eclass to portage and converted xmms-jack-0.10.ebuild to use it.  It adds a 'bmp' USE flag and uses the 'xmms' and 'bmp' use flags to determine which versions get built.  So far, I haven't tested out the separate tarball or patching options, but it should work.  Please try modifying the xmms-* plugin ebuilds to use this new eclass.
Comment 12 Jeremy Huddleston (RETIRED) gentoo-dev 2004-10-24 23:59:07 UTC
*** Bug 68772 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-11 13:43:20 UTC
the eclass thing didn't work very well, so I'm gonna let chainsaw handle adding the bmp plugins...
Comment 14 Tony Vroon gentoo-dev 2004-11-14 06:20:57 UTC
I feel we have done all we can to unite XMMS and BMP plugins. It is not working out, so I suggest we do plugins separately.
A separate BMP and XMMS ebuild for every plugin. In the past week, quite a number of BMP plugins have been committed to CVS, so BMP should become more and more usable. Some plugins have been found defective, I am in contact with their authors in order to get it fixed.

I am closing this bug, we can't unite XMMS and BMP, plugin-wise. Sorry.