Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 543290 - sys-apps/portage: unable to install systemd because of udev related blockers (emerge -uDN @world solves it though)
Summary: sys-apps/portage: unable to install systemd because of udev related blockers ...
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
Depends on:
Blocks: 300071
  Show dependency tree
Reported: 2015-03-14 11:15 UTC by Pacho Ramos
Modified: 2015-10-12 17:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2015-03-14 11:15:12 UTC
My world file is simply:

But portage is still unable to install systemd and, then, remove udev:
# emerge -1av =sys-apps/systemd-216-r4

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] dev-libs/vala-common-0.26.2::gentoo  2,620 KiB
[ebuild  N     ] app-arch/zip-3.0-r1::gentoo  USE="bzip2 crypt unicode -natspec" 0 KiB
[ebuild  N     ] media-libs/libmng-2.0.2-r1:0/2::gentoo  USE="lcms -static-libs" 0 KiB
[ebuild  N     ] sys-devel/bc-1.06.95::gentoo  USE="readline -libedit -static" 0 KiB
[ebuild  N     ] x11-themes/hicolor-icon-theme-0.12::gentoo  0 KiB
[ebuild  N     ] app-admin/eselect-qtgraphicssystem-1.1.1::gentoo  0 KiB
[ebuild  N     ] dev-perl/XML-NamespaceSupport-1.110.0-r1::gentoo  0 KiB
[ebuild  N     ] dev-perl/XML-SAX-Base-1.80.0-r1::gentoo  0 KiB
[ebuild  N     ] app-text/qpdf-5.1.1:0/13::gentoo  USE="-doc -examples -static-libs {-test}" 0 KiB
[ebuild  N     ] virtual/perl-Storable-2.490.0::gentoo  0 KiB
[ebuild  N     ] dev-perl/File-BaseDir-0.30.0-r1::gentoo  USE="{-test}" 0 KiB
[ebuild  N     ] dev-perl/File-DesktopEntry-0.40.0-r1::gentoo  USE="{-test}" 0 KiB
[ebuild  N     ] dev-perl/XML-SAX-0.990.0-r1::gentoo  0 KiB
[ebuild  N     ] dev-perl/XML-LibXML-2.1.400-r1::gentoo  USE="{-test}" 0 KiB
[ebuild  NS    ] app-text/docbook-xml-dtd-4.4-r2:4.4::gentoo [4.1.2-r6:4.1.2::gentoo, 4.5-r1:4.5::gentoo] 0 KiB
[ebuild  NS    ] app-text/docbook-xml-dtd-4.2-r2:4.2::gentoo [4.1.2-r6:4.1.2::gentoo, 4.5-r1:4.5::gentoo] 0 KiB
[ebuild  N     ] dev-perl/XML-Simple-2.200.0-r1::gentoo  0 KiB
[ebuild  N     ] app-text/xmlto-0.0.26::gentoo  USE="-latex" 0 KiB
[ebuild  N     ] x11-misc/icon-naming-utils-0.8.90::gentoo  0 KiB
[ebuild     U ~] dev-libs/glib-2.42.2:2::gentoo [2.40.2:2::gentoo] USE="dbus%* (mime) -debug (-fam) (-selinux) -static-libs (-systemtap) {-test} -utils -xattr" PYTHON_TARGETS="python2_7" 6,839 KiB
[ebuild  N    ~] dev-util/gdbus-codegen-2.42.2::gentoo  PYTHON_TARGETS="python2_7 python3_4 -python3_3" 0 KiB
[ebuild  N     ] dev-lang/spidermonkey-17.0.0-r3:17::gentoo  USE="-debug -jit -minimal -static-libs {-test}" 0 KiB
[ebuild  N     ] dev-libs/libcroco-0.6.8-r1:0.6::gentoo  USE="{-test}" 0 KiB
[ebuild  N     ] x11-libs/libXtst-1.2.2::gentoo  USE="-doc -static-libs" 0 KiB
[ebuild  N     ] x11-libs/libXv-1.0.10::gentoo  USE="-static-libs" 0 KiB
[ebuild  N     ] dev-perl/File-MimeInfo-0.210.0::gentoo  USE="{-test}" 0 KiB
[ebuild  N     ] x11-apps/xprop-1.2.2::gentoo  0 KiB
[ebuild  N     ] dev-util/desktop-file-utils-0.22::gentoo  USE="-emacs" 0 KiB
[ebuild  N     ] x11-apps/xset-1.2.3::gentoo  0 KiB
[ebuild  N     ] sys-libs/gpm-1.20.7-r2::gentoo  USE="(-selinux) -static-libs" 0 KiB
[ebuild  N     ] www-client/links-2.8-r1:2::gentoo  USE="X bzip2 gpm ipv6 jpeg ssl tiff unicode zlib -directfb -fbcon -livecd -lzma (-suid) (-svga)" 0 KiB
[ebuild  N     ] x11-misc/xdg-utils-1.1.0_rc2::gentoo  USE="perl -doc" 0 KiB
[ebuild  N    ~] gnome-base/librsvg-2.40.8:2::gentoo  USE="introspection -tools -vala" 504 KiB
[ebuild  N    ~] x11-themes/adwaita-icon-theme-3.14.1::gentoo  USE="branding" 17,170 KiB
[ebuild  N    ~] sys-apps/systemd-216-r4:0/2::gentoo  USE="acl firmware-loader gudev introspection kmod pam policykit ssl (-apparmor) -audit -cryptsetup -curl -doc -elfutils -gcrypt -http -idn (-kdbus) -lz4 -lzma -python -qrcode (-seccomp) (-selinux) -sysv-utils {-test} -vanilla" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3" 0 KiB
[ebuild  N     ] sys-apps/dbus-1.8.16::gentoo  USE="X systemd -debug -doc (-selinux) -static-libs {-test}" 0 KiB
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4::gentoo  0 KiB
[ebuild  N     ] sys-auth/polkit-0.112-r2::gentoo  USE="gtk introspection nls pam systemd -examples -jit -kde (-selinux)" 0 KiB
[ebuild  N     ] virtual/libgudev-215-r1::gentoo  USE="introspection systemd (-static-libs)" 0 KiB
[ebuild  N    ~] app-accessibility/at-spi2-core-2.14.1:2::gentoo  USE="X introspection" 446 KiB
[ebuild  N    ~] app-accessibility/at-spi2-atk-2.14.1:2::gentoo  USE="{-test}" 275 KiB
[ebuild  N     ] dev-qt/qtcore-4.8.5-r2:4::gentoo  USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" 0 KiB
[ebuild  N     ] dev-qt/qtscript-4.8.5:4::gentoo  USE="exceptions iconv (-aqua) -debug (-jit) -pch" 0 KiB
[ebuild  N     ] dev-qt/qtsql-4.8.5:4::gentoo  USE="exceptions qt3support sqlite (-aqua) -debug (-firebird) -freetds -mysql (-oci8) -odbc -pch -postgres" 0 KiB
[ebuild  N     ] dev-libs/libusb-1.0.19:1::gentoo  USE="udev -debug -doc -examples -static-libs {-test}" 0 KiB
[ebuild  N     ] virtual/libusb-1-r1:1::gentoo  USE="udev" 0 KiB
[ebuild  N    ~] dev-libs/libgusb-0.2.4::gentoo  USE="introspection -static-libs -vala" 268 KiB
[ebuild  N    ~] x11-misc/colord-1.2.9:0/2::gentoo  USE="gusb introspection policykit systemd udev (-argyllcms) -examples (-extra-print-profiles) -scanner -vala" 1,173 KiB
[ebuild  N     ] net-print/cups-2.0.1-r1::gentoo  USE="X acl dbus pam ssl systemd threads usb -debug -java -kerberos -lprng-compat -python (-selinux) -static-libs -xinetd -zeroconf" LINGUAS="-es" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ] dev-qt/qtgui-4.8.5-r3:4::gentoo  USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" 0 KiB
[ebuild  N     ] app-text/poppler-0.26.5:0/46::gentoo  USE="cairo cxx introspection jpeg lcms png qt4 tiff utils -cjk -curl -debug -doc -jpeg2k (-qt5)" 0 KiB
[ebuild  N     ] net-print/cups-filters-1.0.53::gentoo  USE="dbus foomatic jpeg png tiff -perl -static-libs -zeroconf" 0 KiB
[ebuild  N     ] dev-qt/qt3support-4.8.5:4::gentoo  USE="accessibility exceptions (-aqua) -debug -pch" 0 KiB
[ebuild  NS   ~] x11-libs/gtk+-3.14.9:3::gentoo [2.24.25:2::gentoo] USE="X colord cups introspection (-aqua) -broadway -cloudprint -debug -examples {-test} -vim-syntax (-wayland) -xinerama" 15,349 KiB
[ebuild  N    ~] gnome-base/dconf-0.22.0::gentoo  USE="X {-test}" 385 KiB
[ebuild  N     ] gnome-extra/polkit-gnome-0.105::gentoo  0 KiB
[ebuild   R    ] app-text/ghostscript-gpl-9.10-r2::gentoo  USE="X* cups* dbus* gtk* -bindist -djvu -idn -static-libs" LINGUAS="-de -ja -ko -zh_CN -zh_TW" 0 KiB
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-216-r4, sys-apps/gentoo-systemd-integration-4)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-216)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-216)

Total: 57 packages (1 upgrade, 52 new, 3 in new slots, 1 reinstall), Size of downloads: 45,025 KiB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-216:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-208-r1 required by (virtual/udev-215:0/0::gentoo, installed)
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_ppc_32(-)]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)

  (sys-apps/systemd-216-r4:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd:0= required by (sys-apps/dbus-1.8.16:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44:0= required by (x11-misc/colord-1.2.9:0/2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?] (>=sys-apps/systemd-212-r5:0/2[abi_ppc_32(-),gudev,introspection]) required by (virtual/libgudev-215-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0= required by (sys-auth/polkit-0.112-r2:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (net-print/cups-2.0.1-r1:0/0::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

!!! The following installed packages are masked:
- sys-fs/udev-216::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

# emerge --info
Portage 2.2.18 (python 2.7.9-final-0, default/linux/powerpc/ppc32/13.0/desktop/gnome/systemd, gcc-4.8.3, glibc-2.19-r1, 3.12.20-gentoo ppc64)
System uname: Linux-3.12.20-gentoo-ppc64-POWER7_-architected-with-gentoo-2.2
KiB Mem:    16514732 total,   6328420 free
KiB Swap:    7814548 total,   7799112 free
Timestamp of repository gentoo: Sat, 14 Mar 2015 10:00:01 +0000
sh bash 4.2_p53
ld GNU ld (Gentoo 2.24 p1.4) 2.24
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p53::gentoo
dev-lang/perl:            5.20.1-r4::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.4.1::gentoo
dev-util/ccache:          3.1.9-r4::gentoo
dev-util/pkgconfig:       0.28-r1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.9::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.4::gentoo
sys-devel/make:           4.0-r1::gentoo
sys-kernel/linux-headers: 3.16::gentoo (virtual/os-headers)
sys-libs/glibc:           2.19-r1::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-O2 -mcpu=powerpc -mtune=powerpc -pipe -fno-stack-protector"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mcpu=powerpc -mtune=powerpc -pipe -fno-stack-protector"
EMERGE_DEFAULT_OPTS="--quiet-build=n --autounmask-write --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv introspection ipv6 jpeg lcms ldap libav libnotify libsecret mad mng modules mp3 mp4 mpeg nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppc ppds pulseaudio qt3support qt4 readline sdl session socialweb spell ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_PPC="32" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint mach64 mga nv r128 radeon savage tdfx trident dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Zac Medico gentoo-dev 2015-03-14 16:44:15 UTC
The virtual/udev dependencies look like this:

RDEPEND="!systemd? ( || ( >=sys-fs/udev-208-r1 >=sys-fs/eudev-1.3 ) ) systemd? ( >=sys-apps/systemd-208:0 )"

Therefore, you need to rebuild virtual/udev with USE="system" enabled. If you enable the systemd USE flag, then if 'emerge 1av systemd' doesn't solve automatically, you might try this instead:

   emerge -1av virtual/udev systemd
Comment 2 Pacho Ramos gentoo-dev 2015-03-14 16:54:20 UTC
Yeah, it does work (adding virtual/libudev to rebuild too). But I am sure this wasn't needed in the past... I remember "emerge systemd" was enough if udev wasn't in world file :|

Maybe something changed when virtuals started to play with USE flags or similar :/

Isn't there a way to let portage rebuild it? I have tried also "emerge -N systemd" but it wasn't smart enough to try to update the USE for the udev virtuals pulled in the build 

Thanks for your help :)
Comment 3 Zac Medico gentoo-dev 2015-03-14 17:09:43 UTC
(In reply to Pacho Ramos from comment #2)
> Isn't there a way to let portage rebuild it? I have tried also "emerge -N
> systemd" but it wasn't smart enough to try to update the USE for the udev
> virtuals pulled in the build 

If you have USE=systemd enabled, then 'emerge -uDN @world' might solve it.
Comment 4 Pacho Ramos gentoo-dev 2015-03-14 17:21:36 UTC
Ah, indeed, it works ok with full world set :D
Comment 5 Zac Medico gentoo-dev 2015-03-14 17:32:59 UTC

*** This bug has been marked as a duplicate of bug 290818 ***
Comment 6 Zac Medico gentoo-dev 2015-03-14 17:34:33 UTC
This isn't quite the same as bug 290818, but it's closely related.
Comment 7 Pacho Ramos gentoo-dev 2015-03-14 17:42:33 UTC
yeah, in this case it is not about missing "updates", but missing rebuilds of the same versions with the new USEs
Comment 8 Zac Medico gentoo-dev 2015-10-12 17:00:40 UTC
*** Bug 558936 has been marked as a duplicate of this bug. ***