Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 542820 - sys-libs/ntdb: reassess possibly unneeded samba block
Summary: sys-libs/ntdb: reassess possibly unneeded samba block
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 4 votes (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
Depends on: 683926
Blocks:
  Show dependency tree
 
Reported: 2015-03-10 14:00 UTC by Tomáš Chaloupka
Modified: 2019-05-28 13:30 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chaloupka 2015-03-10 14:00:49 UTC
Samba depends on: >=sys-libs/ntdb-1.0
and ntdb depends on: !!<net-fs/samba-4.1.7

which means that samba-4.1.17 cannot be installed due to hard block

Reproducible: Always
Comment 1 Ben Kohler gentoo-dev 2015-03-10 14:04:49 UTC
If you unmerge your currently-installed samba-3.x then you can continue and get samba-4.1.17... though I'm not yet certain that this needs to be a hard blocker as it is now.  It certainly makes the upgrade path a bit ugly.

Can the maintainer confirm that samba-3 REALLY must not exist on the system when ntdb is built?
Comment 2 raffaele_at_gentoo 2015-03-18 08:53:25 UTC
I don't think I have samba-3 and still get the block:

[ebuild  N     ] sys-libs/ntdb-1.0-r1::gentoo  USE="python" PYTHON_TARGETS="python2_7" 776 KiB
[ebuild     U  ] net-fs/samba-4.1.17::gentoo [4.0.25::gentoo] USE="client cups fam -acl -addns -ads -aio -avahi -cluster -dmapi -gnutls -iprint -ldap -quota (-selinux) -syslog -systemd% {-test} -winbind (-swat%)" PYTHON_TARGETS="python2_7" 19,079 KiB
[blocks B      ] <net-fs/samba-4.1.7 ("<net-fs/samba-4.1.7" is hard blocking sys-libs/ntdb-1.0-r1)
Comment 3 Ben Kohler gentoo-dev 2015-03-18 15:04:37 UTC
Replace "samba-3" with "any samba older than 4.1.7" in my previous comments
Comment 4 Olliver Schinagl 2015-03-29 15:08:59 UTC
Samba gets pulled in as a dependancy, I have emerge -C'ed both samba and ntdb, yet samba fails to install due to the blocker? Kind of confusing as to how to fix it.
Comment 5 Olliver Schinagl 2015-03-29 16:59:41 UTC
manually installing with -1 ntdb followed by samba seems to work.
Comment 6 Leonid Kopylov 2015-11-14 16:32:53 UTC
Same here
Comment 7 Jonas Stein gentoo-dev 2016-03-31 11:24:33 UTC
I can confirm that the suggestion by Olliver Schinagl worked for me and hope this workaround can help others too until we have a better solution.

emerge -C net-fs/samba 
# removes net-fs/samba-3.6.25

emerge net-fs/samba
# installs net-fs/samba-4.2.9
Comment 8 Matthew Marchese Gentoo Infrastructure gentoo-dev 2016-03-31 19:49:10 UTC
Same issue for me with Samba 3.6.25 installed. emerge -1a ntdb simply results in a failed emerge (ntdb-1.0-r1 will not install when Samba is <net-fs/samba-4.1.7).

The following worked for me:

emerge -C net-fs/samba 
# removes net-fs/samba-3.6.25

emerge net-fs/samba
# installs net-fs/samba-4.2.9
Comment 9 Ben Kohler gentoo-dev 2016-04-05 20:48:49 UTC
Samba team: is there a real reason for this hard blocker?  Is there a reason samba-3 cannot be installed at the time ntdb is built/installed?  I "softened" the blocker on a test box from !! to !, so it can autoresolve, and I saw no noticeable problems.

Either there is a specific reason for the hard block and we can close this bug INVALID, or there is no reason and the blocker should be softened so that manual unmerging isn't required.

Thanks!
Comment 10 Rick Farina (Zero_Chaos) gentoo-dev 2016-04-07 16:41:28 UTC
with permission from PolyC and no arguments from the rest of the team I have softened the blocker to allow portage to auto-resolve.

Seems pretty odd to block on old versions of samba but not actually dep on samba.

I installed ntdb no problem with samba 3.6.25 installed.  This blocker doesn't appear necessary at all honestly, might want to check it out and tighten it down or drop it.
Comment 11 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-05-28 13:30:33 UTC
Package removed.