Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 542780 - dev-qt/qtcore-4.8.6-r1: fails to build on arm7a musl hardened
Summary: dev-qt/qtcore-4.8.6-r1: fails to build on arm7a musl hardened
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: musl-porting
  Show dependency tree
 
Reported: 2015-03-10 05:53 UTC by Michael Jones
Modified: 2015-04-22 20:25 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (build.log.gz,27.88 KB, application/x-targz)
2015-03-10 05:53 UTC, Michael Jones
Details
Patch for qt4-build.eclass (qt4-build.patch,548 bytes, patch)
2015-04-22 19:44 UTC, Felix Janda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Jones 2015-03-10 05:53:07 UTC
This should be assigned to blueness@gentoo.org
	CC: embedded@gentoo.org, hardened@gentoo.org

as per http://distfiles.gentoo.org/experimental/arm/musl/HOWTO

Reproducible: Always
Comment 1 Michael Jones 2015-03-10 05:53:29 UTC
Created attachment 398566 [details]
build.log.gz
Comment 2 Michael Jones 2015-03-10 05:54:53 UTC
Apologizes for not being able to provide a patch. Hopefully I'll have a chance to look into it in more detail in the next several days.
Comment 3 Felix Janda 2015-04-22 19:44:47 UTC
Created attachment 401832 [details, diff]
Patch for qt4-build.eclass

The build failure is caused by qt4-build injecting -liconv into LIBS
although on the musl profiles we don't have -liconv (musl itself has
an implementation).
Comment 4 Davide Pesavento gentoo-dev 2015-04-22 19:55:19 UTC
qtcore-4.8.6-r1 uses qt4-build-multilib, not qt4-build.

Anyway, I already removed the offending chunk of code from qt4-build-multilib in the qt overlay a few days ago:

https://gitweb.gentoo.org/proj/qt.git/commit/?id=6a666f95d25eb75c651033f50c27dbc6da343b53

will move to gx86 soon...
Comment 5 Davide Pesavento gentoo-dev 2015-04-22 20:25:32 UTC
Done.

  22 Apr 2015; Davide Pesavento <pesa@gentoo.org> qt4-build-multilib.eclass:
  Sync with qt overlay: cleanup prefix-related patching and fix bug #542780.