Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 540032 - net-analyzer/netselect with sys-libs/musl - patch removes <sys/types.h> include - netselect.c:819:7: error: unknown type name ‘u_char’
Summary: net-analyzer/netselect with sys-libs/musl - patch removes <sys/types.h> inclu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: musl-porting
  Show dependency tree
 
Reported: 2015-02-14 04:50 UTC by James Taylor
Modified: 2015-02-14 07:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Taylor 2015-02-14 04:50:23 UTC
net-analyzer/netselect fails to build under sys-libs/musl due to netselect-0.3-bsd.patch not including the <sys/types.h> include under the "#ifdef _ifdef_, which leads to build failures.

Steps to reproduce:
Attempt to emerge net-analyer/netselect under a fresh musl stage3

Expected results:
netselect compiles

Actual results:
compilation fails due to undefined types

netselect.c:819:7: error: unknown type name ‘u_char’
       u_char * buf, int cc,

etc etc
Comment 1 James Taylor 2015-02-14 04:51:32 UTC
Didn't notice my typo:

I added the <sys/types.h> include under the #ifdef __linux__ block which fixed my compilation issues
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-14 07:34:37 UTC
That's odd. It does.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-14 07:46:17 UTC
I fixed the patch which is applied in -r3 but added an -r4 as well.