Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 539840 - media-video/vlc USE=opengl requires USE=xcb
Summary: media-video/vlc USE=opengl requires USE=xcb
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Nick Andrade
URL: https://trac.videolan.org/vlc/ticket/...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-12 03:05 UTC by xpue
Modified: 2015-04-21 03:14 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (vlc_build.log.gz,100.26 KB, application/gzip)
2015-02-12 03:07 UTC, xpue
Details
vlc_debug_opengl_enabled_xcb_enabled.log (vlc_opengl_xcb.log,42.61 KB, text/plain)
2015-04-18 07:51 UTC, Nick Andrade
Details
vlc_debug_opengl_enabled_xcb_disabled.log (vlc_opengl_no_xcb.log,36.81 KB, text/plain)
2015-04-18 07:52 UTC, Nick Andrade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xpue 2015-02-12 03:05:38 UTC
Otherwise there's no opengl video output in video output modules.

Reproducible: Always
Comment 1 xpue 2015-02-12 03:07:19 UTC
Created attachment 396224 [details]
build.log.gz
Comment 2 Nick Andrade 2015-04-18 07:51:04 UTC
Created attachment 401526 [details]
vlc_debug_opengl_enabled_xcb_enabled.log

Confirmed bug.

Log from playing video with both opengl & xcb enabled.  Video plays fine.

Tested with mp4 sample from: http://techslides.com/sample-webm-ogg-and-mp4-video-files-for-html5
Comment 3 Nick Andrade 2015-04-18 07:52:52 UTC
Created attachment 401528 [details]
vlc_debug_opengl_enabled_xcb_disabled.log

VLC debug log from attempting to play same sample video as previous comment with opengl enabled and xcb disabled.

Both were tested under 2.2.1.  

So far I can't find a relevant bug upstream and will report this behavior
Comment 4 Ian Delaney (RETIRED) gentoo-dev 2015-04-19 01:47:18 UTC
From reading the bug report @ URL:, I would be prompting them to reopen the bug, however it's a tough lesson about getting the correct info set outlined in the first place.  It's 50 50 % chance whether upstream devs will even re-visit the bug. Generally they do, in my exp., even if only to re-assert their initial opinion.
Comment 5 Nick Andrade 2015-04-19 03:18:03 UTC
Yeah, definitely.  At the very least this has taught me to pay more attention to the QA notice which clearly calls out that --enable-glx isn't used by configure.  I will try posting in their forums as well to try and get more info.
Comment 6 Ian Delaney (RETIRED) gentoo-dev 2015-04-20 05:30:32 UTC
  20 Apr 2015; Ian Delaney <idella4@gentoo.org> vlc-2.2.0.ebuild,
  vlc-2.2.9999.ebuild:
  drop 'use_enable opengl glx' due to option --enable-glx made defunct, adresses
  Bug #539840
Comment 7 Mike Gilbert gentoo-dev 2015-04-20 17:34:35 UTC
+  20 Apr 2015; Mike Gilbert <floppym@gentoo.org> vlc-2.2.1.ebuild,
+  vlc-9999.ebuild:
+  Drop glx flag here as well.
Comment 8 Ian Delaney (RETIRED) gentoo-dev 2015-04-21 03:14:24 UTC
I was intending on doing it later, but fine.  The commit is 'correct'. New proxy maintainer (and I) hadn't quite got that far yet.