Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 539490 - mirror.datapipe.net is not up to date
Summary: mirror.datapipe.net is not up to date
Status: RESOLVED CANTFIX
Alias: None
Product: Mirrors
Classification: Unclassified
Component: Server Problem (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mirror Admins
URL: ftp://mirror.datapipe.net/gentoo/dist...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-09 17:33 UTC by Christophe PEREZ
Modified: 2015-02-10 20:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe PEREZ 2015-02-09 17:33:40 UTC
impossible to update firefox :
# emerge -DauN world

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] www-client/firefox-31.4.0 [31.3.0]

Would you like to merge these packages? [Yes/No] 

>>> Verifying ebuild manifests
>>> Running pre-merge checks for www-client/firefox-31.4.0
 * Checking for at least 4 GiB disk space at "/other/tmp/portage/www-client/firefox-31.4.0/t [ ok ].

>>> Emerging (1 of 1) www-client/firefox-31.4.0::gentoo
>>> Downloading 'http://mirror.datapipe.net/gentoo/distfiles/firefox-31.4.0esr-fr.xpi'
--2015-02-09 13:28:33--  http://mirror.datapipe.net/gentoo/distfiles/firefox-31.4.0esr-fr.xpi
Resolving mirror.datapipe.net... 64.27.65.115
Connecting to mirror.datapipe.net|64.27.65.115|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-02-09 13:28:33 ERROR 404: Not Found.

>>> Downloading 'ftp://mirror.datapipe.net/gentoo/distfiles/firefox-31.4.0esr-fr.xpi'
pathconf: Permission denied
--2015-02-09 13:28:33--  ftp://mirror.datapipe.net/gentoo/distfiles/firefox-31.4.0esr-fr.xpi
           => '/download/Linux/gentoo/portage/firefox-31.4.0esr-fr.xpi'
Resolving mirror.datapipe.net... 64.27.65.115
Connecting to mirror.datapipe.net|64.27.65.115|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /gentoo/distfiles ... done.
==> SIZE firefox-31.4.0esr-fr.xpi ... done.

==> PASV ... couldn't connect to 64.27.65.115 port 30220: Connection refused
>>> Downloading 'http://mirror.jamit.de/gentoo/distfiles/firefox-31.4.0esr-fr.xpi'
--2015-02-09 13:28:34--  http://mirror.jamit.de/gentoo/distfiles/firefox-31.4.0esr-fr.xpi
Resolving mirror.jamit.de... failed: Unknown host.
wget: unable to resolve host address 'mirror.jamit.de'
>>> Downloading 'http://pinguin.ittelkom.ac.id/mirror/gentoo/distfiles/firefox-31.4.0esr-fr.xpi'
--2015-02-09 13:28:34--  http://pinguin.ittelkom.ac.id/mirror/gentoo/distfiles/firefox-31.4.0esr-fr.xpi
Resolving pinguin.ittelkom.ac.id... failed: Unknown host.
wget: unable to resolve host address 'pinguin.ittelkom.ac.id'
>>> Downloading 'ftp://ftp.mozilla.org/pub/firefox/releases//31.4.0esr/linux-i686/xpi/fr.xpi'
pathconf: Permission denied
--2015-02-09 13:28:35--  ftp://ftp.mozilla.org/pub/firefox/releases//31.4.0esr/linux-i686/xpi/fr.xpi
           => '/download/Linux/gentoo/portage/firefox-31.4.0esr-fr.xpi'
Resolving ftp.mozilla.org... 63.245.215.56, 63.245.215.46
Connecting to ftp.mozilla.org|63.245.215.56|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /pub/firefox/releases//31.4.0esr/linux-i686/xpi ... done.
==> SIZE fr.xpi ... 406462
==> PASV ... couldn't connect to 63.245.215.56 port 52238: Connection refused
!!! Couldn't download 'firefox-31.4.0esr-fr.xpi'. Aborting.
 * Fetch failed for 'www-client/firefox-31.4.0', Log file:
 *  '/var/log/portage/www-client:firefox-31.4.0:20150209-172832.log'


# emerge --info firefox
Portage 2.2.14 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.3, glibc-2.19-r1, 3.17.8-gentoo-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.17.8-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q8200_@_2.33GHz-with-gentoo-2.2
KiB Mem:     3081524 total,   1865264 free
KiB Swap:    4192896 total,   3937212 free
Timestamp of tree: Mon, 09 Feb 2015 15:30:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1
dev-util/ccache:          3.1.9-r4
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.9
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/download/Linux/gentoo/portage"
EMERGE_DEFAULT_OPTS="--with-bdeps y --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg ccache config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo ftp://mirror.datapipe.net/gentoo http://mirror.jamit.de/gentoo/ http://pinguin.ittelkom.ac.id/mirror/gentoo/"
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/other/portage/pkgdir"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/other/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://novazur.fr/gentoo-portage"
USE="X a52 aac acl acpi aim alsa amd64 audiofile bash-completion berkdb bluetooth branding bzip2 cairo caps cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr dvdread eds emboss encode evo exif fam ffmpeg firefox flac gdbm gif glamor gphoto2 gtk gtk2 gtkhtml iconv imagemagick imlib iodbc jabber java joystick jpeg kde kipi lcms ldap libav libnotify libsamplerate lm_sensors mad matroska mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl nptlonly nsplugin odbc ogg oggvorbis openal opengl openmp pam pango pcre pdf phonon plasma png policykit portaudio qt3support qt4 readline scanner sdl semantic-desktop session sndfile sox speex spell sse sse2 ssl startup-notification svg tcltk tcpd theora tiff truetype udev udisks unicode upower usb v4l vorbis win32codecs wxwidgets x264 xcb xcomposite xinerama xml xpm xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel nvidia" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr fr_FR" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

www-client/firefox-31.3.0 was built with the following:
USE="dbus gstreamer jit minimal startup-notification -bindist -custom-cflags -custom-optimization -debug -hardened (-pgo) -pulseaudio (-selinux) -system-cairo -system-icu -system-jpeg -system-libvpx -system-sqlite -test -wifi" ABI_X86="64" LINGUAS="fr -af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -th -tr -uk -vi -xh -zh_CN -zh_TW -zu"
CFLAGS="-march=nocona -pipe -mno-avx"
CXXFLAGS="-march=nocona -pipe -mno-avx"
Comment 1 Christophe PEREZ 2015-02-09 22:38:44 UTC
I had to manually get http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/31.4.0esr/linux-i686/xpi/fr.xpi, rename it firefox-31.4.0esr-fr.xpi.
Comment 2 charles17 2015-02-10 06:44:25 UTC
Maybe dupe of Bug 531278
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-10 07:28:47 UTC
(In reply to charles17 from comment #2)
> Maybe dupe of Bug 531278

No.

You should update your GENTOO_MIRRORS variable. You're able to reach only one of three listed hosts, and that one appears to be outdated.
Comment 4 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2015-02-10 08:16:46 UTC
Hello Daniel,

I see you handled bug 61387 which was the last ticket regarding your mirror, so I'm invoking you again. ;)
Could you check why it is not updating anymore since +/- November 18?

Thanks.
Comment 5 Daniel Drown 2015-02-10 19:56:59 UTC
mirror.datapipe.net is running out of disk space and this broke the sync process.  It is a very old system and it is being phased out.  Unfortunately, it will not be able to be a full mirror of Gentoo any longer.
Comment 6 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2015-02-10 20:11:55 UTC
Too bad, but okay. I've removed the listing from the mirror lists. Thanks for your services over all these years!