Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 538066 - x86_64-w64-mingw32 fails to build with libsanitizer issue
Summary: x86_64-w64-mingw32 fails to build with libsanitizer issue
Status: RESOLVED DUPLICATE of bug 526142
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-28 16:27 UTC by Rob Stoddard
Modified: 2015-01-28 16:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
One of three suggested-by-crossdev attachments... (cross-x86_64-w64-mingw32-gcc-stage2.log.xz,98.79 KB, application/x-xz)
2015-01-28 16:27 UTC, Rob Stoddard
Details
attachment 2 of 3 suggested by crossdev (cross-x86_64-w64-mingw32-info.log,16.19 KB, text/plain)
2015-01-28 16:27 UTC, Rob Stoddard
Details
Attachment 3 of 3 suggested by crossdev (gcc-config.logs.tar.xz,76.81 KB, application/x-xz)
2015-01-28 16:28 UTC, Rob Stoddard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Stoddard 2015-01-28 16:27:12 UTC
Created attachment 395058 [details]
One of three suggested-by-crossdev attachments...

I have a very vanilla install on my "build" machine.  It's basically a compiler that boots.   Here's my make.conf:

CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="bindist mmx sse sse2"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j8"

GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/ http://mirror.datapipe.net/gentoo http://www.gtlib.gatech.edu/pub/gentoo"

SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
ACCEPT_KEYWORDS="~amd64"
PORTDIR_OVERLAY="/usr/local/portage"

I am getting a failure on my MinGW 64 bit build which I haven't been able to defray.

I have three attachments for this particular issue, and don't seem to have a way to add more than one here... so bear with me...
Comment 1 Rob Stoddard 2015-01-28 16:27:45 UTC
Created attachment 395060 [details]
attachment 2 [details] of 3 suggested by crossdev
Comment 2 Rob Stoddard 2015-01-28 16:28:07 UTC
Created attachment 395062 [details]
Attachment 3 [details, diff] of 3 suggested by crossdev
Comment 3 Rob Stoddard 2015-01-28 16:37:15 UTC

*** This bug has been marked as a duplicate of bug 526142 ***
Comment 4 Rob Stoddard 2015-01-28 16:38:06 UTC
Sorry, did not see this bug in the list until looking for the other mingw issue I have on another machine; oddly enough with the search criteria "mingw libgfortran"