Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 537650 - net-fs/nfs-utils-1.3.1-r1: news item requested for nfsmount -> nfsclient init script change
Summary: net-fs/nfs-utils-1.3.1-r1: news item requested for nfsmount -> nfsclient init...
Status: RESOLVED DUPLICATE of bug 537996
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: OpenRC Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-25 13:43 UTC by John R. Graham
Modified: 2015-01-31 15:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John R. Graham gentoo-dev 2015-01-25 13:43:24 UTC
Stabilization of this and sys-apps/openrc-0.13.8 were not well coordinated. Together, the openrc-0.13.8 ebuild and the nfs-utils-1.3.1-r1 ebuild printed enough ewarn messages about changes needed to the network init script configuration to keep your NFS mounts happy; however, there were two problems:
1) The new nfs-utils went stable _before_ the new openrc, so the whole picture wasn't immediately available to the astute user.
2) Alas, ewarn messages are ephemeral and, although you can log them, it's pretty easy to miss them.

Without attention to the init script runlevel configuration, this update broke every NFS mount in the Gentoo universe; users _are_ bumping into this issue (including yours truly). [1]

As news items are _not_ ephemeral, and marginally harder to miss, I think a news item is still warranted.

References:
[1] https://forums.gentoo.org/viewtopic-t-1009012.html
Comment 1 Tim Harder gentoo-dev 2015-01-31 07:16:07 UTC
I think a news item is in the works, and net-fs wasn't the driver for this so re-assigning.
Comment 2 Tim Harder gentoo-dev 2015-01-31 07:25:26 UTC
Marking as a dup of 537996 since that shows the incoming news item timeline.

*** This bug has been marked as a duplicate of bug 537996 ***
Comment 3 John R. Graham gentoo-dev 2015-01-31 15:49:36 UTC
Thanks, Tim.