Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 537356 - x11-wm/fluxbox-1.3.5 USE=-toolbar - fails to disable toolbar support
Summary: x11-wm/fluxbox-1.3.5 USE=-toolbar - fails to disable toolbar support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Panagiotis Christopoulos (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-22 13:56 UTC by charles17
Modified: 2015-02-03 07:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info =x11-wm/fluxbox-1.3.5 (emerge_--info,5.76 KB, text/plain)
2015-01-22 13:56 UTC, charles17
Details
Fixes --enable/disable-systray issue in USE="toolbar" (fluxbox-1.3.5.ebuild.patch,1.93 KB, patch)
2015-01-22 20:31 UTC, zlg (RETIRED)
Details | Diff
fluxbox-1.3.6-r1-fix.patch (fluxbox-1.3.6-r1-fix.patch,363 bytes, patch)
2015-01-26 03:44 UTC, zlg (RETIRED)
Details | Diff
fluxbox-9999 updates for bugfixes (fluxbox-9999-fix.patch,3.76 KB, patch)
2015-01-26 05:39 UTC, zlg (RETIRED)
Details | Diff
emerge --info =x11-wm/fluxbox-1.3.5-r1 (emerge --info,5.79 KB, text/plain)
2015-01-26 08:44 UTC, charles17
Details
emerge --info '=x11-wm/fluxbox-1.3.5-r1' (emerge --info,5.79 KB, text/plain)
2015-01-26 13:49 UTC, charles17
Details

Note You need to log in before you can comment on or make changes to this bug.
Description charles17 2015-01-22 13:56:04 UTC
Created attachment 394618 [details]
emerge --info =x11-wm/fluxbox-1.3.5

Disabling USE flag toolbar on emerge =x11-wm/fluxbox-1.3.5 has no effect.

Problem with this is that starting lxpanel with fluxbox gives the error 
"tray: another systray already running" and applications cannot sit in lxpanel's tray.
Comment 1 zlg (RETIRED) gentoo-dev 2015-01-22 20:16:59 UTC
This is caused by Fluxbox's configure script. It checks for both `toolbar` AND `systray` options. I'll attach a one-liner patch that will add/disable the `systray` switch based on 'toolbar's presence. I've tested it and confirmed a) no toolbar is present in Fluxbox, and b) lxpanel launched correctly and displayed my systray icons.

I'll attach the patch.
Comment 2 zlg (RETIRED) gentoo-dev 2015-01-22 20:31:59 UTC
Created attachment 394656 [details, diff]
Fixes --enable/disable-systray issue in USE="toolbar"

This patch cleans up the ebuild to be in line with 1.3.6's recent fbgm bugfix (bug 536370) and prevents the systray from being enabled when USE="-toolbar".

I have tested the ebuild patch (and the user's use-case) personally and confirmed it works. I'll be opening a bug for fixing this in 1.3.6 and 9999, too.
Comment 3 Ian Delaney (RETIRED) gentoo-dev 2015-01-24 04:17:59 UTC
Before I do a thing to this ebuild I wish to know;
Why is 

1.3.2   set | + + + o + + o ~ + + o o + + 
meaning stabled in all keywords or arches
but
1.3.5   set | ~ + + o + ~ o ~ ~ ~ o o ~ ~ 

(output of ~/cvsPortage/gentoo-x86/x11-wm/fluxbox $ eshowkw)

*fluxbox-1.3.2 (29 Nov 2011) !!!

Apart from that, a revbump here will be required and likely a separate revbump for fluxbox-1.3.6, which is fine.
It seems to me the 1.3.5 either needs remaining arches made stable or somehow revert the stabling of those missing arches. As it is, afaik, the 1.3.2 cannot be purged without breaking QA.
Treating each issue separately is quite legit.
Comment 4 zlg (RETIRED) gentoo-dev 2015-01-25 03:42:31 UTC
1.3.5's stable reports may need to be re-examined. I'm not a developer (just proxy-maint), so I really have no say in the package's fate. I've not had any issues, but the recent bug reports are likely the result of 1.3.6 releasing and generating some eyeballs on the ebuild. As proxy-maint, is it within my rights to post about this bug as a blocker to stabilization?

Good to know that the issues can remain separate and be merged as needed. I'll keep that in mind for the future.
Comment 5 Ian Delaney (RETIRED) gentoo-dev 2015-01-26 02:41:47 UTC
(In reply to Daniel Campbell from comment #4)
> 1.3.5's stable reports may need to be re-examined. I'm not a developer (just
> proxy-maint), so I really have no say in the package's fate. I've not had
> any issues, but the recent bug reports are likely the result of 1.3.6
> releasing and generating some eyeballs on the ebuild. 

Re stabling; it was me missing observing the presence of bug 536086, which is an odd oversight on my part since I've been examining stabling progress is most every other package I've dealt with lately.  Basically that is all under control and in summary the quicker arches have already been quick and the slower arches come in their own time.

As proxy-maint, is it within my rights to post about this bug as a blocker to 
> stabilization?

YES. just make it block. (I forget whether user has authority to block, otherwise 'we' need to) It's a bug of fluxbox-1.3.5 which just happened to be submitted by your co-maintainer.  While it will undermine the stabling of the 3 arches done so far, it's frankly trivial.  By rights you ought put a stop on the stabling of fluxbox-1.3.5 and await 30 days from today as I commit the revbump with the (your own) fix and re-prompt us to re-add arches and instead request the fluxbox-1.3.5-r1.ebuild be made stable. 

> Good to know that the issues can remain separate and be merged as needed.
> I'll keep that in mind for the future.

*fluxbox-1.3.5-r1 (26 Jan 2015)

  26 Jan 2015; Ian Delaney <idella4@gentoo.org> +fluxbox-1.3.5-r1.ebuild:
  revbump to -1.3.5; patch by D. Campbell, fixes bug #537356 made by co-
  maintainer


Here's the plan for you to pursue.  Take fluxbox-1.3.6-r1.ebuild and apply the changes fixes from the fluxbox-1.3.5-r1.ebuild. Make a new bug or keep using this one, no diff to me.  Attach either a whole new ebuild with fixes from -1.3.5-r1 applied to -1.3.6-r1 OR a diff -u style patch. Then decide does this warrant a revbump to -1.3.6-r2 OR can it just go straight in.

Any further questions?
Comment 6 zlg (RETIRED) gentoo-dev 2015-01-26 03:44:51 UTC
Created attachment 394910 [details, diff]
fluxbox-1.3.6-r1-fix.patch

This patch is to fix the USE="-toolbar" issue that's also present in the fluxbox-1.3.6{-r1} ebuild. I do not think it's worth a revbump since it's ensuring that a given USE flag is working correctly and not making large enough changes for the user to concern themselves with.

This patch can be applied to the git (9999) version as well.

I have commented on 1.3.5's stabilization bug and informed them of the two blocker bugs (this one included).

How should I go about getting these fixes into fluxbox-9999? It's the furthest behind. Perhaps just a patch to put it in line with the others?
Comment 7 Ian Delaney (RETIRED) gentoo-dev 2015-01-26 05:04:21 UTC
  26 Jan 2015; Ian Delaney <idella4@gentoo.org> fluxbox-1.3.6-r1.ebuild:
  add fix re USE toolbar from Bug 537356 to -1.3.6-r1, patch by maintainer D.
  Campbell

My preference is to just keep using this bug to complete the live ebuild. But if you must make a new one, do as you will. Either way, just make a patch to bring the live ebuild up to speed and I can commit that in one hit. A diff -u style patch is the norm as you've done recently
Comment 8 zlg (RETIRED) gentoo-dev 2015-01-26 05:39:59 UTC
Created attachment 394920 [details, diff]
fluxbox-9999 updates for bugfixes

This patch updates fluxbox-9999.ebuild to include fixes for both this bug and bug 536370, in addition to one small fix that was not added to 9999 (bug 509014).

This should result in all fluxbox versions having this bug (and the printf bug) fixed.
Comment 9 charles17 2015-01-26 08:44:19 UTC
Created attachment 394924 [details]
emerge --info =x11-wm/fluxbox-1.3.5-r1

Changelog says it's fixed:

*fluxbox-1.3.5-r1 (26 Jan 20
 26 Jan 2015; Ian Delaney <idella4@gentoo.org> +fluxbox-1.3.5-r1.ebuild:
 revbump to -1.3.5; patch by D. Campbell, fixes bug #537356 made by co-
 maintainer

But the problem still exists in 1.3.5-r1.
Comment 10 Ian Delaney (RETIRED) gentoo-dev 2015-01-26 12:35:49 UTC
Just discovered missed adding systray to  $(use_enable toolbar. Added now.

  26 Jan 2015; Ian Delaney <idella4@gentoo.org> -fluxbox-1.3.6.ebuild,
  files/1.3.5-generate_menu-printf-fix.patch, fluxbox-1.3.5-r1.ebuild,
  fluxbox-9999.ebuild:
  update patch with final form from upstream, add missed addition from bug
  537356 to -1.3.5-r1, full update to live ebuild from patch from same bug,
  remove broken 1.3.6 ebuild, fixes Bugs 537356, 536370 by maintainers.

Leave set TEST-REQUEST before closing fully.
Comment 11 charles17 2015-01-26 13:49:41 UTC
Created attachment 394934 [details]
emerge --info '=x11-wm/fluxbox-1.3.5-r1'

USE=-toolbar no longer blocks lxpanel's tray, but still creates fluxbox' toolbar.
Comment 12 zlg (RETIRED) gentoo-dev 2015-01-26 19:27:13 UTC
(In reply to Ian Delaney from comment #10)
> Just discovered missed adding systray to  $(use_enable toolbar. Added now.
> 
>   26 Jan 2015; Ian Delaney <idella4@gentoo.org> -fluxbox-1.3.6.ebuild,
>   files/1.3.5-generate_menu-printf-fix.patch, fluxbox-1.3.5-r1.ebuild,
>   fluxbox-9999.ebuild:
>   update patch with final form from upstream, add missed addition from bug
>   537356 to -1.3.5-r1, full update to live ebuild from patch from same bug,
>   remove broken 1.3.6 ebuild, fixes Bugs 537356, 536370 by maintainers.
> 
> Leave set TEST-REQUEST before closing fully.

The issue is both flags need to be set. It should be:

$(use_enable toolbar ) \
$(use_enable toolbar systray ) \

The first sets --{en|dis}able-toolbar, as expected, and the second sets --{en|dis}able-systray. Both are needed to properly disable the toolbar completely and would explain why Charles experienced the issue.

See attachment 394656 [details, diff].
Comment 13 Ian Delaney (RETIRED) gentoo-dev 2015-01-27 00:15:09 UTC
Jut as well I set TEST-REQUEST.  Sorry for the misread on the first attempt.

  27 Jan 2015; Ian Delaney <idella4@gentoo.org> fluxbox-1.3.5-r1.ebuild,
  fluxbox-1.3.6-r1.ebuild:
  Set correct fix to bug #537356

Anything else?
Comment 14 charles17 2015-01-27 07:20:46 UTC
Tested both 1.3.5-r1 and 1.3.6-r1 and both seem to be ok now.
Thanks for your help.