Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 537022 - net-misc/freerdp-1.2.0_beta1_pre20141115 - CMake Warning at cmake/FindFeature.cmake:46 (message): feature Wayland was requested but could not be found! ON / FALSE
Summary: net-misc/freerdp-1.2.0_beta1_pre20141115 - CMake Warning at cmake/FindFeature...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Gilbert
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-19 08:41 UTC by klaus818
Modified: 2015-02-06 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klaus818 2015-01-19 08:41:31 UTC
-- Configuring incomplete, errors occurred!
See also "/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/CMakeFiles/CMakeError.log".
 * ERROR: net-misc/freerdp-1.2.0_beta1_pre20141115::gentoo failed (configure phase):
 *   cmake failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 2717:  Called cmake-utils_src_configure
 *   environment, line  747:  Called _execute_optionally 'src_configure'
 *   environment, line  310:  Called enable_cmake-utils_src_configure
 *   environment, line 1064:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 * 
 * If you need support, post the output of `emerge --info '=net-misc/freerdp-1.2.0_beta1_pre20141115::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-misc/freerdp-1.2.0_beta1_pre20141115::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/temp/environment'.
 * Working directory: '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build'
 * S: '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115'

>>> Failed to emerge net-misc/freerdp-1.2.0_beta1_pre20141115, Log file:

>>>  '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/temp/build.log'

Reproducible: Always




emerge --info
Portage 2.2.15 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/kde/systemd, gcc-4.9.2, glibc-2.20-r1, 3.18.3-gentoo x86_64)
=================================================================
System uname: Linux-3.18.3-gentoo-x86_64-Intel-R-_Pentium-R-_CPU_B960_@_2.20GHz-with-gentoo-2.2
KiB Mem:     3897660 total,    449224 free
KiB Swap:    8191996 total,   7714228 free
Timestamp of tree: Mon, 19 Jan 2015 07:45:01 +0000
sh bash 4.3_p33
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.2
dev-util/cmake:           3.1.0
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.15
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.9.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.4
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.20-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -mno-avx -mno-aes -mno-rdrnd -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7-avx -mno-avx -mno-aes -mno-rdrnd -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-march=corei7-avx -mno-avx -mno-aes -mno-rdrnd -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=corei7-avx -mno-avx -mno-aes -mno-rdrnd -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb branding btrfs bzip2 cairo cdda cdr cli cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif extraengine fam fat ffmpeg firefox flac fortran gdbm geoip gif glamor google gpm gtk iconv ipv6 jpeg kde kdepim kipi lame lcms ldap libnotify lm_sensors mad matroska mmx mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ntfs ntp ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline sdl semantic-desktop session spell sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg systemd tcpd theora tiff truetype udev udisks unicode upnp upower usb vaapi vdpau vorbis vpx wxwidgets x264 xcb xcomposite xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" SANE_BACKENDS="niash" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2015-01-19 08:44:20 UTC
Please attach the entire build log to this bug report.
Comment 2 klaus818 2015-01-19 09:09:37 UTC
First: The Problem is cmake. You can compile freerdp with cmake-3.0.2. The problem was cmake 3.1.0.

And second, here ist the complete log:

 * Package:    net-misc/freerdp-1.2.0_beta1_pre20141115
 * Repository: gentoo
 * Maintainer: floppym@gentoo.org
 * USE:        X abi_x86_64 alsa amd64 client cups elibc_glibc ffmpeg gstreamer jpeg kernel_linux pulseaudio sse2 usb userland_GNU xinerama xv
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work
>>> Preparing source in /var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build"
cmake --no-warn-unused-cli -C /var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/gentoo_common_config.cmake -G Unix Makefiles -DCMAKE_INSTALL_PREFIX=/usr -DWITH_ALSA=ON -DWITH_CLIENT=ON -DWITH_CUPS=ON -DWITH_DEBUG_ALL=OFF -DWITH_MANPAGES=OFF -DWITH_FFMPEG=ON -DWITH_GSTREAMER_1_0=ON -DWITH_JPEG=ON -DWITH_PULSE=ON -DWITH_SERVER=OFF -DWITH_PCSC=OFF -DWITH_SSE2=ON -DCHANNEL_URBDRC=ON -DWITH_X11=ON -DWITH_XINERAMA=ON -DWITH_XV=ON -DBUILD_TESTING=OFF -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/gentoo_rules.cmake -DCMAKE_TOOLCHAIN_FILE=/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/gentoo_toolchain.cmake  /var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/gentoo_common_config.cmake
-- The C compiler identification is GNU 4.9.2
-- The CXX compiler identification is GNU 4.9.2
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/x86_64-pc-linux-gnu-pkg-config (found version "0.28") 
-- FreeRDP GIT
-- Git Revision n/a
-- Performing Test Wno-unused-result
-- Performing Test Wno-unused-result - Success
-- Performing Test Wno-unused-but-set-variable
-- Performing Test Wno-unused-but-set-variable - Success
-- Performing Test Wno-deprecated-declarations
-- Performing Test Wno-deprecated-declarations - Success
-- Performing Test Wno-deprecated-declarationsCXX
-- Performing Test Wno-deprecated-declarationsCXX - Success
-- Looking for include file fcntl.h
-- Looking for include file fcntl.h - found
-- Looking for include file unistd.h
-- Looking for include file unistd.h - found
-- Looking for include file execinfo.h
-- Looking for include file execinfo.h - found
-- Looking for include file stdint.h
-- Looking for include file stdint.h - found
-- Looking for include file inttypes.h
-- Looking for include file inttypes.h - found
-- Looking for include file sys/modem.h
-- Looking for include file sys/modem.h - not found
-- Looking for include file sys/filio.h
-- Looking for include file sys/filio.h - not found
-- Looking for include file sys/strtio.h
-- Looking for include file sys/strtio.h - not found
-- Looking for include file sys/select.h
-- Looking for include file sys/select.h - found
-- Performing Test HAVE_TM_GMTOFF
-- Performing Test HAVE_TM_GMTOFF - Success
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Looking for pthread_tryjoin_np in pthread
-- Looking for pthread_tryjoin_np in pthread - found
-- Looking for include file sys/eventfd.h
-- Looking for include file sys/eventfd.h - found
-- Looking for include file sys/eventfd.h
-- Looking for include file sys/eventfd.h - found
-- Looking for include file sys/timerfd.h
-- Looking for include file sys/timerfd.h - found
-- Looking for include file poll.h
-- Looking for include file poll.h - found
-- Finding recommended feature X11 for X11 (X11 client and server)
--     Disable feature X11 using "-DWITH_X11=OFF"
-- Found X11: /usr/lib64/libX11.so  
-- Finding recommended feature Wayland for Wayland (Wayland client)
--     Disable feature Wayland using "-DWITH_WAYLAND=OFF"
-- Could NOT find WAYLAND (missing:  WAYLAND_LIBRARY WAYLAND_INCLUDE_DIR) 
CMake Warning at cmake/FindFeature.cmake:46 (message):
      feature Wayland was requested but could not be found! ON / FALSE
Call Stack (most recent call first):
  CMakeLists.txt:535 (find_feature)


-- Skipping optional feature DirectFB for DirectFB (DirectFB client)
--     Enable feature DirectFB using "-DWITH_DIRECTFB=ON"
-- Finding required feature ZLIB for compression (data compression)
-- Found ZLIB: /usr/lib64/libz.so (found version "1.2.8") 
-- Finding required feature OpenSSL for cryptography (encryption, certificate validation, hashing functions)
-- Found OpenSSL: /usr/lib64/libssl.so;/usr/lib64/libcrypto.so (found version "1.0.1l") 
-- Skipping optional feature OpenSLES for multimedia (OpenSLES audio / video)
--     Enable feature OpenSLES using "-DWITH_OPENSLES=ON"
-- Finding recommended feature ALSA for sound (audio input, audio output and multimedia redirection)
--     Disable feature ALSA using "-DWITH_ALSA=OFF"
-- Found ALSA: /usr/lib64/libasound.so (found version "1.0.28") 
-- Finding optional feature Pulse for sound (audio input, audio output and multimedia redirection)
-- checking for module 'libpulse'
--   found libpulse, version 5.0
-- Found Pulse: /usr/include  
-- Finding optional feature Cups for printing (printer device redirection)
-- Found Cups: /usr/lib64/libcups.so (found version "2.0.1") 
-- Skipping optional feature PCSC for smart card (smart card device redirection)
--     Enable feature PCSC using "-DWITH_PCSC=ON"
-- Finding recommended feature FFmpeg for multimedia (multimedia redirection, audio and video playback)
--     Disable feature FFmpeg using "-DWITH_FFMPEG=OFF"
-- checking for module 'libavcodec'
--   found libavcodec, version 55.52.102
-- checking for module 'libavutil'
--   found libavutil, version 52.66.100
-- Found FFmpeg: TRUE  
-- Skipping optional feature GStreamer_0_10 for multimedia (multimedia redirection, audio and video playback, gstreamer 0.10 version)
--     Enable feature GStreamer_0_10 using "-DWITH_GSTREAMER_0_10=ON"
-- Finding recommended feature GStreamer_1_0 for multimedia (multimedia redirection, audio and video playback)
--     Disable feature GStreamer_1_0 using "-DWITH_GSTREAMER_1_0=OFF"
-- checking for module 'glib-2.0'
--   found glib-2.0, version 2.42.1
-- Found Glib 
-- checking for module 'gstreamer-1.0'
--   found gstreamer-1.0, version 1.4.5
-- checking for module 'gstreamer-base-1.0'
--   found gstreamer-base-1.0, version 1.4.5
-- checking for module 'gstreamer-app-1.0'
--   found gstreamer-app-1.0, version 1.4.5
-- checking for module 'gstreamer-audio-1.0'
--   found gstreamer-audio-1.0, version 1.4.5
-- checking for module 'gstreamer-fft-1.0'
--   found gstreamer-fft-1.0, version 1.4.5
-- checking for module 'gstreamer-pbutils-1.0'
--   found gstreamer-pbutils-1.0, version 1.4.5
-- checking for module 'gstreamer-video-1.0'
--   found gstreamer-video-1.0, version 1.4.5
-- Found GSTREAMER_1_0: /usr/lib64/libgstreamer-1.0.so  
-- Finding optional feature JPEG for codec (use JPEG library)
-- Found JPEG: /usr/lib64/libjpeg.so  
-- Skipping optional feature OpenH264 for codec (use OpenH264 library)
--     Enable feature OpenH264 using "-DWITH_OPENH264=ON"
-- Skipping optional feature GSM for codec (GSM audio codec library)
--     Enable feature GSM using "-DWITH_GSM=ON"
-- Skipping optional feature IPP for performance (Intel Integrated Performance Primitives library)
--     Enable feature IPP using "-DWITH_IPP=ON"
-- FreeRDP GIT
-- Finding recommended feature XKBFile for X11 keyboard (X11 keyboard file extension)
--     Disable feature XKBFile using "-DWITH_XKBFILE=OFF"
-- Found XKBFile: /usr/lib64/libxkbfile.so  
CMake Error at channels/client/CMakeLists.txt:27 (list):
  list sub-command REMOVE_DUPLICATES requires list to be present.


-- FreeRDP GIT
-- Found DocBookXSL: /usr/share/sgml/docbook/xsl-stylesheets  
-- Finding required feature XShm for X11 shared memory (X11 shared memory extension)
-- Found XShm: /usr/lib64/libXext.so  
-- Finding recommended feature Xinerama for multi-monitor (X11 multi-monitor extension)
--     Disable feature Xinerama using "-DWITH_XINERAMA=OFF"
-- Found Xinerama: /usr/lib64/libXinerama.so  
-- Finding recommended feature Xext for X11 extension (X11 core extensions)
--     Disable feature Xext using "-DWITH_XEXT=OFF"
-- Found Xext: /usr/lib64/libXext.so  
-- Finding recommended feature Xcursor for cursor (X11 cursor extension)
--     Disable feature Xcursor using "-DWITH_XCURSOR=OFF"
-- Found Xcursor: /usr/lib64/libXcursor.so  
-- Finding recommended feature Xv for video (X11 video extension)
--     Disable feature Xv using "-DWITH_XV=OFF"
-- Found Xv: /usr/lib64/libXv.so  
-- Finding recommended feature Xi for input (X11 input extension)
--     Disable feature Xi using "-DWITH_XI=OFF"
-- Found Xi: /usr/lib64/libXi.so  
-- Looking for XITouchClass
-- Looking for XITouchClass - found
-- Finding recommended feature Xrender for rendering (X11 render extension)
--     Disable feature Xrender using "-DWITH_XRENDER=OFF"
-- Found Xrender: /usr/lib64/libXrender.so  
-- Finding recommended feature Xfixes for X11 xfixes extension (Useful additions to the X11 core protocol)
--     Disable feature Xfixes using "-DWITH_XFIXES=OFF"
-- Found Xfixes: /usr/lib64/libXfixes.so  
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -march=corei7-avx -mno-avx -mno-aes -mno-rdrnd -O2 -pipe  -fPIC -Wall -Wno-unused-result -Wno-unused-but-set-variable -Wno-deprecated-declarations -g -msse2 -DWINPR_EXPORTS -DFREERDP_EXPORTS
C++             -march=corei7-avx -mno-avx -mno-aes -mno-rdrnd -O2 -pipe  -Wno-deprecated-declarations -g -DWINPR_EXPORTS -DFREERDP_EXPORTS
Linker flags:
Executable       -Wl,-O1 -Wl,--as-needed
Module           -Wl,-O1 -Wl,--as-needed
Shared           -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
See also "/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/CMakeFiles/CMakeOutput.log".
See also "/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build/CMakeFiles/CMakeError.log".
 * ERROR: net-misc/freerdp-1.2.0_beta1_pre20141115::gentoo failed (configure phase):
 *   cmake failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 2718:  Called cmake-utils_src_configure
 *   environment, line  748:  Called _execute_optionally 'src_configure'
 *   environment, line  311:  Called enable_cmake-utils_src_configure
 *   environment, line 1065:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 * 
 * If you need support, post the output of `emerge --info '=net-misc/freerdp-1.2.0_beta1_pre20141115::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-misc/freerdp-1.2.0_beta1_pre20141115::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/temp/environment'.
 * Working directory: '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115_build'
 * S: '/var/tmp/portage/net-misc/freerdp-1.2.0_beta1_pre20141115/work/freerdp-1.2.0_beta1_pre20141115'
Comment 3 Greg Turner 2015-01-22 01:07:07 UTC
Saw this too.  Taking cmake's advice like so:

--- /usr/portage/net-misc/freerdp/freerdp-1.2.0_beta1_pre20141115.ebuild.orig   2015-01-21 16:57:54.599496778 -0800
+++ /usr/portage/net-misc/freerdp/freerdp-1.2.0_beta1_pre20141115.ebuild        2015-01-21 17:00:09.189206840 -0800
@@ -23,7 +23,7 @@ HOMEPAGE="http://www.freerdp.com/"
 LICENSE="Apache-2.0"
 SLOT="0/1.2"
 IUSE="alsa +client cups debug doc ffmpeg gstreamer jpeg
-       pulseaudio server smartcard sse2 test usb X xinerama xv"
+       pulseaudio server smartcard sse2 test usb -wayland X xinerama xv"
 
 RDEPEND="
        dev-libs/openssl
@@ -94,6 +94,7 @@ src_configure() {
                $(cmake-utils_use_with smartcard PCSC)
                $(cmake-utils_use_with sse2 SSE2)
                $(cmake-utils_use usb CHANNEL_URBDRC)
+               $(cmake-utils_use_with wayland WAYLAND)
                $(cmake-utils_use_with X X11)
                $(cmake-utils_use_with xinerama XINERAMA)
                $(cmake-utils_use_with xv XV)

got me to a new, ostensibly unrelated error:

CMake Error at channels/client/CMakeLists.txt:27 (list):
  list sub-command REMOVE_DUPLICATES requires list to be present.

Note that the above patch ignores the question (due to ignorance of the patch's author) of how to codify the wayland dependencies themselves.
Comment 4 Greg Turner 2015-01-22 01:09:43 UTC
Note, commenting out the CMakefile line it complains about seemed to allow the build to succeed.  Of course, presumably that line is there for some reason other than just to vex us :)
Comment 5 Patrick Lauer gentoo-dev 2015-01-23 00:35:35 UTC
+  23 Jan 2015; Patrick Lauer <patrick@gentoo.org>
+  freerdp-1.2.0_beta1_pre20141115.ebuild:
+  Make CMake fail less, add wayland useflag to avoid broken autodetection etc,
+  #537022

At least it has a chance of building now ...
Comment 6 Mike Gilbert gentoo-dev 2015-01-23 01:25:29 UTC
Sorry, I have been busy and haven't had a chance to dig into this. Thanks for the fix in the mean time.
Comment 7 Mike Gilbert gentoo-dev 2015-01-23 01:51:46 UTC
+  23 Jan 2015; Mike Gilbert <floppym@gentoo.org> +files/freerdp-cmake-3.1.patch,
+  freerdp-1.2.0_beta1_pre20141115.ebuild, freerdp-9999.1.ebuild:
+  Add patch from upstream for cmake-3.1 compatibility, bug 537022.
Comment 8 Kobboi 2015-02-06 13:06:29 UTC
Hitting the same problem on freerdp-1.1.0_beta1_p20130710-r2