Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 536164 - dev-db/pg_top-3.7.0 with sys-libs/ncurses[tinfo] - .../work/pg_top-3.7.0/display.c:264: error: undefined reference to 'tgoto'
Summary: dev-db/pg_top-3.7.0 with sys-libs/ncurses[tinfo] - .../work/pg_top-3.7.0/disp...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PgSQL Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2015-01-10 04:31 UTC by Reuben Martin
Modified: 2015-01-11 11:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reuben Martin 2015-01-10 04:31:14 UTC
Errors are a bit misleading since the missing function calls are from libraries like libreadline. However they are all from libraries pulled in by libtinfo. Adding "-ltinfo" is sufficient to link correctly.

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2015-01-11 11:36:19 UTC
Fixed without revision bump.