Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 53563 - Ebuild for Wordpress CMS/blog system v1.2
Summary: Ebuild for Wordpress CMS/blog system v1.2
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: web-apps Herd
URL:
Whiteboard:
Keywords:
: 53051 (view as bug list)
Depends on:
Blocks: 57395
  Show dependency tree
 
Reported: 2004-06-10 12:10 UTC by Peter Westwood
Modified: 2004-08-18 10:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The ebuild (wordpress-1.2.ebuild,1.92 KB, text/plain)
2004-06-10 12:12 UTC, Peter Westwood
Details
The required diff for symlink fixing (wordpress-1.2.gentoo.diff,4.94 KB, patch)
2004-06-10 12:13 UTC, Peter Westwood
Details | Diff
postinstall-en.txt required by ebuild (postinstall-en-1.2.txt,490 bytes, text/plain)
2004-06-10 12:13 UTC, Peter Westwood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Westwood 2004-06-10 12:10:11 UTC
webapp aware ebuild for wordpress v1.2 includes a diff to get around problems with symlinks.

Reproducible: Always
Steps to Reproduce:
Comment 1 Peter Westwood 2004-06-10 12:12:14 UTC
Created attachment 33041 [details]
The ebuild

ebuild for wordpress-1.2
Comment 2 Peter Westwood 2004-06-10 12:13:04 UTC
Created attachment 33042 [details, diff]
The required diff for symlink fixing

Diff for symlink fixing
Comment 3 Peter Westwood 2004-06-10 12:13:52 UTC
Created attachment 33043 [details]
postinstall-en.txt required by ebuild

Install/Upgrade instructions
Comment 4 Peter Westwood 2004-06-10 12:14:22 UTC
Reassigned to it's proper home
Comment 5 Stuart Herbert (RETIRED) gentoo-dev 2004-07-11 15:28:36 UTC
Okay, this is now in Portage.  To use this, you need to use webapp-config 1.10-r5 or later.  I had to patch the login code to make it work with my existing wordpress upgrade, so please let me know if there's any problems with this ebuild.

Best regards,
Stu
Comment 6 Stuart Herbert (RETIRED) gentoo-dev 2004-07-11 15:29:26 UTC
*** Bug 53051 has been marked as a duplicate of this bug. ***
Comment 7 Stuart Herbert (RETIRED) gentoo-dev 2004-07-11 16:05:41 UTC
Hrm .. I'm going to have to take another look at my login-patch when I'm a bit more awake.
Comment 8 billy 2004-07-14 14:41:52 UTC
Login does not seem to work on a new install of wordpress 1.2.
The default blog shows fine, and the login link from there works.
But when putting in the user "admin" and the password given on install,
it just reloads the login page asking yet again for login/pass.

I do have webapp-config 1.10-r5 installed.
Comment 9 Stuart Herbert (RETIRED) gentoo-dev 2004-07-20 15:20:53 UTC
I've put a new login patch in place.  It works for me on my existing install of wordpress.

Please let me know how you get on.

Stu
Comment 10 billy 2004-07-29 07:31:03 UTC
I unmerged wordpress 1.2 and re-emerged. Letting the app setup the database from scratch. Unfortunately I'm still having redirect limit errors when trying to login.
I've tried it w/ firefox .9.2 on win32 and IE 5.5.

What's weird, is I was able to login on the first try via IE, but logging out gave me a redirect error. When I tried to login again w/ IE, I got redirect limit errors.

I deleted all cookies, tmp files, and basically everything from both browsers and tried again. Redirect limit errors on each.

I can unmerge and re-emerge pretty simply, so if there is anything specific you'd like me to try, just say the word.

Thanks,
billy
Comment 11 Kai Groner 2004-07-30 14:02:56 UTC
I tried the wordpress ebuild this afternoon with no previous wordpress install.  I got a redirect loop when I try to load wp-login.php.

It looks like checklogin() (in wp-login.php) is returning true when no wordpress cookie is found.

I changed line 246 of wp-login.php to test for that:
-               if ($user_pass_md5 != $userdata->user_pass) {
+               if (!$userdata || $user_pass_md5 != $userdata->user_pass) {

I can log in now, I have not checked for similar problems elsewhere in the login patch.
Comment 12 billy 2004-07-31 09:44:14 UTC
Kai, that change works for me as well, much appreciated.
If the login is looping because of the lack of a cookie, is the ultimate problem the fact that a cookie is not being set? My install does not attempt to set a cookie.
Comment 13 Stuart Herbert (RETIRED) gentoo-dev 2004-08-08 03:46:52 UTC
I've added Kai's fix as -r1.  Please test it, and let me know how you get on, so that I can close this bug ;-)

Best regards,
Stu
Comment 14 billy 2004-08-18 10:05:37 UTC
Just installed -r1 and it's working great.
Muchas gracias,
billy