Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 534728 - app-admin/eselect-opengl-1.3.1-r1 with app-emulation/emul-linux-x86-opengl-20140508-r1 and x11-drivers/nvidia-drivers - file collision in /usr/lib32/ /usr/lib32/
Summary: app-admin/eselect-opengl-1.3.1-r1 with app-emulation/emul-linux-x86-opengl-20...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2015-01-05 00:23 UTC by avx
Modified: 2015-03-01 10:14 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

Attachments (,6.33 KB, application/gzip)
2015-01-05 00:24 UTC, avx

Note You need to log in before you can comment on or make changes to this bug.
Description avx 2015-01-05 00:23:43 UTC
Trying to update above package fails for me with a file collision error on

* package app-emulation/emul-linux-x86-opengl-20140508-r1 NOT merged
 * Detected file collision(s):
 * 	/usr/lib32/
 * 	/usr/lib32/
 * Searching all installed packages for file collisions...
 * Press Ctrl-C to Stop
 * None of the installed packages claim the file(s).

equery b /usr/lib32/
 * Searching for /usr/lib32/ ... 
x11-drivers/nvidia-drivers-346.22 (/usr/lib32/opengl/nvidia/lib/

Reproducible: Always
Comment 1 avx 2015-01-05 00:24:42 UTC
Created attachment 393178 [details]

emerge --info

attached as it's bigger than max comment size(bug?)
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2015-01-05 07:44:29 UTC
That's because the symlinks would still be in place, I guess.

Please post your `emerge -vpq app-admin/eselect-opengl' output in a comment.
Comment 3 avx 2015-01-05 14:08:15 UTC
(In reply to Jeroen Roovers from comment #2)
> That's because the symlinks would still be in place, I guess.
> Please post your `emerge -vpq app-admin/eselect-opengl' output in a comment.

emerge -vpq app-admin/eselect-opengl
[ebuild   R   ] app-admin/eselect-opengl-1.3.1-r1 
[blocks B     ] <=app-emulation/emul-linux-x86-opengl-20140508 ("<=app-emulation/emul-linux-x86-opengl-20140508" is blocking app-admin/eselect-opengl-1.3.1-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-emulation/emul-linux-x86-opengl-20140508:0/0::gentoo, installed) pulled in by
    app-emulation/emul-linux-x86-opengl required by (app-emulation/emul-linux-x86-xlibs-20140508:0/0::gentoo, installed)
    ~app-emulation/emul-linux-x86-opengl-20140508 required by (app-emulation/emul-linux-x86-gtklibs-20140508-r6:0/0::gentoo, installed)
    app-emulation/emul-linux-x86-opengl[development,-abi_x86_32(-)] required by (app-emulation/wine-1.7.33:0/0::gentoo, installed)
    app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] required by (games-fps/unreal-tournament-goty-451:0/0::gentoo, installed)

  (app-admin/eselect-opengl-1.3.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-admin/eselect-opengl-1.3.0 required by (x11-base/xorg-server-, installed)
    >=app-admin/eselect-opengl-1.3.0 required by (media-libs/mesa-10.3.5-r1:0/0::gentoo, installed)
    >=app-admin/eselect-opengl-1.0.9 required by (x11-drivers/nvidia-drivers-346.22:0/0::gentoo, installed)
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2015-01-06 08:37:58 UTC
Looks like eselect-opengl should somehow have been called to clean up the symlinks.
Comment 5 avx 2015-01-06 13:38:05 UTC
Seems like it, yes. Ran `eselect opengl set xorg-x11 ; eselect opengl set nvidia` by hand and that seems to have fixed it, as after this the installation ran through.

According to the Changelog file:

 03 Jan 2015; Michał Górny <>
  Move files for new eselect-opengl framework

So maybe something got wrong here?

For me it seems to be solved, still I'm leaving it to more knowledgeable people if this bug should be closed.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-03-01 10:14:30 UTC
Sorry to disappoint you but FEATURES=collision-protect is something we can't help you with. You either have to disable it globally (and rely on FEATURES=protect-owned) or temporarily to get through the upgrade.