Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 53409 - sonar 1.2.2-r1 gives floating point error
Summary: sonar 1.2.2-r1 gives floating point error
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-09 07:06 UTC by Steev Klimaszewski (RETIRED)
Modified: 2005-01-12 01:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
strace output from running strace sonar (sonar.strace,2.08 KB, text/plain)
2004-06-09 07:09 UTC, Steev Klimaszewski (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steev Klimaszewski (RETIRED) gentoo-dev 2004-06-09 07:06:32 UTC
After emerging sonar 1.2.2-r1, running it, it just says Floating point error.

Reproducible: Always
Steps to Reproduce:
1.Emerge sonar
2.Run sonar.

Actual Results:  
equilibrium src # sonar
Floating point exception

Expected Results:  
should have output for me to give options for running sonar.

Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r0,
2.6.7-rc3)
=================================================================
System uname: 2.6.7-rc3 i686 Intel(R) Pentium(R) 4 CPU 2.66GHz
Gentoo Base System version 1.4.16
distcc 2.14 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632)
[disabled]Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache fixpackages sandbox"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa apm arts avi berkdb bonobo cdr cjk crypt cups doc dvd dvdr
encode esd flac foomaticdb gd gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2
gtkhtml imlib java jpeg ldap libg++ libwww mad mikmod mmx motif mozilla mpeg
mysql ncurses nls nptl oggvorbis opengl oss pam pdflib perl png python quicktime
readline samba scanner sdl slang spell sse sse2 ssl svga tcltk tcpd tetex tiff
truetype video_cards_radeon x86 xml xml2 xmms xv zlib"
Comment 1 Steev Klimaszewski (RETIRED) gentoo-dev 2004-06-09 07:09:20 UTC
Created attachment 32974 [details]
strace output from running strace sonar

Not really sure how to trouble shoot this.  I did recently change my cflags - i
don't remember what i had, but there was one more line, something about
-finline-something
Comment 2 Eldad Zack (RETIRED) gentoo-dev 2004-06-09 10:06:42 UTC
Try to emerge sonar again like this:
CFLAGS="-march=i386" emerge sonar

was your CFLAGS -finline-functions ?
Comment 3 Steev Klimaszewski (RETIRED) gentoo-dev 2004-06-09 10:17:20 UTC
yes, it was -finline-functions.

Emerged with CFLAGS="-march=i386" sudo emerge sonar 
Still getting floating point error.
Comment 4 Eldad Zack (RETIRED) gentoo-dev 2004-06-09 10:28:15 UTC
can you provide an "ltrace -C -dd" output?
Comment 5 Eldad Zack (RETIRED) gentoo-dev 2004-06-09 10:31:36 UTC
forget the request... my bad
Comment 6 Steev Klimaszewski (RETIRED) gentoo-dev 2004-06-09 10:43:06 UTC
Well, I emerged ltrace just in case, and I ran sonar through gdb, this is the output...

(gdb) run
Starting program: /usr/bin/sonar
warning: Unable to find dynamic linker breakpoint function.
GDB will be unable to debug shared library initializers
and track explicitly loaded dynamic code.

Program received signal SIGFPE, Arithmetic exception.
0x4000869c in ?? ()
Comment 7 Eldad Zack (RETIRED) gentoo-dev 2004-06-09 10:44:50 UTC
It seems that sonar is dying BEFORE all of the shared libraries are loaded.
Can you try to emerge a different sonar version (current stable x86), and also provide with ldd $(which sonar) ?

Comment 8 Steev Klimaszewski (RETIRED) gentoo-dev 2004-06-09 10:52:34 UTC
>>> net-analyzer/sonar-1.2.1 merged.

>>> clean: No packages selected for removal.

>>> Auto-cleaning packages ...

>>> No outdated packages were found on your system.


 * GNU info directory index is up-to-date.

equilibrium sonar # sonar
Floating point exception
equilibrium sonar # ldd $(which sonar)
        linux-gate.so.1 =>  (0xffffe000)
        libltdl.so.3 => /usr/lib/libltdl.so.3 (0x40032000)
        libdl.so.2 => /lib/libdl.so.2 (0x4003a000)
        libpopt.so.0 => /usr/lib/libpopt.so.0 (0x4003d000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x40045000)
        libc.so.6 => /lib/libc.so.6 (0x40056000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
Comment 9 Eldad Zack (RETIRED) gentoo-dev 2004-06-09 10:58:51 UTC
Did sonar ever worked for you?
Any similar problems with other packages you emerge now?
Comment 10 Steev Klimaszewski (RETIRED) gentoo-dev 2004-06-09 11:01:02 UTC
Honestly, I cannot ever remember running sonar - I remember I emerged it with the 1.22 release, and checked out the website, but never did anything with it till I was to do more reading.  No other programs are giving me any problems, as far as I can tell.
Comment 11 Eldad Zack (RETIRED) gentoo-dev 2004-06-14 08:06:36 UTC
I don't have many machines to QA on, but from what I did check I can't replicate this problem. 
It smells like a library that sonar loads causes the SIGFPE - I could be wrong though.
Comment 12 Daniel Black (RETIRED) gentoo-dev 2005-01-12 01:11:47 UTC
Bad news - I can replicate.

Worse news - seems dead upstream.

Unfortunate news - I don't care that much at this stage.

Submitted bug upstream just to show I care (a little).

emerge info
Portage 2.0.51-r8 (default-linux/x86/2004.3, gcc-3.4.3, glibc-2.3.4.20040808-r1, 2.6.10-gentoo-r2 i686)
=================================================================
System uname: 2.6.10-gentoo-r2 i686 AMD Athlon(tm) XP 1900+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Oct 24 2004, 08:06:09)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r5
sys-devel/automake:  1.8.5-r1
sys-devel/binutils:  2.15.90.0.1.1-r3
sys-devel/libtool:   1.5.2-r7
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-pipe"
CHOST="i686-pc-linux-gnu"