Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 533902 - media-libs/libjpeg-turbo: configure failure with /bin/sh != bash
Summary: media-libs/libjpeg-turbo: configure failure with /bin/sh != bash
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2014-12-29 10:45 UTC by Rémi Cardona
Modified: 2015-07-30 08:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,13.79 KB, text/plain)
2014-12-29 10:50 UTC, Rémi Cardona
Details
ebuild patch (patch,728 bytes, patch)
2015-01-03 16:23 UTC, Rémi Cardona
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2014-12-29 10:45:53 UTC
configure: creating ./config.status
...
config.status: creating Makefile
sed: file ./confstatUGWBur/subs-1.sed line 29: unterminated `s' command
...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/media-libs/libjpeg-turbo-1.3.1-r1/work/libjpeg-turbo-1.3.1 ...
 * abi_x86_64.amd64: running multilib-minimal_abi_src_compile
make -j4 
make: *** No targets.  Stop.

I have /bin/sh that points to dash and CONFIG_SHELL set to /bin/dash explicitly in make.conf.

Another weird thing is that the rest of the configure output has many blank lines. Bash output looks like:

checking for a BSD-compatible install... /usr/bin/install -c

Dash output looks like:

checking for a BSD-compatible install... 

	/usr/bin/install -c

(" " with bash, "\n\n\t" with dash) I have no idea if this is at all related.

Reproducible: Always
Comment 1 Rémi Cardona gentoo-dev 2014-12-29 10:50:15 UTC
Created attachment 392634 [details]
build.log
Comment 2 Rémi Cardona gentoo-dev 2015-01-03 16:23:24 UTC
Created attachment 393086 [details, diff]
ebuild patch

Here's an ebuild patch that fixes the issue. It also fixes the weird output issue.

In a nutshell, the patch forces eautoreconf all the time, so we get a fresh ./configure. The original configure was generated with autoconf 2.59 which is 11 years old.
Comment 3 Rémi Cardona gentoo-dev 2015-01-07 23:21:28 UTC
May I commit?
Comment 4 Jory A. Pratt gentoo-dev 2015-01-07 23:59:22 UTC
(In reply to Rémi Cardona from comment #3)
> May I commit?

Commit it.
Comment 5 Rémi Cardona gentoo-dev 2015-01-08 00:16:34 UTC
Pushed to portage without a revbump. Thanks
Comment 6 SpanKY gentoo-dev 2015-07-30 08:06:12 UTC
Commit message: Set CONFIG_SHELL directly instead of regenerating autotools as it will be faster and less flaky (like libtool version mismatches)
http://sources.gentoo.org/media-libs/libjpeg-turbo/libjpeg-turbo-1.4.1.ebuild?r1=1.1&r2=1.2