Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 532402 - www-apache/mod_authnz_external-3.3.2 version bump
Summary: www-apache/mod_authnz_external-3.3.2 version bump
Status: RESOLVED DUPLICATE of bug 460438
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-12 23:49 UTC by smkbot
Modified: 2014-12-13 09:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description smkbot 2014-12-12 23:49:59 UTC
www-apps/mod_authnz_external has a single ebuild in the tree, version 3.2.6. This version is compatible with Apache 2.2.

Apache 2.4 is in the tree, and people who have installed it need to install mod_authnz_external version 3.3.x (current upstream version is 3.3.2) in order to have a compatible version.

This should be added as www-apache/mod_authnz_external-3.3.2.ebuild:




inherit eutils apache-module

DESCRIPTION="An Apache2 authentication DSO using external programs"
HOMEPAGE="http://code.google.com/p/mod-auth-external/"
SRC_URI="http://mod-auth-external.googlecode.com/files/${P}.tar.gz"

LICENSE="Apache-1.1"
SLOT="2"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND=""
RDEPEND=""

DOCFILES="AUTHENTICATORS CHANGES INSTALL INSTALL.HARDCODE README TODO UPGRADE"

APACHE2_MOD_CONF="10_${PN}"
APACHE2_MOD_DEFINE="AUTHNZ_EXTERNAL"

need_apache2_4

Reproducible: Always

Steps to Reproduce:
1. Install Apache 2.4
2. No compatible mod_authnz_external ebuilds are avaialble
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2014-12-13 09:01:26 UTC

*** This bug has been marked as a duplicate of bug 460438 ***