Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 532200 - sys-boot/grub:2 grub2-mkconfig fails with /bin/sh -> dash
Summary: sys-boot/grub:2 grub2-mkconfig fails with /bin/sh -> dash
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2014-12-10 21:07 UTC by Rémi Cardona
Modified: 2015-07-23 14:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2014-12-10 21:07:53 UTC
# grub2-mkconfig -o /boot/grub/grub.cfg 
Generating grub configuration file ...
Found linux image: -n
basename: invalid option -- 'n'
Try 'basename --help' for more information.

Changing the hashbang to /bin/bash in /etc/grub.d/10_linux works around the issue.

# grub2-mkconfig -o /boot/grub/grub.cfg 
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.17.3-gentoo
Found linux image: /boot/vmlinuz-3.16.3-gentoo
done
Comment 2 Mike Gilbert gentoo-dev 2014-12-11 01:30:29 UTC
(In reply to Alexander Tsoy from comment #1)
> Upstream fix:
> http://git.savannah.gnu.org/cgit/grub.git/commit/
> ?id=cdae5bf208f5fa6093fa34c978c5da7b5bbafc54

Thanks for pointing that out!

+*grub-2.02_beta2-r6 (11 Dec 2014)
+
+  11 Dec 2014; Mike Gilbert <floppym@gentoo.org> +grub-2.02_beta2-r6.ebuild,
+  -grub-2.02_beta2-r5.ebuild:
+  Backport patch to remove bashisms in grub-mkconfig, bug 532200 by Rémi
+  Cardona.
Comment 3 Rémi Cardona gentoo-dev 2014-12-11 08:40:44 UTC
\o/ thanks to both of you!
Comment 4 Mike Gilbert gentoo-dev 2015-07-23 14:35:17 UTC
*** Bug 555700 has been marked as a duplicate of this bug. ***