Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 531682 - app-emulation/vmware-workstation-11.0.0.2305329 version bump
Summary: app-emulation/vmware-workstation-11.0.0.2305329 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-04 15:17 UTC by cyshei
Modified: 2016-03-20 18:08 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
New vmware-modules patchset (patches.tar.gz,4.95 KB, application/gzip)
2015-01-13 15:47 UTC, Daniel Augustin
Details
vmware-modules-304.0.ebuild (vmware-modules-304.0.ebuild,2.52 KB, text/plain)
2015-01-13 15:48 UTC, Daniel Augustin
Details
vmware-tools-9.9.0.2305329.ebuild (vmware-tools-9.9.0.2305329.ebuild,1.49 KB, text/plain)
2015-01-13 15:48 UTC, Daniel Augustin
Details
vmware-workstation-11.0.0.2305329.ebuild (vmware-workstation-11.0.0.2305329.ebuild,13.91 KB, text/plain)
2015-01-13 15:48 UTC, Daniel Augustin
Details
vmware-11.0.rc (vmware-11.0.rc,743 bytes, text/plain)
2015-01-13 15:49 UTC, Daniel Augustin
Details
new vmware-modules with extra CFLAG filters (vmware-modules-304.0.ebuild,2.53 KB, text/plain)
2015-01-25 06:10 UTC, Garth
Details
patch with fixed vmnet module with linux-3.19 (3.19-vmnet-only.patch,1.91 KB, patch)
2015-02-15 01:33 UTC, Harris Landgarten
Details | Diff
patch fixes some vmblock issues with linux-3.19 (vmblock-319.patch,705 bytes, patch)
2015-02-15 01:35 UTC, Harris Landgarten
Details | Diff
patch fixes struct nameidata issues with vmblock and linux-3.19 (vmblock-nameidata-319.patch,2.07 KB, patch)
2015-02-15 01:36 UTC, Harris Landgarten
Details | Diff
vmware-tools ebuild for 11.1.0 (vmware-tools-9.9.2.2496824.ebuild,1.49 KB, text/plain)
2015-03-23 02:53 UTC, Harris Landgarten
Details
vmware-workstation-11.1.0.2496824.ebuild (vmware-workstation-11.1.0.2496824.ebuild,13.91 KB, text/plain)
2015-03-25 19:46 UTC, Daniel Augustin
Details
vmware-tools-9.9.2.2496824.ebuild (vmware-tools-9.9.2.2496824.ebuild,1.49 KB, text/plain)
2015-03-25 19:47 UTC, Daniel Augustin
Details
vmware-modules-304.1.ebuild (vmware-modules-304.1.ebuild,2.74 KB, text/plain)
2015-03-25 19:47 UTC, Daniel Augustin
Details
304-vmblock-3.19.patch (304-vmblock-3.19.patch,2.76 KB, patch)
2015-03-25 19:48 UTC, Daniel Augustin
Details | Diff
304-vmnet-3.19.patch (304-vmnet-3.19.patch,1.91 KB, patch)
2015-03-25 19:48 UTC, Daniel Augustin
Details | Diff
vmware-11.1.rc (vmware-11.1.rc,743 bytes, text/plain)
2015-03-25 19:49 UTC, Daniel Augustin
Details
vmware-modules-304.1.ebuild (vmware-modules-304.1.ebuild,2.77 KB, text/plain)
2015-03-29 14:01 UTC, Daniel Augustin
Details
304-vmblock-3.18.patch (304-vmblock-3.18.patch,2.76 KB, patch)
2015-03-29 14:02 UTC, Daniel Augustin
Details | Diff
vmware-11.1.rc (vmware-11.1.rc,904 bytes, text/plain)
2015-06-21 23:23 UTC, Garth
Details
vmware-workstation-11.1.0.2496824.ebuild (vmware-workstation-11.1.0.2496824.ebuild,13.92 KB, text/plain)
2015-06-21 23:29 UTC, Garth
Details
vmblock-patch for kernel 4.2 (linux-4.2-inode.patch,1.49 KB, patch)
2015-08-31 19:23 UTC, Harris Landgarten
Details | Diff
vmnet patch for kernel 4.2 (linux-4.2-vmnet.patch,903 bytes, patch)
2015-08-31 19:25 UTC, Harris Landgarten
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description cyshei 2014-12-04 15:17:53 UTC
VMware Workstation 11 was released on Dec. 1, and it would be nice to get an updated ebuild for it.

Reproducible: Always
Comment 1 Billy DeVincentis 2014-12-13 01:45:24 UTC
Tried renaming the ebuild, (just to point out X86 support has been dropped in this version) that worked but very strange as far as the vmware-modules ebuild is concerned. 11 requires modules version 279.0, not sure how that can be or if I did something wrong. Tried renaming my current ebuild 279.4 for the latest 10 series but several patches did not work and could not get it fixed. Maybe when I have more time
Comment 2 Harris Landgarten 2014-12-13 04:52:36 UTC
From what I have read, the modules with 11 are supposed to work with the 3.17 and 3.18 kernels with no patches. I assume the modules are in the bundle but not sure how to get to them. I also read it is designed to work with the kernel supplied modules.

The dependence on 279 modules comes from the pdepend line in the renamed ebuild which I assume needs to be changed for the newer modules.
Comment 3 Harris Landgarten 2014-12-14 22:16:46 UTC
Just to get things working I created a 280.0 vmware-modules that changed the workstation ebuild pdepend for it.

I also created a 9.9.2305329 vmware-tools ebuild my just renaming the old one.

The vmware-modules-280.0.ebuild needs the following patches.

src_prepare() {
	epatch "${FILESDIR}/${PV_MAJOR}-makefile-kernel-dir.patch"
	epatch "${FILESDIR}/${PV_MAJOR}-makefile-include.patch"
	epatch "${FILESDIR}/${PV_MAJOR}-netdevice.patch"
	use pax_kernel && epatch "${FILESDIR}/279-hardened.patch"
	epatch "${FILESDIR}/${PV_MAJOR}-apic.patch"
	
	kernel_is ge 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
    kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-vmblock.patch"
    kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-00-userns.patch"
    kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-01-getname.patch"
    kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-04-dentry.patch"
    kernel_is ge 3 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.10-05-inode.patch"
    kernel_is ge 3 11 0 && epatch "${FILESDIR}/${PV_MAJOR}-filldir.patch"
    kernel_is ge 3 15 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.15-00-readlink.patch"
    kernel_is ge 3 15 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.15-01-vsock.patch"

	# Allow user patches so they can support RC kernels and whatever else
	epatch_user
}

I also had to cp all the 279 patches to 280 equivalents in the files dir.

I am now running 11 with no issues. tools upgraded and all the modules load and run.

We know it works so it should be easy to get into the tree.
Comment 4 Billy DeVincentis 2014-12-15 01:10:50 UTC
I emerge workstation but modules fails

make[1]: Entering directory `/lib/modules/3.17.4-gentoo/build'
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/linux/driver.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/linux/vmciKernelIf.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciDriver.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciResource.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciContext.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciDatagram.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciHashtable.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciEvent.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciQueuePair.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciDoorbell.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciQPair.o
/var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/linux/driver.c: In function ‘LinuxDriver_Ioctl’:
/var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/linux/driver.c:738:12: error: incompatible types when assigning to type ‘VMCIHostUser’ from type ‘uid_t’
       user = from_kuid(current_user_ns(), current_uid());
            ^
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/common/vmciRoute.o
/usr/src/linux-3.17.4-gentoo/scripts/Makefile.build:257: recipe for target '/var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/linux/driver.o' failed
make[3]: *** [/var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only/linux/driver.o] Error 1
make[3]: *** Waiting for unfinished jobs....
/usr/src/linux-3.17.4-gentoo/Makefile:1373: recipe for target '_module_/var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only' failed
make[2]: *** [_module_/var/tmp/portage/app-emulation/vmware-modules-280.0/work/vmci-only] Error 2
Makefile:181: recipe for target 'sub-make' failed
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-3.17.4-gentoo'
Makefile:120: recipe for target 'vmci.ko' failed
make: *** [vmci.ko] Error 2
 * ERROR: app-emulation/vmware-modules-280.0::miscellaneous failed (compile phase):
 *   emake failed
Comment 5 Harris Landgarten 2014-12-15 03:26:34 UTC
I use vmci and vsock modules from the kernel and use= -vsock -vmci

Note if you do this the vmci module will be called vmw_vmci and you have to change the systemd vmci service to reference the right module name
Comment 6 Billy DeVincentis 2014-12-16 02:27:55 UTC
Did just as you said
It's working!!
Comment 7 Billy DeVincentis 2014-12-30 01:32:35 UTC
just realized I'm getting a new problem, when I try to autostart a vm using vmrun, here is what happens

billydv@linux1 ~ $ /opt/vmware/bin/vmrun start "/Virtual_Machines/My Virtual Machines/Vm-Lin1-Gentoo/Vm-Lin1-Gentoo.vmx" gui
Unable to connect to host.
Error: The specified version was not found
Comment 8 Harris Landgarten 2014-12-30 03:05:51 UTC
I always run my vms in a scope using the machine.slice. I don't know that it makes any real difference but restarting is not a problem.

Here is the command:

systemd-run --scope --unit=vmware --slice=machine vmware

That will bring up vmware in it own scope.

After I am done

systemctl stop vmware.scope

and you are ready to run the first command again to restart

I hope this helps.
Comment 9 Billy DeVincentis 2015-01-05 04:33:17 UTC
problem with vmrun was this in ebuild

if use vix; then
		vmware-bundle_extract-bundle-component "${bundle}" vmware-vix-core vmware-vix
		vmware-bundle_extract-bundle-component "${bundle}" vmware-vix-lib-Workstation1100andvSphere600 vmware-vix

the numbers 1000 had to be replaced with 1100 and vsphere to 600

now it works
Comment 10 Daniel Augustin 2015-01-13 15:47:35 UTC
Created attachment 393860 [details]
New vmware-modules patchset
Comment 11 Daniel Augustin 2015-01-13 15:48:09 UTC
Created attachment 393862 [details]
vmware-modules-304.0.ebuild
Comment 12 Daniel Augustin 2015-01-13 15:48:37 UTC
Created attachment 393864 [details]
vmware-tools-9.9.0.2305329.ebuild
Comment 13 Daniel Augustin 2015-01-13 15:48:54 UTC
Created attachment 393866 [details]
vmware-workstation-11.0.0.2305329.ebuild
Comment 14 Daniel Augustin 2015-01-13 15:49:08 UTC
Created attachment 393868 [details]
vmware-11.0.rc
Comment 15 Daniel Augustin 2015-01-13 15:51:55 UTC
I created new vmware workstation 11 ebuilds.

Changes I made:

I removed support for vmci and vsock as external modules. They don't seem to build (see comments) and all stable kernels in tree have mainline support. I changed the ebuild to require the config options and attached a new vmware-11.0.rc file that only loads the non-mainline modules.

If you currently have vmware-modules WITH the useflags, don't forget to delete the modules in /misc and run depmod -a.

I also sorted the patches, removed unnecessary ones and strippoed them down to only patch the remaining modules.

Removed support for x86 and changed a lot of version strings.
Comment 16 Daniel Augustin 2015-01-13 15:53:46 UTC
It also depends on /usr/lib64/libgtop-2.0.so.7, in gmt-vmware overlay there is an ebuild for that (gentoo tree doesn't have a proper version for that anymore).

This is available here: https://raw.githubusercontent.com/gmt/gmt-vmware-overlay/master/gnome-base/libgtop-compat/libgtop-compat-2.28.5-r1.ebuild
Comment 17 Garth 2015-01-25 06:10:11 UTC
Created attachment 394828 [details]
new vmware-modules with extra CFLAG filters

It seems some CFLAGS causes the following error:
 "/var/tmp/portage/app-emulation/vmware-modules-279.3-r1/work/vmmon-only/linux/driver.c:1252:4: error: too many arguments to function ‘smp_call_function’".

This new vmware-modules ebuild add flag filtering for the ones I could find out about.
Comment 18 Garth 2015-01-25 06:21:31 UTC
The ebuild I just sent uses flag filtering to get rid of a problem, but it does seems like a bit of a workaround to me. I don't have the required knowledge to really fix this, but if someone wants to give it a try, here's what I could find out.


The test done to check if the kernel has a 3 or 4 arguments smp_call_function() fails with some CFLAGS. I've experienced it with -msse4.1 , but according to comment 41 on bug #462666 , all of: "-msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mf16c -mpclmul" would cause it. With the guilty CFLAGS, the following error is generated:
/var/tmp/portage/app-emulation/vmware-modules-304.0/work/vmmon-only/./autoconf/smpcall.c:1:0: error: -mpreferred-stack-boundary=3 is not between 4 and 12

Which prevents the makefile from adding the crucial "-DVMW_HAVE_SMP_CALL_3ARG" which is used by "linux/vmmonInt.h" to define if compat_smp_call_function() uses 3 or 4 arguments to call smp_call_function().


Now, the "-mpreferred-stack-boundary=3" was automatically added from somewhere, but I don't know where, it was not in my CFLAGS (which are: "-march=core2 -mtune=core2 -msse4.1 -O2 -fforce-addr -pipe").
Comment 19 Matthew Marlowe gentoo-dev 2015-01-29 04:07:17 UTC
Anyone in the vmware team working on this?  I can do help and do some testing/etc -- finally got rid of my 8yr old system that could barely run workstation 8, there wasn't any point in helping out with the vmware stuff before but now I have a very fast modern box and I'd be happy to do what I can to help with getting workstation 11 ebuilds supported and stable.

Current system is running kernel 3.17
Comment 20 Matthew Marlowe gentoo-dev 2015-01-29 14:31:54 UTC
Spent a few hours trying to work through all the issues with workstation 11:

- created a repo on github, latest changes haven't been pushed yet, but prior testing is based on: https://github.com/deploylinux/mattmGentooDevRepo

- workstation, modules, and tools all installed w/o issue, and the vmware gui also ran.

- However, there were a host of problems, including:
* the init scripts were not copied properly and were essentially blank
* the links to openssl libraries were not set properly
* some commands gave exec errors, was workstation expecting some emulation x86 libs that existed that weren't on my test box?
* the tool to configure the virtual networks just didn't work

- Lastly, the dependency on the newer libgcrypt is almost a showstopper as it breaks so many other ebuilds.
Comment 21 Harris Landgarten 2015-02-11 20:23:24 UTC
I am trying to get vmblock to compile with kernel-3.19 and it is failing with errors related to;

struct nameidata actualNd;

I fails with storage size of actualNd is not known.

This issue appears to be that the declaration of struct nameidata is no longer in namei.h as it was prior. I can't find it anywhere in include/linux.

Any ideas?
Comment 22 Harris Landgarten 2015-02-13 12:29:46 UTC
After reading all the sources I figured out what changed in the namei api. As of 3.19 struct nameidata is no longer exported and only existed locally in the fs/namei.c file.

Therefore any code the was using struct nameidata no longer works.

I reworked dentry.c, filesystem.c and shared/namei.h to use struct path directly.

That is now working.

I will try to put some patched together later today for this issue as well as the other patches needed to run vmware-workstation-11 under kernel 3.19
Comment 23 Harris Landgarten 2015-02-15 01:33:11 UTC
Created attachment 396480 [details, diff]
patch with fixed vmnet module with linux-3.19
Comment 24 Harris Landgarten 2015-02-15 01:35:36 UTC
Created attachment 396482 [details, diff]
patch fixes some vmblock issues with linux-3.19
Comment 25 Harris Landgarten 2015-02-15 01:36:41 UTC
Created attachment 396484 [details, diff]
patch fixes struct nameidata issues with vmblock and linux-3.19
Comment 26 Harris Landgarten 2015-02-15 01:39:42 UTC
I posted the three patches I am using to get vmware-modules to build with linux-3.19

They fix vmnet and vmblock which will not build under linux-3.19

note I am using vmci and vsock from the kernel.
Comment 27 Kenton Groombridge 2015-03-06 01:39:28 UTC
vmware-workstation 11.1 was released on 17 Feb.  Renaming these file names was enough to build and install.
Comment 28 Billy DeVincentis 2015-03-23 02:42:35 UTC
What is the modules number version for 11.1?
Comment 29 Harris Landgarten 2015-03-23 02:51:27 UTC
you can use the same ebuild as 11.0 for modules. Just make sure the depends match up to the right build number for workstation-11.1.0

I am uploading the ebuild for the vmware-tools that goes with 11.1.0
Comment 30 Harris Landgarten 2015-03-23 02:53:36 UTC
Created attachment 399520 [details]
vmware-tools ebuild for 11.1.0

This is the ebuild for vmware-tools that goes with 11.1.0
Comment 31 Billy DeVincentis 2015-03-24 23:12:10 UTC
Here is the line for modules

PDEPEND="~app-emulation/vmware-modules-304.${PV_MINOR}

Is it still 304 for 11.1?
Comment 32 Billy DeVincentis 2015-03-24 23:52:08 UTC
Please post the new ebuilds for vmware-workstation and vmware-modules for 11.1
Comment 33 Daniel Augustin 2015-03-25 19:45:45 UTC
I have attached new ebuilds.

I added the new filters from Garth, added the patches from Harris Landgarten (untested, please test someone with 3.19!) and adjusted version for use with 11.1.

Don't forget to copy

vmware-11.0.rc
vmware-server-11.0.rc

in the files directory of vmware-workstation to 11.1 (otherwise your init script is empty).
Comment 34 Daniel Augustin 2015-03-25 19:46:44 UTC
Created attachment 399760 [details]
vmware-workstation-11.1.0.2496824.ebuild
Comment 35 Daniel Augustin 2015-03-25 19:47:14 UTC
Created attachment 399762 [details]
vmware-tools-9.9.2.2496824.ebuild
Comment 36 Daniel Augustin 2015-03-25 19:47:49 UTC
Created attachment 399764 [details]
vmware-modules-304.1.ebuild
Comment 37 Daniel Augustin 2015-03-25 19:48:15 UTC
Created attachment 399766 [details, diff]
304-vmblock-3.19.patch
Comment 38 Daniel Augustin 2015-03-25 19:48:35 UTC
Created attachment 399768 [details, diff]
304-vmnet-3.19.patch
Comment 39 Daniel Augustin 2015-03-25 19:49:19 UTC
Created attachment 399770 [details]
vmware-11.1.rc
Comment 40 Daniel Augustin 2015-03-29 14:01:15 UTC
vmware-modules didnt work right with 3.18. Here is a new version.
Comment 41 Daniel Augustin 2015-03-29 14:01:53 UTC
Created attachment 400032 [details]
vmware-modules-304.1.ebuild
Comment 42 Daniel Augustin 2015-03-29 14:02:30 UTC
Created attachment 400034 [details, diff]
304-vmblock-3.18.patch
Comment 43 Harris Landgarten 2015-04-13 15:58:03 UTC
vmware-modules with the patches I posted work with kernel-4.0.0 without issue.
Comment 44 Cameron 2015-05-18 00:46:01 UTC
Thank you everyone. 11.1 is running nicely for me on KDE stable.
Comment 45 Garth 2015-06-21 23:23:44 UTC
Created attachment 405520 [details]
vmware-11.1.rc

News vmware-11.1.rc which attempts to load quietly the following modules: vmw_vmci, vsock, vmw_vsock_vmci_transport.

vmware-modules ebuild checks that the kernel configuration has them, but they can be built-in or modules. This new rc script attempts to load them, that way if they are modules they'll get loaded and vmware will work (otherwise it complains about missing VMCI modules when a virtual machine is started).

I'm using modprobe's "-q" option, so if they fail to load or unload, it fails silently, which could be a problem. If someone knows of a better way, please improve.
Comment 46 Garth 2015-06-21 23:29:30 UTC
Created attachment 405522 [details]
vmware-workstation-11.1.0.2496824.ebuild

I've changed the RDEPEND of libgcrypt to use :/0/11 instead of :11 , and changed the EAPI to 5 (so it would work). This allows use the of the currently stable libgcrypt-1.5.4-r1, making install much easier (the -r100 that was otherwise asked caused multiple conflicts on my mostly stable system), and as far as I can tell, everything works with this dependency.
Comment 47 Evan Teran 2015-07-10 23:32:21 UTC
Hi guys, I just pushed vmware-modules-304 and vmware-workstation-11.1.0.2496824 to the official vmware overlay.

It should compile and function on kernels 3.10 - 4.0.

Please let me know if you have any issues.
Comment 48 Billy DeVincentis 2015-07-18 12:30:42 UTC
Hi Evan Teran,
  Just a couple of problems with the ebuilds you put in the overlay. I can only speak of vmware-workstation, vmware-modules, vmware-tools. First off, there were no manifests in any of those folders. Second, you are missing a bunch of files from the vmware-workstation files folder, here is what you should have:

configure-hostd.sh, list-component-files.xsl, vmware-11.0.rc, vmware-server-10.0.rc, vmware-server-11.1.rc, vmware-server-9.0.rc, list-bundle-components.xsl,  vmware-10.0.rc, vmware-11.1.rc, vmware-9.0.rc, vmware-server-11.0.rc  

Next you have an error in the ebuild for vmware-workstation-11.1.2.2780323
versions are wrong
replace this line 

vmware-bundle_extract-bundle-component "${bundle}" vmware-vix-lib-Workstation1000andvSphere550 vmware-vix


with this

vmware-bundle_extract-bundle-component "${bundle}" vmware-vix-lib-Workstation1100andvSphere600 vmware-vix
Comment 49 Billy DeVincentis 2015-07-18 13:37:06 UTC
Just wanted to report allcompiles and works properly with linux 4.1.2
Comment 50 Evan Teran 2015-07-19 01:40:36 UTC
All seem like easy fixes. I'll try to get them in there ASAP :-)
Comment 51 Evan Teran 2015-07-19 01:55:55 UTC
Billy DeVincentis,

OK, I've made sure that the files you mentioned are now in the layman. And have updated the ebuild to use the correct version for the VIX component.

As far as the manifest. vmware-modules isn't supposed to have one as far as I know because it doens't download any files itself. Instead, it just pulls the tars which are in /opt/vmware/lib/vmware/modules/source/
Comment 52 Peter Leugner 2015-07-21 17:42:44 UTC
I get the following error, wehn I try to install vmware-player:

>>> Install vmware-player-7.1.2.2780323 into /tmp/portage/app-emulation/vmware-player-7.1.2.2780323/image/ category app-emulation
 *      /tmp/portage/app-emulation/vmware-player-7.1.2.2780323/image//opt/vmware/lib/vmware/bin/vmware-vmx
 TYPE    PAX   FILE 
ET_EXEC PeMRxS /tmp/portage/app-emulation/vmware-player-7.1.2.2780323/image//opt/vmware/lib/vmware/bin/vmware-vmx 
sed: can't read /var/lib/layman/vmware/app-emulation/vmware-player/files/vmware-3.0.rc: No such file or directory
 * ERROR: app-emulation/vmware-player-7.1.2.2780323::vmware failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_install
 *   environment, line 2575:  Called die
 * The specific snippet of code:
 *       sed -e "s:@@BINDIR@@:${VM_INSTALL_DIR}/bin:g" "${FILESDIR}/vmware-3.0.rc" > "${initscript}" || die;
 * 
 * If you need support, post the output of `emerge --info '=app-emulation/vmware-player-7.1.2.2780323::vmware'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/vmware-player-7.1.2.2780323::vmware'`.
 * The complete build log is located at '/tmp/portage/app-emulation/vmware-player-7.1.2.2780323/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/app-emulation/vmware-player-7.1.2.2780323/temp/environment'.
 * Working directory: '/tmp/portage/app-emulation/vmware-player-7.1.2.2780323/work'
 * S: '/tmp/portage/app-emulation/vmware-player-7.1.2.2780323/work'
Comment 53 Evan Teran 2015-07-21 18:31:02 UTC
Thanks, vmware-player should be fixed in the next day or so depending on my schedule.
Comment 54 Billy DeVincentis 2015-08-19 01:50:18 UTC
Just updated to kde 5. No more tray icon. Does anyone have a way to get the tray icon back?
Comment 55 David Carlos Manuelda 2015-08-20 19:17:24 UTC
Not sure if I need to report it here, but I'm using it inside vmware overlay, and when I install on Windows7 and Windows10, vmware tools, I get a NULL kernel dereference and a system crash with kernel 4.1.5

Aug 20 18:40:33 Zero kernel: BUG: unable to handle kernel NULL pointer dereference at 000000000000009d
Aug 20 18:40:33 Zero kernel: IP: [<ffffffffa03442d9>] VMCISock_GetAFValue+0x6a9/0xd10 [vsock]
Aug 20 18:40:33 Zero kernel: PGD 0 
Aug 20 18:40:33 Zero kernel: Oops: 0000 [#1] PREEMPT SMP 
Aug 20 18:40:33 Zero kernel: Modules linked in: vmnet(O) vmblock(O) vsock(O) vmmon(O) vmci(O) cmac ecb rfcomm ctr ccm ipv6 bnep binfmt_misc pinctrl_cherryview intel_rst intel_ips bbswitch(O) efivarfs btrfs xor raid6_pq raid0 md_mod ath3k btusb btbcm btintel bluetooth sr_mod sd_mod cdrom joydev mousedev hid_generic usbhid hid snd_hda_codec_realtek snd_hda_codec_generic arc4 psmouse atkbd libps2 msi_wmi sparse_keymap x86_pkg_temp_thermal intel_powerclamp snd_hda_intel coretemp hwmon snd_hda_controller ath9k snd_hda_codec led_class snd_hwdep snd_hda_core ath9k_common ath9k_hw kvm_intel i915 ath mac80211 fbcon xhci_pci xhci_hcd evdev cfbfillrect bitblit cfbimgblt softcursor i2c_algo_bit cfbcopyarea kvm ehci_pci ehci_hcd cfg80211 drm_kms_helper microcode snd_pcm ahci libahci libata lpc_ich fb fbdev snd_timer mfd_core
Aug 20 18:40:33 Zero kernel:  snd drm i2c_i801 soundcore scsi_mod usbcore rfkill intel_gtt efivars pcspkr i2c_core usb_common thermal battery ac i8042 serio video wmi backlight button processor thermal_sys [last unloaded: nvidia]
Aug 20 18:40:33 Zero kernel: CPU: 1 PID: 9892 Comm: vmware Tainted: P           O    4.1.5-gentoo #1
Aug 20 18:40:33 Zero kernel: Hardware name: Micro-Star International Co., Ltd. GT70 2PE/MS-1763, BIOS E1763IMS.51B 01/29/2015
Aug 20 18:40:33 Zero kernel: task: ffff8805a0b04000 ti: ffff88008dd98000 task.ti: ffff88008dd98000
Aug 20 18:40:33 Zero kernel: RIP: 0010:[<ffffffffa03442d9>]  [<ffffffffa03442d9>] VMCISock_GetAFValue+0x6a9/0xd10 [vsock]
Aug 20 18:40:33 Zero kernel: RSP: 0018:ffff88008dd9bd28  EFLAGS: 00010246
Aug 20 18:40:33 Zero kernel: RAX: ffff88008dd9bd60 RBX: 00000000ffffffa1 RCX: 0000000000000000
Aug 20 18:40:33 Zero kernel: RDX: 0000000000000055 RSI: ffff88008dd9bdc8 RDI: ffff8807234cea80
Aug 20 18:40:33 Zero kernel: RBP: ffff88008dd9bf18 R08: ffff8807c7b70e00 R09: ffff8807234cea80
Aug 20 18:40:33 Zero kernel: R10: 000055f249a6c214 R11: 0000000000000293 R12: 000055f24a9edea0
Aug 20 18:40:33 Zero kernel: R13: 0000000000000055 R14: 000055f24a5cf570 R15: 0000000000000055
Aug 20 18:40:33 Zero kernel: FS:  00007f3ad41bf740(0000) GS:ffff8807efa40000(0000) knlGS:0000000000000000
Aug 20 18:40:33 Zero kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Aug 20 18:40:33 Zero kernel: CR2: 000000000000009d CR3: 0000000046b1d000 CR4: 00000000001406e0
Aug 20 18:40:33 Zero kernel: Stack:
Aug 20 18:40:33 Zero kernel:  00007fffd4a32730 0000000000000040 ffff88008dd9be00 ffff8805ad450c80
Aug 20 18:40:33 Zero kernel:  0000000000000000 ffff8805a0b04000 ffffffff81086ae0 ffff88008dd9bd60
Aug 20 18:40:33 Zero kernel:  ffff88008dd9bd60 0000000021aff242 000055f249d36444 ffff88008dd9be78
Aug 20 18:40:33 Zero kernel: Call Trace:
Aug 20 18:40:33 Zero kernel:  [<ffffffff81086ae0>] ? wait_woken+0x80/0x80
Aug 20 18:40:33 Zero kernel:  [<ffffffff813524b2>] ? sock_sendmsg+0x12/0x30
Aug 20 18:40:33 Zero kernel:  [<ffffffff81352556>] ? sock_write_iter+0x86/0x100
Aug 20 18:40:33 Zero kernel:  [<ffffffff81145246>] ? __vfs_write+0xd6/0x130
Aug 20 18:40:33 Zero kernel:  [<ffffffff81145a4f>] ? vfs_write+0x9f/0x1b0
Aug 20 18:40:33 Zero kernel:  [<ffffffff81161540>] ? __fget_light+0x20/0x60
Aug 20 18:40:33 Zero kernel:  [<ffffffff8114677d>] ? SyS_write+0x4d/0xc0
Aug 20 18:40:33 Zero kernel:  [<ffffffff8140b22e>] ? system_call_fastpath+0x12/0x71
Aug 20 18:40:33 Zero kernel: Code: 20 00 00 00 00 65 48 8b 04 25 40 b8 00 00 48 89 44 24 28 48 8d 44 24 38 48 c7 44 24 30 e0 6a 08 81 48 89 44 24 38 48 89 44 24 40 <f6> 42 48 01 75 2c 31 f6 4c 89 ff 48 89 cd e8 84 19 01 e1 41 8b 
Aug 20 18:40:33 Zero kernel: RIP  [<ffffffffa03442d9>] VMCISock_GetAFValue+0x6a9/0xd10 [vsock]
Aug 20 18:40:33 Zero kernel:  RSP <ffff88008dd9bd28>
Aug 20 18:40:33 Zero kernel: CR2: 000000000000009d
Aug 20 18:40:33 Zero kernel: ---[ end trace 364dbcf76d2d082b ]---
Comment 56 Billy DeVincentis 2015-08-26 01:44:27 UTC
Workstation 12 is out. Would love to get it going but renaming the ebuild fails immediately

>>> Emerging (1 of 2) app-emulation/vmware-workstation-12.0.0.2985596::miscellaneous
 * VMware-Workstation-12.0.0-2985596.x86_64.bundle.tar SHA256 SHA512 WHIRLPOOL size ;-) ...                                                            [ ok ]
 * gentoo-01.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                               [ ok ]
>>> Unpacking source...
>>> Unpacking VMware-Workstation-12.0.0-2985596.x86_64.bundle.tar to /var/tmp/portage/app-emulation/vmware-workstation-12.0.0.2985596/work
>>> Unpacking gentoo-01.tar.gz to /var/tmp/portage/app-emulation/vmware-workstation-12.0.0.2985596/work
 * Extracting 'vmware-vmx' component from 'VMware-Workstation-12.0.0-2985596.x86_64.bundle' ...
...........................
gzip: stdin: unexpected end of file
 * ERROR: app-emulation/vmware-workstation-12.0.0.2985596::miscellaneous failed (unpack phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_unpack
 *   environment, line 3153:  Called vmware-bundle_extract-bundle-component 'VMware-Workstation-12.0.0-2985596.x86_64.bundle' 'vmware-vmx' '/var/tmp/portage/app-emulation/vmware-workstation-12.0.0.2985596/work'
 *   environment, line 4184:  Called vmware-bundle_extract-component 'VMware-Workstation-12.0.0-2985596.x86_64.bundle' '/var/tmp/portage/app-emulation/vmware-workstation-12.0.0.2985596/work' '13351020'
 *   environment, line 4220:  Called die
 * The specific snippet of code:
 *               tail -c+$((offset+component_dataOffset+file_offset+1)) "${component}" 2> /dev/null | head -c$((file_compressedSize)) | gzip -cd > "${file_path}" || die;
Comment 57 Evan Teran 2015-08-29 19:14:07 UTC
@Billy DeVincentis,

if you would like to have the version bumped to 12, please open a separate issue for it so it can be properly tracked. Thanks
Comment 58 Harris Landgarten 2015-08-31 19:23:56 UTC
Created attachment 410716 [details, diff]
vmblock-patch for kernel 4.2

Fixes inode.c in vmblock for kernel 4.2
Comment 59 Harris Landgarten 2015-08-31 19:25:04 UTC
Created attachment 410718 [details, diff]
vmnet patch for kernel 4.2

patches vmnet for kernel 4.2
Comment 60 Manfred Knick 2015-09-07 10:25:17 UTC
Proposal
concerning overlay : 
vmware-workstation-11.1.2.2780323.ebuild :
line : 11

Change RDEPEND 

... from .... =dev-libs/libgcrypt-1.5*

... to ...... dev-libs/libgcrypt:0/11

to circumvent current conflicts.
Comment 61 Manfred Knick 2015-09-07 12:01:18 UTC
(In addition to Manfred Knick from comment #60)

<--- cite --->

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.6.3-r4:0/20::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (app-crypt/gcr-3.14.0:0/1::gentoo, installed)
                              ^^^^^^
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (gnome-base/gnome-keyring-3.14.0:0/0::gentoo, installed)
                              ^^^^^^
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (gnome-base/libgnome-keyring-3.12.0:0/0::gentoo, installed)
                              ^^^^^^
    dev-libs/libgcrypt:0/11= required by (sys-fs/cryptsetup-1.6.7:0/0::gentoo, installed)
                      ^^^^^^
    >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)] required by (dev-libs/libxslt-1.1.28-r4:0/0::gentoo, installed)
                              ^^^^^^               
    =dev-libs/libgcrypt-1.5* required by (app-emulation/vmware-workstation-11.1.2.2780323:0/0::gentoo, installed)
    ^                   ^^^^
    >=dev-libs/libgcrypt-1.5:0/11= required by (app-crypt/gnupg-2.0.28:0/0::gentoo, installed)
                            ^^^^
Comment 62 Manfred Knick 2015-09-08 08:25:01 UTC
(In addition to Manfred Knick from comment #60)


Please, note

https://bugs.gentoo.org/show_bug.cgi?id=534252

and

https://bugs.gentoo.org/show_bug.cgi?id=538488

.
Comment 63 Manfred Knick 2015-09-08 17:01:51 UTC
(In addition to Manfred Knick from comment #60)

In between, -1.6.3-r4:0/20 has been stabilized:

# equery list -p dev-libs/libgcrypt  

[IP-] [  ] dev-libs/libgcrypt-1.5.4-r1:0/11
[-P-] [ ~] dev-libs/libgcrypt-1.5.4-r100:11/11
[-P-] [  ] dev-libs/libgcrypt-1.6.3-r4:0/20
[-P-] [ ~] dev-libs/libgcrypt-1.6.3-r5:0/20
[-P-] [ ~] dev-libs/libgcrypt-1.6.4:0/20


:: dev-libs/libgcrypt-1.6.3-r4:0/20

WORKSFORME.
Comment 64 Andreas K. Hüttel gentoo-dev 2016-03-20 18:08:40 UTC
I guess this can be closed.