Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 531414 - x11-drivers/xf86-video-ati-7.5.0 USE=glamor - firefox-24.8.0 crashes X during login at https://mail.yandex.ru
Summary: x11-drivers/xf86-video-ati-7.5.0 USE=glamor - firefox-24.8.0 crashes X during...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: Bug
Depends on:
Blocks:
 
Reported: 2014-12-02 08:48 UTC by noc
Modified: 2015-11-17 07:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
dmesg (dmesg,11.54 KB, text/plain)
2014-12-02 08:52 UTC, noc
Details
xorg.conf (xorg.conf,7.19 KB, text/plain)
2014-12-02 08:52 UTC, noc
Details
xorg.conf (xorg.conf,5.60 KB, text/plain)
2014-12-02 14:43 UTC, noc
Details
Xorg.0.log (Xorg.0.log.old,43.18 KB, application/x-trash)
2014-12-02 14:48 UTC, noc
Details
Xorg.1.log (Xorg.1.log.old,43.03 KB, text/plain)
2014-12-02 14:55 UTC, noc
Details
kdmrc (kdmrc,24.29 KB, text/plain)
2014-12-02 15:00 UTC, noc
Details
kdmrc (kdmrc,459 bytes, text/plain)
2014-12-03 14:00 UTC, noc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description noc 2014-12-02 08:48:25 UTC
Freez desktop for few minutes just after login to https://mail.yandex.ru

Reproducible: Always

Steps to Reproduce:
1. Login to web mail https://mail.yandex.ru may be other
2. dmesg |grep radeon



[ebuild   R   ~] x11-drivers/xf86-video-ati-7.5.0  USE="glamor udev" 0 kB
[ebuild   R    ] x11-drivers/radeon-ucode-20140823  0 kB
[ebuild   R    ] www-client/firefox-24.8.0  USE="alsa custom-cflags custom-optimization dbus libnotify minimal startup-notification system-cairo system-icu system-jpeg -bindist -debug -gstreamer -jit (-pgo) -pulseaudio (-selinux) -system-sqlite {-test} -wifi" LINGUAS="ru -af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -si -sk -sl -son -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW -zu" 0 kB
[ebuild   R    ] media-libs/mesa-10.0.4  USE="classic egl gallium gbm gles2 llvm llvm-shared-libs nptl opencl openvg osmesa pax_kernel pic r600-llvm-compiler vdpau xa xvmc -bindist -debug -gles1 (-selinux) -wayland" VIDEO_CARDS="i915 i965 intel nouveau r100 r200 r300 r600 radeon radeonsi (-freedreno) -ilo -vmware" 0 kB
[ebuild   R    ] x11-libs/glamor-0.6.0  USE="xv -gles -static-libs" 0 kB
[ebuild   R    ] kde-base/kde-meta-4.12.5:4  USE="nls semantic-desktop -accessibility (-aqua) -sdk" 0 kB



Portage 2.2.8-r2 (hardened/linux/amd64/no-multilib, gcc-4.8.3, glibc-2.19-r1, 3.17.3-hardened-ati x86_64)
=================================================================
System uname: Linux-3.17.3-hardened-ati-x86_64-Genuine_Intel-R-_CPU_2160_@_1.80GHz-with-gentoo-2.2
KiB Mem:     3082248 total,   1334512 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of tree: Tue, 18 Nov 2014 00:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.7, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo NOC
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA PUEL AdobeFlash-11.x Intel-SDP skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"                                                                                                                                                                                      
DISTDIR="/usr/portage/distfiles"                                                                                                                                                                                                             
EMERGE_DEFAULT_OPTS="--jobs 3 --load-average=6"                                                                                                                                                                                              
FCFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"                                                                                                                                                                                       
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"                                                                                                                                                                           
FFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"                                                                                                                                                                                        
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                                                                                                                                                                 
LANG="ru_RU.UTF-8"                                                                                                                                                                                                                           
LC_ALL="ru_RU.UTF-8"                                                                                                                                                                                                                         
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                                                                                                            
MAKEOPTS="-j3"                                                                                                                                                                                                                               
PKGDIR="/usr/portage/packages"                                                                                                                                                                                                               
PORTAGE_CONFIGROOT="/"                                                                                                                                                                                                                       
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"             
PORTAGE_TMPDIR="/var/tmp"                                                                                                                                                                                                                    
PORTDIR="/usr/portage"                                                                                                                                                                                                                       
PORTDIR_OVERLAY="/usr/local/portage"                                                                                                                                                                                                         
USE="X X509 a52 aac acl alsa amd64 aspell bash-completion berkdb bluetooth bluray bzip2 cairo calculate_nokernel calculate_noopenbox calculate_noprinter calculate_nowireless calculate_noxorg caps cdda cdistro_CLS cdr cl_server clamav cli cpudetection cracklib crypt cups cxx dbus dia djvu dri dts dvb dvd ebook ecdsa egl encode exif fam ffmpeg flac gdbm gif glamor gles gles2 gme gmp gnutls gost gpg gphoto2 gsl gudev hardened hwdb iconv idn introspection ipv6 jingle jpeg justify kde kdepim keymap kvs40xx lapack lcms libnotify lm_sensors logrotate lz4 lzma lzo mad mmx mng modules mp3 mpeg mpfi musepack mustek_usb2 ncurses nls nptl ogg opencl opengl openmp oscar otr pam pax_kernel pcre pdf pic png policykit qt4 readline rfc3779 scanner schroedinger sdl semantic-desktop session shine sms speex spell sse sse2 ssl ssse3 startup-notification svg switcher tcpd theora threads tiff truetype twolame udev udisks unicode urandom usb uxa v4l vaapi vdpau video vlc vorbis winpopup wma-fixed x264 xattr xcb xml xpdf-headers xtpax xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="coreboot multiboot pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver" LINGUAS="en ru ru_RU" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="x86_64 arm mips64 mips64el ppc64 sparc64" QEMU_USER_TARGETS="x86_64 arm mips64 mips64el ppc64 sparc64" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="i915 i965 intel mga nouveau nv r100 r200 r300 r600 radeon radeonsi v4l vesa via" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC


01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland PRO [Radeon R7 240]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670]
Comment 1 noc 2014-12-02 08:52:19 UTC
Created attachment 390752 [details]
dmesg
Comment 2 noc 2014-12-02 08:52:51 UTC
Created attachment 390754 [details]
xorg.conf
Comment 3 Jeroen Roovers gentoo-dev 2014-12-02 09:03:26 UTC
Your Xorg.?.log would be helpful here.
Comment 4 noc 2014-12-02 12:25:11 UTC
Fixed by using properly acceleration mode as suggested http://wiki.gentoo.org/wiki/Radeon#Driver in xorg.conf:

For
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland PRO [Radeon R7 240]
Section "Device"
        Option      "AccelMethod"           "glamor"
        Driver      "radeon"
EndSection

For
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670]
Section "Device"
        Option      "AccelMethod"           "EXA"
        Driver      "radeon"
EndSection
Comment 5 noc 2014-12-02 12:35:37 UTC
All USE is correct. We must compile x11-drivers/xf86-video-ati with USE="glamor" and x11-libs/glamor USE="-gles"

But in "Device" Section of xorg.conf use "AccelMethod" "EXA"!
Comment 6 noc 2014-12-02 14:37:56 UTC
With xorg.conf оption "AccelMethod" "glamor" bug exist!
Provided solution to change "AccelMethod" from "glamor" to "EXA" suitable only for ARUBA, BARTS, TURKS, CAICOS, CAYMAN 
For newer  CAPE VERDE, PITCAIRN, TAHITI, OLAND, HAINAN, ... with glamor acceleration it is bug!!!
Comment 7 noc 2014-12-02 14:43:10 UTC
Created attachment 390772 [details]
xorg.conf

System running multihead xorg servers:
X0 on Oland PRO [Radeon R7 240]
X1 on Turks XT [Radeon HD 6670/7670]
Comment 8 noc 2014-12-02 14:48:05 UTC
Created attachment 390776 [details]
Xorg.0.log

For Oland PRO [Radeon R7 240] this bug make X server unusable, some times hang computer, some times hang only one monitor. Switch to console impossible because of artifacts. Second X server on other card may continue working...
Comment 9 noc 2014-12-02 14:55:53 UTC
Created attachment 390782 [details]
Xorg.1.log

If on Turks XT [Radeon HD 6670/7670] switch from EXA to glamor, witch is not recommended, we do not have hang up, X servers "like reload GPU" and after some time continue running with all apps, firefox with some artifacts is not usable!
Comment 10 noc 2014-12-02 15:00:44 UTC
Created attachment 390784 [details]
kdmrc

I use xorg build with USE=dmx so run 2 X servers for 2 kde sessions with ISOLATED devises.
Comment 11 noc 2014-12-03 14:00:07 UTC
Created attachment 390848 [details]
kdmrc

Try x11-libs/glamor-0.6.0-r1 with same result..
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-12-03 15:44:26 UTC
Can you try to use >=x11-base/xorg-server-1.16[glamor] instead of x11-libs/glamor?
Comment 13 noc 2014-12-05 15:38:03 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #12)
> Can you try to use >=x11-base/xorg-server-1.16[glamor] instead of
> x11-libs/glamor?

Today I try media-libs/mesa-10.3.1 with same result.. Next week will try xorg-server-1.16.2 or later.
Comment 14 Matt Turner gentoo-dev 2015-11-12 05:55:05 UTC
Please try xorg-server[glamor]-1.18, xf86-video-ati-7.6.1, and mesa-11.0.4.
Comment 15 noc 2015-11-17 07:02:18 UTC
I only try x11-base/xorg-server-1.16.4[glamor], x11-drivers/xf86-video-ati-7.6.1[glamor], and media-libs/mesa-10.3.7-r1.

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland PRO [Radeon R7 240]
Section "Device"
        Option      "AccelMethod"           "glamor"
        Driver      "radeon"
EndSection

For
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670]
Section "Device"
        Option      "AccelMethod"           "EXA"
        Driver      "radeon"
EndSection

No any errors!

I'll try xorg-server[glamor]-1.18, and mesa-11.0.4 later..

We can close also: https://bugs.gentoo.org/show_bug.cgi?id=501286