Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 531018 - app-portage/porthole - porthole when run as root exits after: NameError: global name 'priviliges' is not defined
Summary: app-portage/porthole - porthole when run as root exits after: NameError: glob...
Status: RESOLVED WONTFIX
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2020-03-18
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks:
 
Reported: 2014-11-28 16:47 UTC by ehrich.weiss
Modified: 2020-03-19 07:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emergeinfo,20.48 KB, text/plain)
2014-11-28 16:51 UTC, ehrich.weiss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ehrich.weiss 2014-11-28 16:47:08 UTC
Using porthole 0.6.1-r1 as root I get the error listed. At first I thought it was simply a typo in the file but when I corrected it there were other errors so I reverted. The only reason I use it as root is because for some reason I can no longer use "ask" in the Advanced Emerge options if run as non-root. 

This happens most often when I'm trying to unmask


Reproducible: Always

Steps to Reproduce:
1. run porthole as root(I did it via command line to see the error)
2. Attempt to unmask a package
3. 
Actual Results:  
At some point in this process it will give "NameError: global name 'priviliges' is not defined"

Expected Results:  
It should have unmasked(or whatever I asked it to do)
Comment 1 ehrich.weiss 2014-11-28 16:49:14 UTC
(It won't let me put my emerge --info here. Complains of the size..grr)
Comment 2 ehrich.weiss 2014-11-28 16:51:27 UTC
Created attachment 390500 [details]
emerge --info
Comment 3 Jeroen Roovers gentoo-dev 2014-11-28 19:43:16 UTC
Also, privileges...
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-03-19 07:43:13 UTC
Removed.