Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 52976 - eclipse 2.1.3-r3 shortcut bar for selecting perspectives missing with gtk frontend
Summary: eclipse 2.1.3-r3 shortcut bar for selecting perspectives missing with gtk fro...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Karl Trygve Kalleberg (RETIRED)
Depends on:
Reported: 2004-06-04 07:04 UTC by Heinrich Nirschl
Modified: 2004-07-09 09:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Heinrich Nirschl 2004-06-04 07:05:18 UTC
I tried to build eclipse-sdk-2.1.3-r3 on a stable system with sun java 1.4.2 and with blackdown java 1.4.1 but both builds show the same problem:
the shortcut bar for switching perspectives on the left side of the window does not show up in the gtk version. It is there in the motif version.

There are no errors in the workspace/.metadata/.log file.

I have installed gtk+ 1.2.10-r11 and 2.4.1 

N.B. I also tried jikes, but that build had even more severe issues (ClassNotFound exceptions).

Reproducible: Always
Steps to Reproduce:
1. build eclipse-sdk
2. start up eclipse

Actual Results:  
Main window shows up but shortcut bar is missing.

Expected Results:  
Main window with all components shows up.

Portage 2.0.50-r7 (default-x86-2004.0, gcc-3.3.2, glibc-2.3.2-r9, 2.4.25-gentoo-r3)
System uname: 2.4.25-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
Gentoo Base System version 1.4.15
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="X alsa apm arts avi berkdb cdr crypt cups doc dvd encode esd foomaticdb
gdbm gif gnome gpm gtk gtk2 imlib java jpeg libg++ libwww mad mikmod motif
mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python
quicktime readline sdl slang spell ssl svga tcpd tetex tiff truetype x86 xml2
xmms xv zlib"
Comment 1 Dominik Diesch 2004-06-04 11:16:55 UTC
At first I thought that I had the same problem, but at a closer look to the
location, where the perspective bar should reside, one can see that in fact 
the bar is visible but only one pixel wide. So I guess the bar is just hidden 
by the other views. I can even click on the buttons (with verrry carefull 
IIRC this problem appeared after the last update of gtk+ lib.
Comment 2 Karl Trygve Kalleberg (RETIRED) gentoo-dev 2004-06-04 15:12:53 UTC
I suspect this is more an upstream problem that's related to the gtk+
version the program is compiled against.

Can you try compiling it against both gtk+-2.2 and 2.4, to see if there's
any change?
Comment 3 Heinrich Nirschl 2004-06-05 00:12:28 UTC
I tried it, compiling against gtk+-2.2 solves the problem.
Comment 4 Billy Biggs 2004-06-09 07:38:34 UTC
For more information see this eclipse bug report and the ones marked as duplicates of it:

A change in Eclipse makes vertical toolbars work in M9 and later under Gtk+ 2.4.  The problem did not occur with Gtk+ 2.2.
Comment 5 Karl Trygve Kalleberg (RETIRED) gentoo-dev 2004-07-09 09:35:42 UTC
This is a known bug upstream, for which no patch currently exist. Unless
somebody comes up with one, I will not have the time to fix it.

As 3.0.0 is out (although not marked stable quite yet), and there exists
a not totally unreasonable workaround for gentoo currently, I'm closing this
bug as UPSTREAM, pending updates from the team.

If anybody objects, please reopen the bug with a patch attached, and I'll
apply it.