Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 529224 - dev-lang/texlive-core-2014-r1 - src_compile(): Making all in web2c /// Makefile:1814: *** missing separator. Stop.
Summary: dev-lang/texlive-core-2014-r1 - src_compile(): Making all in web2c /// Makefi...
Status: RESOLVED DUPLICATE of bug 528022
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Alexis Ballier
Depends on:
Reported: 2014-11-14 08:18 UTC by Philipp Riegger
Modified: 2014-11-17 13:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

app-text:texlive-core-2014-r1:20141114-071339.log (app-text:texlive-core-2014-r1:20141114-071339.log,249.83 KB, text/plain)
2014-11-14 08:19 UTC, Philipp Riegger
Makefile (Makefile,959.59 KB, text/plain)
2014-11-15 08:58 UTC, Philipp Riegger

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Riegger 2014-11-14 08:18:27 UTC
When I try to compile texlive core on my x86 XEN vserver, I get an error.

Reproducible: Always

Steps to Reproduce:
1. emerge -uDvN @system @world

Actual Results:  
I get an error about a missing separator in a Makefile:

configure: creating ./config.status
config.status: creating Makefile
config.status: creating kpathsea/c-auto.h
config.status: executing depfiles commands
config.status: executing libtool commands
Making all in web2c
Makefile:1814: *** missing separator.  Stop.
Makefile:878: recipe for target 'recurse' failed
make[2]: *** [recurse] Error 1
Makefile:458: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
Makefile:544: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
 * ERROR: app-text/texlive-core-2014-r1::gentoo failed (compile phase):
 *   emake failed
 * If you need support, post the output of `emerge --info '=app-text/texlive-core-2014-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-text/texlive-core-2014-r1::gentoo'`.
 * The complete build log is located at '/var/log/portage/app-text:texlive-core-2014-r1:20141114-071339.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/app-text/texlive-core-2014-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/texlive-core-2014-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/texlive-core-2014-r1/work/texlive-core-2014_build'
 * S: '/var/tmp/portage/app-text/texlive-core-2014-r1/work/texlive-core-2014_build'

Expected Results:  
The package texlive-core should be updated from 2013-r1 to 2014-r1.

emerge --info:
Portage 2.2.14 (python 2.7.8-final-0, hardened/linux/x86, gcc-4.8.3, glibc-2.20, 3.17.1-hardened i686)
System uname: Linux-3.17.1-hardened-i686-Intel-R-_Xeon-R-_CPU_E3-1220L_V2_@_2.30GHz-with-gentoo-2.2
KiB Mem:     1025696 total,     29308 free
KiB Swap:    1001468 total,    248488 free
Timestamp of tree: Fri, 14 Nov 2014 06:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30-r1
dev-lang/perl:            5.20.1-r2
dev-lang/python:          2.7.8, 3.3.5-r1
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc:           2.20
Repositories: gentoo stoile_overlay sunrise
CFLAGS="-O2 -march=pentium4 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium4 -pipe"
EMERGE_DEFAULT_OPTS="--alphabetical --binpkg-respect-use y --load-average=3 --with-bdeps y --dynamic-deps n"
FCFLAGS="-march=i686 -O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg cgroup collision-protect compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=i686 -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1 -s"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/stoile /var/lib/layman/sunrise"
USE="acl berkdb bzip2 caps cli cracklib crypt cxx dri gmp gs hardened iconv idn ipv6 jpeg logrotate logwatch lzma lzo modules ncurses nls nptl pam pax_kernel pcre pic png readline seccomp session ssl svg tcpd tiff udev unicode urandom vhosts x86 xattr xtpax zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="aggregation apache cgroups conntrack contextswitch cpu curl curl_json curl_xml df disk entropy ethstat exec interface iptables irq load lvm memory netlink network nginx openvpn perl ping processes protocols python rrdtool swap syslog tail tcpconns threshold uptime users vmem" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en en_GB eu" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Philipp Riegger 2014-11-14 08:19:54 UTC
Created attachment 389286 [details]
Comment 2 Philipp Riegger 2014-11-14 09:57:27 UTC
I masked all texlive 2014 ebuilds and try to re-emerge texlive-core-2013. Same error here. But it worked at some point in time.
Comment 3 Philipp Riegger 2014-11-14 10:10:05 UTC
This is most likely because of /bin/sh -> /bin/dash. I will know in about 25 minutes.
Comment 4 Philipp Riegger 2014-11-14 10:16:42 UTC
(In reply to Philipp Riegger from comment #3)
> This is most likely because of /bin/sh -> /bin/dash. I will know in about 25
> minutes.

Setting the /bin/sh symlink back to bash does not seem to fix the issue.
Comment 5 Alexis Ballier gentoo-dev 2014-11-14 14:44:48 UTC
can you post the offending makefile plz ? and try with USE=-xattr on portage ?
Comment 6 Philipp Riegger 2014-11-15 08:56:45 UTC
I switched from hardened profile to default profile (1 in eselect profile) and recompiled portage without xattr. I then recompiled texlive-core 2013 and got the same error. The Makefile where the problem occurs seems to be /var/tmp/portage/app-text/texlive-core-2013-r1/work/texlive-core-2013_build/texk/web2c/Makefile. I'll attach it in a minute, here are some lines from it: 

ICU_LIBS = -L/usr/lib  -licui18n -licuuc -licudata
-lpthread -ldl -lm
INSTALL = /usr/bin/install -c

The problem is in the line after ICU_LIBS, the "\n" should most likely not be there.
Comment 7 Philipp Riegger 2014-11-15 08:58:22 UTC
Created attachment 389364 [details]
Comment 8 Alexis Ballier gentoo-dev 2014-11-17 08:46:57 UTC
(In reply to Philipp Riegger from comment #6)
> The problem is in the line after ICU_LIBS, the "\n" should most likely not
> be there.

yep, indeed.

Does something like 'icu-config --ldflags-searchpath --ldflags-libsonly --ldflags-system' outputs two lines too on your system ?
Comment 9 Philipp Riegger 2014-11-17 09:27:05 UTC
playground ~ # icu-config --ldflags-searchpath --ldflags-libsonly  --ldflags-system
-licui18n -licuuc -licudata 
-lpthread -ldl -lm   

playground ~ #
Comment 10 Alexis Ballier gentoo-dev 2014-11-17 09:58:54 UTC
(In reply to Philipp Riegger from comment #9)
> playground ~ # icu-config --ldflags-searchpath --ldflags-libsonly 
> --ldflags-system
> -L/usr/lib 
> -licui18n -licuuc -licudata 
> -lpthread -ldl -lm   
> playground ~ #

wow, this is not normal and likely the cause of you problem; can you try rebuilding icu, with bash as /bin/sh, and see if this is still like that ?

here i get:

$ icu-config --ldflags-searchpath --ldflags-libsonly --ldflags-system
-L/usr/lib64 -licui18n -licuuc -licudata -lpthread -ldl -lm   

(on one line)
Comment 11 Philipp Riegger 2014-11-17 12:18:31 UTC
Installing icu with /bin/sh->/bin/bash works. icu-config returns the correct result. Switching back /bin/sh->/bin/dash and the error returns. I replaced #!/bin/sh with #!/bin/bash in /usr/bin/icu-config, switched back to dash and everything is working so far.
Comment 12 Alexis Ballier gentoo-dev 2014-11-17 13:49:29 UTC
good then, thanks; nothing to do on texlive side, we have another bug for icu

*** This bug has been marked as a duplicate of bug 528022 ***