Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 529200 - sys-apps/portage: portageq root parameter no longer works
Summary: sys-apps/portage: portageq root parameter no longer works
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, PATCH, REGRESSION
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2014-11-14 01:54 UTC by Zac Medico
Modified: 2014-12-04 05:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2014-11-14 01:54:14 UTC
It was broken by this change in commit c9f6aa9f0151adb3c86706eaef1914cdbdcf2b6d, since it causes portage.settings to be instantiated earlier:

diff --git a/bin/portageq b/bin/portageq
index c88ee88..1ae1fe1 100755
--- a/bin/portageq
+++ b/bin/portageq
@@ -1232,7 +1232,7 @@ def main(argv):
 			sys.stderr.write("Run portageq with --help for info\n")
 			sys.stderr.flush()
 			sys.exit(os.EX_USAGE)
-		eprefix = portage.const.EPREFIX
+		eprefix = portage.settings["EPREFIX"]
 		eroot = portage.util.normalize_path(argv[2])
 
 		if eprefix:
Comment 1 Zac Medico gentoo-dev 2014-11-14 07:45:34 UTC
I have a patch in the following branch:

	https://github.com/zmedico/portage/tree/bug_529200

I've posted it for review here:

	http://thread.gmane.org/gmane.linux.gentoo.portage.devel/4783
Comment 3 Brian Dolbec gentoo-dev 2014-12-04 05:38:17 UTC
This is in the portage-2.2.15 release.