Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 529128 - x11-drivers/nvidia-drivers - .../work/kernel/nv-linux.h:199:2: error: #error "This driver requires the ability to change memory types!"
Summary: x11-drivers/nvidia-drivers - .../work/kernel/nv-linux.h:199:2: error: #error ...
Status: RESOLVED DUPLICATE of bug 528108
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-13 10:35 UTC by Silvio
Modified: 2014-11-13 11:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.86 KB, text/plain)
2014-11-13 10:38 UTC, Silvio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Silvio 2014-11-13 10:35:55 UTC
I've 64bit system.

Yesterday I've migrated my system from emul-linux to abi_x86_32 USE flag.

After recompiling everything without problems nvidia-drivers fails to compile with this error:

make -j1 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.17.2-gentoo/build CC=x86_64-pc-linux-gnu-gcc clean module                                                                                                                                                                               
NVIDIA: calling KBUILD...                                                                                                                                                                                      
make[1]: Entering directory '/usr/src/linux-3.17.2-gentoo'                                                                                                                                                     
make[1]: Entering directory `/lib/modules/3.17.2-gentoo/build'                                                                                                                                                 
make -C /lib/modules/3.17.2-gentoo/build \                                                                                                                                                                     
KBUILD_SRC=/usr/src/linux-3.17.2-gentoo \                                                                                                                                                                      
KBUILD_EXTMOD="/var/tmp/portage/x11-drivers/nvidia-drivers-343.22-r2/work/kernel" -f /usr/src/linux-3.17.2-gentoo/Makefile \                                                                                   
modules                                                                                                                                                                                                        
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \                                                                                                                      
echo >&2;                                                       \                                                                                                                                              
echo >&2 "  ERROR: Kernel configuration is invalid.";           \                                                                                                                                              
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\                                                                                                                    
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \                                                                                                                      
echo >&2 ;                                                      \                                                                                                                                              
/bin/false)



Reproducible: Always
Comment 1 Silvio 2014-11-13 10:38:02 UTC
Created attachment 389226 [details]
build.log
Comment 2 Silvio 2014-11-13 10:40:04 UTC
I've tried to:

1) redo
make oldconfig && make prepare
on kernel src

2) unemerge re-emerge gentoo-sources

3) Recompile kernel

Nothing changes.

I used this howto to migrate:

http://wiki.gentoo.org/wiki/Multilib_System_without_emul-linux_Packages

my emerge -- info:

Portage 2.2.14 (python 2.7.8-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.3, glibc-2.20, 3.17.2-gentoo x86_64)                                                                                                                                                                                                 
=================================================================                                                                                                                                                                                                                                                        
System uname: Linux-3.17.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-4710HQ_CPU_@_2.50GHz-with-gentoo-2.2                                                                                                                                                                                                                       
KiB Mem:    16344912 total,  11383016 free                                                                                                                                                                                                                                                                               
KiB Swap:   17825788 total,  17825788 free                                                                                                                                                                                                                                                                               
Timestamp of tree: Thu, 13 Nov 2014 02:15:01 +0000                                                                                                                                                                                                                                                                       
ld ld di GNU (GNU Binutils) 2.24                                                                                                                                                                                                                                                                                         
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]                                                                                                                                                                                                                                                                             
ccache version 3.1.10 [enabled]                                                                                                                                                                                                                                                                                          
app-shells/bash:          4.3_p30-r1                                                                                                                                                                                                                                                                                     
dev-java/java-config:     2.2.0                                                                                                                                                                                                                                                                                          
dev-lang/perl:            5.20.1-r2                                                                                                                                                                                                                                                                                      
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.2                                                                                                                                                                                                                                                                         
dev-util/ccache:          3.1.10-r1                                                                                                                                                                                                                                                                                      
dev-util/cmake:           3.0.2                                                                                                                                                                                                                                                                                          
dev-util/pkgconfig:       0.28-r2                                                                                                                                                                                                                                                                                        
sys-apps/baselayout:      2.2                                                                                                                                                                                                                                                                                            
sys-apps/openrc:          0.13.3                                                                                                                                                                                                                                                                                         
sys-apps/sandbox:         2.6-r1                                                                                                                                                                                                                                                                                         
sys-devel/autoconf:       2.13, 2.69                                                                                                                                                                                                                                                                                     
sys-devel/automake:       1.11.6, 1.14.1                                                                                                                                                                                                                                                                                 
sys-devel/binutils:       2.24-r3                                                                                                                                                                                                                                                                                        
sys-devel/gcc:            4.8.3                                                                                                                                                                                                                                                                                          
sys-devel/gcc-config:     1.8                                                                                                                                                                                                                                                                                            
sys-devel/libtool:        2.4.3-r2                                                                                                                                                                                                                                                                                       
sys-devel/make:           4.1-r1                                                                                                                                                                                                                                                                                         
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)                                                                                                                                                                                                                                                                   
sys-libs/glibc:           2.20                                                                                                                                                                                                                                                                                           
Repositories: gentoo sunrise gamerlay pinkbyte luman zugaina belak maggu2810-overlay maekke betagarden nikai yarik-overlay amielke-overlay pentoo voyageur vortex manual bibletime                                                                                                                                       
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                                                                                                                                                                                                           
ACCEPT_LICENSE="*"                                                                                                                                                                                                                                                                                                       
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="${CONFIG_PROTECT} /etc /etc/idea/conf /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.1/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" http://mirror.ovh.net/gentoo-distfiles/ http://ftp.heanet.ie/pub/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ rsync://rsync3.it.gentoo.org/gentoo-sources/ ftp://ftp.unina.it/pub/linux/distributions/gentoo/"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/gamerlay /var/lib/layman/pinkbyte /var/lib/layman/luman /var/lib/layman/zugaina /var/lib/layman/belak /var/lib/layman/maggu2810-overlay /var/lib/layman/maekke /var/lib/layman/betagarden /var/lib/layman/nikai /var/lib/layman/yarik-overlay /var/lib/layman/amielke-overlay /var/lib/layman/pentoo /var/lib/layman/voyageur /var/lib/layman/vortex /usr/portage/local/manual /var/lib/layman/bibletime"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3ds 64bit X a52 aac aacplus aacs aalib acl acpi ads aften aiglx akode alias alsa amd64 amr ao apache apm apng asyncns audiofile autoreplace autotrace avahi avi bash-completion berkdb bidi bitmap-fonts bluetooth bluray bmp branding browserplugin bzip bzip2 cairo caps cdaudio cdda cddb cdr cli clucene connectionstatus consolekit contactnotes cracklib crypt cuda cups cvd cvs cxx dbus declarative dia dialup dirac djvu dri dtmf dts dv dvb dvd dvdr dvdread dvi dxva2 dynamicplugin ebook efi emboss encode ethereal exif faac faad fam farstream fat fdk ffmpeg firefox flac fluidsynth fontconfig foomaticdb fortran freetds frei0r fribidi g726 g729 gbm gdbm geolocation gif gimp git glamor gles gles2 glib glitz gme gphoto2 gpm gps gpu groupwise gstreamer gtk gtk3 h323 highlight history hvm i8x0 iconv icu ieee1394 ilbc imagemagick innodb ios iphone ipod ipv6 irc ithreads jack java javascript jingle jpeg jpeg2k kate kde kdenlive kdepim kerberos kipi kontact kqemu lame laptop lcms ldap libass libkms libnotify lm_sensors lucene m4a mad marble mbrola mdb mdnsresponder-compat mercurial midi mime minizip mmx mmxext mng modules moonlight mozilla mp3 mp4 mpeg mpeg2 mplayer msn mssql multilib musepack musicbrainz ncurses netmeeting nls nowlistening npt1 nptl nptlonly nsplugin ntfs nvidia odbc ogg openal openexr opengl openipmi openmp opus orc oss pam pango pcmcia pcre pda pdf perl phonon plasma pmu png policykit portaudio postgres ppds pulseaudio python python3 qemu qt qt3support qt4 quicktime rar raw rdesktop rdp readline reiserfs reports rtsp samba sametime sane scanner sdl sdl-image semantic-desktop session shout sip sipim skype smp sms soprano soundtouch speex spell sqlite sse sse2 ssh ssl ssse3 startup-notification subtitles subversion svg tcpd texteffect texteffects theora tidy tiff timidity tk tordns translator truetype truetype-fonts twolame type1-fonts udev udisks unicode upower usb utempter uxa v4l v4l2 vaapi vcd vcdx vdpau video virtualbox vnc vorbis vpx wav wavpack webkit webpresence webrtc-aec wicd wifi win32codecs win64 winbind winetriks winpopup wlm wma wma-fixed wmf wxwidgets wxwindows x264 xcb xcomposite xen xetex xine xinerama xml xmp xscreensaver xv xvid xvmc yahoo zeroconf zlib" ABI_X86="64 32" ALSA_CARDS="snd_hda_intel" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev joystick synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it en it_IT" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20 ruby21" SANE_BACKENDS="*" USERLAND="GNU" VIDEO_CARDS="nvidia intel i965 nv vesa nouveau v4l v4l2 modesetting fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Jeroen Roovers gentoo-dev 2014-11-13 11:21:23 UTC

*** This bug has been marked as a duplicate of bug 528108 ***