Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 528770 - www-apache/mod_wsgi-3.5 with /bin/sh -> dash - /usr/share/build-1/libtool: 1555: /usr/share/build-1/libtool: preserve_args+= --silent: Permission denied
Summary: www-apache/mod_wsgi-3.5 with /bin/sh -> dash - /usr/share/build-1/libtool: 15...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Dirkjan Ochtman
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2014-11-09 22:44 UTC by Bodo Graumann
Modified: 2016-02-08 08:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (1415570626-install-www-apache_mod_wsgi-3.5:0::gentoo.out,5.98 KB, text/plain)
2014-11-09 22:46 UTC, Bodo Graumann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bodo Graumann 2014-11-09 22:44:10 UTC
When dash is used as the system shell, mod_wsgi fails to build with errors similar to that of apache in
https://bugs.gentoo.org/show_bug.cgi?id=526178

Reproducible: Always
Comment 1 Bodo Graumann 2014-11-09 22:46:14 UTC
Created attachment 388980 [details]
build.log
Comment 2 Dirkjan Ochtman gentoo-dev 2014-11-10 09:04:20 UTC
So I guess the same thing goes here, I guess, that you have to re-emerge apr.
Comment 3 Bodo Graumann 2014-11-10 09:46:34 UTC
Reinstalling dev-libs/apr-1.5.0-r2 indeed solved the problem. /usr/share/build-1/libtool now explicitely depends on /bin/bash. Maybe apr should be bumped to dev-libs/apr-1.5.0-r3?
Comment 4 Alexander Tsoy 2014-11-10 10:51:35 UTC
See bug 528798
Comment 5 Dirkjan Ochtman gentoo-dev 2016-02-08 08:37:08 UTC
I don't think this is still relevant.