Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 528742 - media-libs/avidemux-plugins-2.6.8 - /usr/lib/libc_nonshared.a(stack_chk_fail_local.oS): In function `__stack_chk_fail_local': (.text+0x10): undefined reference to `__stack_chk_fail'
Summary: media-libs/avidemux-plugins-2.6.8 - /usr/lib/libc_nonshared.a(stack_chk_fail_...
Status: RESOLVED DUPLICATE of bug 503500
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-09 15:32 UTC by Martin Väth
Modified: 2015-09-25 04:30 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,18.12 KB, text/plain)
2014-11-10 06:51 UTC, Martin Väth
Details
media-libs:avidemux-plugins-2.6.8:20141110-064400.log.xz (media-libs:avidemux-plugins-2.6.8:20141110-064400.log.xz,24.31 KB, application/x-xz)
2014-11-10 06:56 UTC, Martin Väth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Väth 2014-11-09 15:32:10 UTC
media-libs/avidemux-plugins-2.6.8 does not compile with gcc-4.9.1 on x86
There is no such problem with gcc-4.8.2 or on amd64; probably all dependencies have already been recompiled with gcc-4.9.
The relevant error is:

/usr/lib/libc_nonshared.a(stack_chk_fail_local.oS): In function `__stack_chk_fail_local':
(.text+0x10): undefined reference to `__stack_chk_fail'

(note that glibc has been recompiled with gcc-4.9.1)

When compiling, the following use-flags were enabled:

a52 aac aften alsa amr dts lame mmx opengl oss qt4 twolame vorbis vpx x264 xv xvid
PYTHON_TARGETS="python2_7
Comment 1 Jeroen Roovers gentoo-dev 2014-11-09 22:21:30 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 2 Martin Väth 2014-11-10 06:51:04 UTC
Created attachment 388986 [details]
emerge --info

Same result without ccache
Same result also when recompiling avidemux-core and avidemux before without OPT*FLAGS
Comment 3 Martin Väth 2014-11-10 06:56:54 UTC
Created attachment 388988 [details]
media-libs:avidemux-plugins-2.6.8:20141110-064400.log.xz

Log is too long to attach, so I compressed it with xz
Comment 4 Martin Väth 2014-11-23 14:00:08 UTC
Same error also with sys-libs/glibc-2.20:
Exactly the same behaviour after the upgrade
Comment 5 SpanKY gentoo-dev 2015-09-18 19:15:56 UTC
please try upgrading to binutils-2.25.1-r1
Comment 6 Alexander Tsoy 2015-09-24 23:28:26 UTC
I reproduced this issue with binutils-2.24-r3 in 32-bit chroot. As expected, upgrade to binutils-2.25.1-r1 fixed it. So this bug should not block gcc-4.9 tracker.
Comment 7 SpanKY gentoo-dev 2015-09-25 04:30:40 UTC

*** This bug has been marked as a duplicate of bug 503500 ***