Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 52851 - mplayer should install hebrew fonts and enable them when USE="bidi"
Summary: mplayer should install hebrew fonts and enable them when USE="bidi"
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 94315 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-03 00:18 UTC by Genady Okrain
Modified: 2005-11-20 07:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
font.desc (font.desc,4.33 KB, application/octet-stream)
2004-06-03 00:19 UTC, Genady Okrain
Details
iso-8859-8-a.raw (iso-8859-8-a.raw,127.06 KB, application/octet-stream)
2004-06-03 00:19 UTC, Genady Okrain
Details
iso-8859-8-b.raw (iso-8859-8-b.raw,127.06 KB, application/octet-stream)
2004-06-03 00:20 UTC, Genady Okrain
Details
mplayer-1.0_pre6.ebuild.diff (mplayer-1.0_pre6.ebuild.diff,1.28 KB, patch)
2005-02-07 05:58 UTC, Roland Bär
Details | Diff
mplayer-1.0_pre6.ebuild.diff (mplayer-1.0_pre6.ebuild.diff,930 bytes, patch)
2005-02-15 08:06 UTC, Roland Bär
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Genady Okrain 2004-06-03 00:18:19 UTC
fonts dir: /usr/share/mplayer/fonts/font-arial-24-iso-8859-8
and if bidi enabled 
/usr/share/mplayer/font
need to point at
/usr/share/mplayer/fonts/font-arial-24-iso-8859-8

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Genady Okrain 2004-06-03 00:19:21 UTC
Created attachment 32566 [details]
font.desc
Comment 2 Genady Okrain 2004-06-03 00:19:53 UTC
Created attachment 32567 [details]
iso-8859-8-a.raw
Comment 3 Genady Okrain 2004-06-03 00:20:27 UTC
Created attachment 32568 [details]
iso-8859-8-b.raw
Comment 4 Genady Okrain 2004-06-03 00:29:40 UTC
the fonts can be found here too
http://codex.homelinux.net/movies/subtitles/mplayer_heb.tar.gz
Comment 5 Roland Bär 2005-02-07 05:58:23 UTC
Created attachment 50616 [details, diff]
mplayer-1.0_pre6.ebuild.diff

emerges cleanly. Test it. This "arial" naming works technically, reduces amount
of diff needed.
Comment 6 Roland Bär 2005-02-15 08:06:13 UTC
Created attachment 51276 [details, diff]
mplayer-1.0_pre6.ebuild.diff

Removed the symlinking part, as this has side-effects on onscreen display
(volume e.g.)
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-05-28 14:30:31 UTC
*** Bug 94315 has been marked as a duplicate of this bug. ***
Comment 8 Matan 2005-05-29 07:42:45 UTC
According to bug 52851 hebrew fonts are missing or mispointed correctly, while
according to bug 94315 the "bidi" use flag has no entry in the ebuild, as a
result the missing use flag entry causes any(!) RTL language to display
backwards. Those two bugs are different.
Comment 9 Luca Barbato gentoo-dev 2005-08-04 11:32:34 UTC
bidi support is present at least in the pre7 ebuild, I warmly suggest to use the
truetype font support that is already present in mplayer since I won't add other
useflag and/or add any bitmap font to the ebuild if there is another solution
that is easyer.

Could we close this bug?
Comment 10 Luca Barbato gentoo-dev 2005-11-20 07:02:33 UTC
Closing as WONTFIX, truetype fonts should work fine for that task