Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 528494 - net-misc/owncloud-client-1.6.4 can't find QtDBus types (qt-4.8.6)
Summary: net-misc/owncloud-client-1.6.4 can't find QtDBus types (qt-4.8.6)
Status: RESOLVED DUPLICATE of bug 526078
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: InOverlay, PMASKED
Depends on:
Blocks: 510042
  Show dependency tree
 
Reported: 2014-11-06 21:40 UTC by Andrés Becerra Sandoval
Modified: 2014-11-07 23:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,405.57 KB, application/octet-stream)
2014-11-06 21:40 UTC, Andrés Becerra Sandoval
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrés Becerra Sandoval 2014-11-06 21:40:00 UTC
Created attachment 388698 [details]
build.log

/var/tmp/portage/net-misc/owncloud-client-1.6.4/work/mirall-1.6.4/src/mirall/systray.cpp: In member function ‘void Mirall::Systray::showMessage(const QString&, const QString&, QSystemTrayIcon::MessageIcon, int)’:
/var/tmp/portage/net-misc/owncloud-client-1.6.4/work/mirall-1.6.4/src/mirall/systray.cpp:34:85: error: ‘QDBusInterface’ was not declared in this scope
     if(QDBusInterface(NOTIFICATIONS_SERVICE, NOTIFICATIONS_PATH, NOTIFICATIONS_IFACE).isValid()) {
                                                                                     ^
/var/tmp/portage/net-misc/owncloud-client-1.6.4/work/mirall-1.6.4/src/mirall/systray.cpp:37:9: error: ‘QDBusMessage’ was not declared in this scope
         QDBusMessage method = QDBusMessage::createMethodCall(NOTIFICATIONS_SERVICE, NOTIFICATIONS_PATH, NOTIFICATIONS_IFACE, "Notify");
         ^
/var/tmp/portage/net-misc/owncloud-client-1.6.4/work/mirall-1.6.4/src/mirall/systray.cpp:37:22: error: expected ‘;’ before ‘method’
Comment 1 Davide Pesavento gentoo-dev 2014-11-06 21:44:28 UTC
Andrés, can you please stop filing bugs and answer to my previous questions? There might be something wrong with your qt installation...
Comment 2 Davide Pesavento gentoo-dev 2014-11-07 23:45:42 UTC

*** This bug has been marked as a duplicate of bug 526078 ***