Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 527676 - sys-devel/binutils-apple-4.3: build failure: gcc needs __has_feature instead of clang's __has_extension
Summary: sys-devel/binutils-apple-4.3: build failure: gcc needs __has_feature instead ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All OS X
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 527514
  Show dependency tree
 
Reported: 2014-11-01 01:32 UTC by Guilherme Amadio
Modified: 2014-11-27 13:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build-log.txt (build.log,61.20 KB, application/octet-stream)
2014-11-01 01:33 UTC, Guilherme Amadio
Details
binutils-apple-4.3-gcc.patch (binutils-apple-4.3-gcc.patch,2.35 KB, patch)
2014-11-01 02:36 UTC, Guilherme Amadio
Details | Diff
binutils-apple-4.3-r1.ebuild (binutils-apple-4.3-r1.ebuild,8.38 KB, text/plain)
2014-11-01 02:37 UTC, Guilherme Amadio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guilherme Amadio gentoo-dev 2014-11-01 01:32:23 UTC
sys-devel/binutils-apple-4.3 fails to build with the following error:

In file included from /usr/include/servers/bootstrap.h:14,
                 from libtool.c:59:
/usr/include/xpc/base.h:64:20: error: missing binary operator before token "("
/usr/include/xpc/base.h:81:18: error: missing binary operator before token "("
Makefile:81: recipe for target 'libtool.o' failed

Reproducible: Always
Comment 1 Guilherme Amadio gentoo-dev 2014-11-01 01:33:21 UTC
Created attachment 387916 [details]
build-log.txt
Comment 2 Guilherme Amadio gentoo-dev 2014-11-01 02:36:16 UTC
Created attachment 387918 [details, diff]
binutils-apple-4.3-gcc.patch

This patch fixes build problems with gcc-apple.
Comment 3 Guilherme Amadio gentoo-dev 2014-11-01 02:37:04 UTC
Created attachment 387920 [details]
binutils-apple-4.3-r1.ebuild

Ebuild that applies patch above.
Comment 4 Fabian Groffen gentoo-dev 2014-11-01 08:49:11 UTC
this should be the same patch as I did to gcc, right?
Comment 5 Guilherme Amadio gentoo-dev 2014-11-01 12:43:33 UTC
I'm not sure, because I don't know what you did to GCC. Is there a bug for reference? The patch is quite simple if want to look at it.
Comment 7 Guilherme Amadio gentoo-dev 2014-11-01 20:25:34 UTC
Yes, I guess it's a minor variation of the same thing. Do you have a working prefix too at this point? I think this was the last fix I needed.
Comment 8 Fabian Groffen gentoo-dev 2014-11-02 20:43:56 UTC
nope, I don't.  I hope to find time to patch Clang so we can bootstrap with Clang and fix all these problems.
Comment 9 Guilherme Amadio gentoo-dev 2014-11-03 01:59:16 UTC
What do we need to do to be able to bootstrap with clang? I know we need to tweak the profile, and somehow use gcc-config to set clang as system compiler, but I'm not familiar enough with these things to know what to do yet. Maybe if you could give me some tips I could start working on it.
Comment 10 Ruud Koolen (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2014-11-27 13:12:32 UTC
Fixed for now due to using clang for python.