Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 526914 - x11-libs/libxkbcommon-0.5.0: rekeyword request
Summary: x11-libs/libxkbcommon-0.5.0: rekeyword request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: http://xkbcommon.org/download/
Whiteboard:
Keywords: KEYWORDREQ
: 527416 (view as bug list)
Depends on:
Blocks: gnome-3.14 530652
  Show dependency tree
 
Reported: 2014-10-26 10:21 UTC by Rémi Cardona
Modified: 2015-02-19 08:58 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2014-10-26 10:21:35 UTC
0.4.3 and 0.5.0 have been released on 2014-08-19 and 2014-10-18 respectively. 0.4.3 is required by Gnome 3.14 (Gnome Team has an ebuild for 0.4.3 in their overlay).

TODO: figure out if we can move to 0.5.0 directly.
Comment 1 Rémi Cardona gentoo-dev 2014-10-26 16:34:01 UTC
Hey there arches, could you guys keyword libxkbcommon-0.5.0? It's needed for Gnome 3.14 and mutter (actual Gnome WM) now needs it. I've added a test USE flag so you can run that until something actually uses the lib.

Thanks
Comment 2 Rémi Cardona gentoo-dev 2014-10-26 16:34:55 UTC
Hey there arches, could you guys keyword libxkbcommon-0.5.0? It's needed for Gnome 3.14 and mutter (actual Gnome WM) now needs it. I've added a test USE flag so you can run that until something actually uses the lib.

Thanks
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-10-30 15:18:04 UTC
*** Bug 527416 has been marked as a duplicate of this bug. ***
Comment 4 Gilles Dartiguelongue gentoo-dev 2014-12-23 23:40:48 UTC
x11-wm/mutter-3.14.3 ~alpha ~ia64 ~ppc ~ppc64 ~sparc
lost keywords due to this bug.
Comment 5 Gilles Dartiguelongue gentoo-dev 2014-12-23 23:54:15 UTC
This chains to gnome-shell as well.
Comment 6 Émeric Maschino 2015-02-07 20:07:00 UTC
ia64 stable.

     Émeric
Comment 7 Pacho Ramos gentoo-dev 2015-02-08 09:29:29 UTC
+  08 Feb 2015; Pacho Ramos <pacho@gentoo.org> libxkbcommon-0.5.0.ebuild:
+  ia64 keyword, bug #526914 by Émeric Maschino
+
Comment 8 Agostino Sarubbo gentoo-dev 2015-02-19 08:58:51 UTC
+  19 Feb 2015; Agostino Sarubbo <ago@gentoo.org> libxkbcommon-0.5.0.ebuild:
+  Add ~alpha/~ppc/~ppc64/~sparc wrt bug #526914
+