Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 526866 - dev-qt/qtgui:5 - add USE=gtkstyle
Summary: dev-qt/qtgui:5 - add USE=gtkstyle
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2014-10-26 01:01 UTC by Gino McCarty
Modified: 2015-04-19 18:53 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-qt/qtgui-5.3.2.ebuild gtkstyle use flag patch (patch,1.02 KB, patch)
2014-10-26 01:22 UTC, Gino McCarty
Details | Diff
dev-qt/qtgui-5.3.2.ebuild gtkstyle use flag patch (patch,1.26 KB, patch)
2014-10-26 02:18 UTC, Gino McCarty
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gino McCarty 2014-10-26 01:01:42 UTC
qt5 also has a gtkstyle module. Please add a use flag for it, the same as in qtgui:4. 

I need it to integrate themes with my existing gtk theme.

Reproducible: Always
Comment 1 Gino McCarty 2014-10-26 01:22:29 UTC
Created attachment 387390 [details, diff]
dev-qt/qtgui-5.3.2.ebuild gtkstyle use flag patch

This compiled and works fine for me..
not to sure about the QT5_GENTOO_CONFIG variable though
Comment 2 Gino McCarty 2014-10-26 02:16:50 UTC
Maybe I missed something But I'm not seeing the linking reported here in the eclass..

I'm also building against 1.12.16 cairo stable so there is no qt4 use flag...

"
# disable gtkstyle because it adds qt4 include paths to the compiler
		# command line if x11-libs/cairo is built with USE=qt4 (bug 433826)
		-no-gtkstyle
"

This bug report is from 5.0_beta of qt so maybe its been fixed now in 5.3.2?
I searched upstream but could find no bug relating to this, i really don't want to comb through their commits..
Comment 3 Gino McCarty 2014-10-26 02:18:42 UTC
Created attachment 387402 [details, diff]
dev-qt/qtgui-5.3.2.ebuild gtkstyle use flag patch
Comment 4 Davide Pesavento gentoo-dev 2014-10-26 13:02:58 UTC
(In reply to Harvey Mittens from comment #2)
> Maybe I missed something But I'm not seeing the linking reported here in the
> eclass..
> 
> I'm also building against 1.12.16 cairo stable so there is no qt4 use flag...
> 

USE=qt4 is masked in base/package.use.mask

> This bug report is from 5.0_beta of qt so maybe its been fixed now in 5.3.2?
> I searched upstream but could find no bug relating to this, i really don't
> want to comb through their commits..

It's not a qt bug so I doubt you'll find fixes there...
Comment 5 Gino McCarty 2014-10-26 16:33:07 UTC
(In reply to Davide Pesavento from comment #4)
> (In reply to Harvey Mittens from comment #2)
> > Maybe I missed something But I'm not seeing the linking reported here in the
> > eclass..
> > 
> > I'm also building against 1.12.16 cairo stable so there is no qt4 use flag...
> > 
> 
> USE=qt4 is masked in base/package.use.mask
> 
> > This bug report is from 5.0_beta of qt so maybe its been fixed now in 5.3.2?
> > I searched upstream but could find no bug relating to this, i really don't
> > want to comb through their commits..
> 
> It's not a qt bug so I doubt you'll find fixes there...

I think your right, i went ahead and tested with cairo 1.4.0 with qt4 enabled and qtgui-5.3.2 and it still doesn't compile.. however I do see some message board comments about cairo being able to compile against qt5.. however I'm not sure how to make it to this..
http://lists.cairographics.org/archives/cairo/2012-February/022715.html
Comment 6 James Le Cuirot gentoo-dev 2014-11-20 21:49:09 UTC
I think this should be added. The qt4 flag on cairo is masked and it's caused nothing but breakage anyway; no package actually requires it.
Comment 7 Olaf Leidinger 2015-03-21 00:00:57 UTC
Is there any packages that requires +qt4 in cairo?

equery depends cairo | grep qt4 reports nothing.
Comment 8 James Le Cuirot gentoo-dev 2015-03-21 21:21:14 UTC
(In reply to Olaf Leidinger from comment #7)
> Is there any packages that requires +qt4 in cairo?

No, that's what I already said.
Comment 9 Chris Mayo 2015-03-26 19:44:19 UTC
Seems to require qtwidgets to be built with -gtksytle as well.
Comment 11 Michael Palimaka (kensington) gentoo-dev 2015-04-19 17:00:19 UTC
I should add that I think we should proceed due to demand and the fact that cairo[qt4] is masked and not required by anything. We can revisit filtering out the bad includes later if it becomes necessary.
Comment 12 Davide Pesavento gentoo-dev 2015-04-19 18:11:26 UTC
(In reply to Michael Palimaka (kensington) from comment #11)
> I should add that I think we should proceed due to demand and the fact that
> cairo[qt4] is masked and not required by anything. We can revisit filtering
> out the bad includes later if it becomes necessary.

Sure, feel free to apply to 5.4.1 in tree as well. The qt4 USE flag doesn't exist anymore in >=x11-libs/cairo-1.14.2, so the blocker is fine IMO.
Comment 13 Michael Palimaka (kensington) gentoo-dev 2015-04-19 18:53:11 UTC
Thanks, fixed in CVS.

+  19 Apr 2015; Michael Palimaka <kensington@gentoo.org> qtgui-5.4.1-r1.ebuild:
+  Add gtkstyle USE flag by Harvey Mittens <teknocratdefunct@riseup.net> and
+  Davide Pesavento <pesa@gentoo.org> wrt bug #526866.

+  19 Apr 2015; Michael Palimaka <kensington@gentoo.org> metadata.xml,
+  qtwidgets-5.4.1.ebuild:
+  Add gtkstyle USE flag wrt bug #526866.