Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 526400 - app-portage/gentoolkit - revdep-rebuild: gawk: warning: escape sequence `\.' treated as plain `.'
Summary: app-portage/gentoolkit - revdep-rebuild: gawk: warning: escape sequence `\.' ...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 346443
  Show dependency tree
 
Reported: 2014-10-22 01:24 UTC by Nikos Chantziaras
Modified: 2014-11-12 18:22 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix Gawk warning (0001-Fix-gawk-warning-escape-sequence-.-treated-as-plain..patch,862 bytes, patch)
2014-11-03 02:44 UTC, Paul Varner (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Chantziaras 2014-10-22 01:24:19 UTC
When running revdep-rebuild, I get this at the end:

   * Checking dynamic linking consistency
  [ 100% ]                 
  gawk: warning: escape sequence `\.' treated as plain `.'

   * Dynamic linking on your system is consistent... All done.
Comment 1 Nikos Chantziaras 2014-10-22 01:24:51 UTC
$ emerge --info app-portage/gentoolkit
Portage 2.2.14 (python 3.4.2-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.3, glibc-2.19-r1, 3.14.22-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.14.22-gentoo-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.2
KiB Mem:    16386332 total,  12984264 free
KiB Swap:   25166912 total,  25166912 free
Timestamp of tree: Wed, 22 Oct 2014 00:15:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.3_p30
dev-lang/perl:            5.20.1-r1
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.2
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo interactive-fiction steam-overlay qt vmware Local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -mtune=native -march=native -O2 -fomit-frame-pointer -floop-interchange -floop-strip-mine -floop-block"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -mtune=native -march=native -O2 -fomit-frame-pointer -floop-interchange -floop-strip-mine -floop-block"
DISTDIR="/mnt/Data/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.ntua.gr/pub/linux/gentoo http://mirror.ovh.net/gentoo-distfiles http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--sort-common"
MAKEOPTS="-j4"
PKGDIR="/mnt/Data/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/interactive-fiction /var/lib/layman/steam /var/lib/layman/qt /var/lib/layman/vmware /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aes-ni alsa amd64 audiofile avx bash-completion branding bzip2 cairo cdr cli consolekit cracklib crypt cxx dbus declarative dri dts dvd dvdr emboss encode exif fam fbcondecor flac gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi lcdfilter lcms libnotify libsamplerate lm_sensors mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nptl nvidia offensive ogg opengl openmp pango pcre pdf pgo phonon plasma png policykit ppds pulseaudio qt4 readline session spell sse sse2 sse3 sse4 sse4_1 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xcb xcomposite xml xv xvid xvmc zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="emu efi-32 efi-64 pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20" SANE_BACKENDS="nothing" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="3.4 3.3 2.7"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-portage/gentoolkit-0.3.0.9-r1 was built with the following:
USE="" ABI_X86="64" PYTHON_TARGETS="python2_7 python3_3 -pypy -python3_2"
LDFLAGS="-Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
Comment 2 Gangræna Gorgeous 2014-10-23 23:07:11 UTC
Reproducible with bash-4.3

There is one incompatible change between bash-4.2 and bash-4.3.  Bash now
performs quote removal on the replacement string in pattern substitution
(${param/pat/rep}), since the shell treats quotes as special.  If you
have to quote single quotes to get them to be treated literally, the shell
should perform quote removal on them.
Comment 3 Paul Varner (RETIRED) gentoo-dev 2014-10-24 16:36:24 UTC
I've found the problem.  Now I need to figure out how to make it work properly with Bash 4.2 and Bash 4.3

The line of code causing the issue is:
ldmask="(${LD_LIBRARY_MASK//./\\\.})"

In Bash 4.2 that expands to:
ldmask=(libjava\\.so|libjawt\\.so|libjvm\\.so|libodbc\\.so|libodbcinst\\.so)'

In Bash 4.3 that expands to:
ldmask=(libjava\.so|libjawt\.so|libjvm\.so|libodbc\.so|libodbcinst\.so)'
Comment 4 Paul Varner (RETIRED) gentoo-dev 2014-10-24 18:22:22 UTC
Fix has been pushed to the git repository.  It can be tested with revdep-rebuild.sh in app-portage/gentoolkit-9999
Comment 5 Nikos Chantziaras 2014-11-01 14:27:04 UTC
Can you link to a patch that we can apply by putting into /etc/portage/patches?
Comment 6 Paul Varner (RETIRED) gentoo-dev 2014-11-03 02:44:23 UTC
Created attachment 388382 [details, diff]
Fix Gawk warning

I've attached the patch for what was committed in git.  I'm going to try to get a release out soon that includes the patch.
Comment 7 Nikos Chantziaras 2014-11-04 10:43:29 UTC
Seems to be working fine for me.
Comment 8 Thomas Deutschmann gentoo-dev Security 2014-11-12 13:38:18 UTC
Patch works for me (at least the warning is gone), too. Thanks!
Comment 9 Paul Varner (RETIRED) gentoo-dev 2014-11-12 18:22:34 UTC
This is released in gentoolkit-0.3.0.9-r2