Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 5264 - Invalid fields in bugzilla database inhibit users from posting
Summary: Invalid fields in bugzilla database inhibit users from posting
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: Bugzilla (show other bugs)
Hardware: All All
: High critical (vote)
Assignee: John Davis (zhen) (RETIRED)
URL:
Whiteboard:
Keywords:
: 5964 8777 14326 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-07-19 15:05 UTC by SpanKY
Modified: 2011-10-30 23:15 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SpanKY gentoo-dev 2002-07-19 15:05:10 UTC
Only the owner or submitter of the bug, or a sufficiently empowered user, may make that change to the op_sys field.
   Old value:
   New value: All

so i see this fairly often and it reallys pisses me off cause i cant put my 2
cents in on the bug

i dont know bugzilla so i dont know how you can fix it, but please do :)
(or give me some suppa powers to fix it ... we all know *thats* best)
Comment 1 Doug Goldstein gentoo-dev 2002-07-30 18:15:06 UTC
Just ignore the operating system field... it's only 1 OS here....  
Comment 2 SpanKY gentoo-dev 2002-07-30 18:22:41 UTC
heh, i would if i could
the problem is that a null value does not exist in the drop down list, so when 
IE/lynx load the pages, it selects the first value in the drop down list (which 
isnt null).  so when i submit the form, it submits a new value for the drop 
down list, resulting in that error
i know i could script it myself to post the form with only the fields i want to 
change, but the thing is, i dont want to, and the common user may not be able 
to do it
Comment 3 SpanKY gentoo-dev 2002-08-02 10:35:18 UTC
if you do a query and look for bugs using the boolean chart, you can find the 
bugs that i refer to

problem when os_sys field is invalid:
query for OS/Version is not equal to any of {Linux,All} you should get bugs 
1991,2365,2552,2609,2918,3419,3997,4805,4928,5194,5240,5248,5894

problem when rep_platform field is invalid:
query for Platform is not equal to any of {All,PC,PPC,Sparc,Sparc64}
1343,2436,3334,3335,3413,3514,3561,3831,4145,4235,4791,4868,5630,5786,5835,5887,
5888,5894,5898

i didnt test all of the bugs to confirm each has the problem, but i test 4/5 
and each did have the issue where i couldnt post because i didnt have enough 
power to change the fields op_sys or rep_platform

i think this has to do with the fact that on the NEW BUG page both the op_sys 
field and the rep_platform field get auto set by some browsers (or does it get 
set by a script in the page?) .... i know IE + win2000 sets op_sys to Win2000,  
and Linux+Lynx sets op_sys to Other and rep_platform to Other ...

the problem with that is the VIEW BUG page does not provide these other 
choices, so when some other user submits the form, they send the first value in 
the html select list, resulting in the error
Comment 4 SpanKY gentoo-dev 2002-08-03 12:30:15 UTC
as a heads up, i was going to 'fix' some of these bugs so that other people 
could post to them ... by fix i mean set the os_sys field or the rep_platform 
field to 'All'
Comment 5 SpanKY gentoo-dev 2002-08-03 12:31:52 UTC
*** Bug 5964 has been marked as a duplicate of this bug. ***
Comment 6 Damon Conway 2002-08-13 21:21:00 UTC
Hmmm...this is kabau testing with another account without editbugs privs.
Comment 7 SpanKY gentoo-dev 2002-08-13 21:54:27 UTC
whats up ?
Comment 8 Tom Ribbens 2002-08-14 06:37:34 UTC
When is this going to be resolved? Is it so hard that someone with correct 
priveledges edit all false entries?
Comment 9 SpanKY gentoo-dev 2002-08-14 06:50:33 UTC
i am editing the bugs :P
ive fixed many, and i check for new ones multiple times every day

ive just left a few for the person who is supposed to fix this :P
Comment 10 SpanKY gentoo-dev 2002-10-05 16:01:31 UTC
*** Bug 8777 has been marked as a duplicate of this bug. ***
Comment 11 Martin Holzer (RETIRED) gentoo-dev 2002-10-07 04:52:35 UTC
maybe bugzilla 2.16 fix this ?
Comment 12 Martin Holzer (RETIRED) gentoo-dev 2002-10-28 01:08:36 UTC
2.17 is out now
Comment 13 John Davis (zhen) (RETIRED) gentoo-dev 2002-12-15 21:16:33 UTC
Is this issue resolved now? I see that there is an "All" entry in both Platform 
and OS. This should fix the problem. Whats up with this?

//ZhEN
Comment 14 John Davis (zhen) (RETIRED) gentoo-dev 2002-12-19 16:48:11 UTC
Well, I am not sure that there is an easy solution to this. Short of giving a
normal user full power to edit any aspect of a bug, there is nothing that I can
do. Maybe the upgrade will fix this...
Until then, this bug will have to sleep.

//ZhEN
Comment 15 SpanKY gentoo-dev 2002-12-19 18:12:26 UTC
i was thinking of something along the lines of modifying the script that submits new 
bugs ... it would check the value of these 2 fields and if they werent right, just set them 
to 'All' 
Comment 16 John Davis (zhen) (RETIRED) gentoo-dev 2002-12-29 23:51:29 UTC
Well, I am testing this with bugzilla 2.17.2, which should roll as soon as I
have the server space. I think that this is resolved in that version; there is a
null value selected on page load, and bugzilla will throw an error if there is
no legal op_sys entry, therefore forcing the user to enter a correct op_sys
category.

Cheers,
//zhen
Comment 17 SpanKY gentoo-dev 2003-01-22 10:09:06 UTC
*** Bug 14326 has been marked as a duplicate of this bug. ***
Comment 18 Martin Holzer (RETIRED) gentoo-dev 2003-03-17 18:10:12 UTC
works
Comment 19 John Davis (zhen) (RETIRED) gentoo-dev 2003-04-04 01:19:51 UTC
db fix
Comment 20 John Davis (zhen) (RETIRED) gentoo-dev 2003-04-04 01:24:48 UTC
db fix
Comment 21 Martin Holzer (RETIRED) gentoo-dev 2003-05-05 12:38:05 UTC
works