Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 526170 - dev-perl/libintl-perl-1.230.0 - ?
Summary: dev-perl/libintl-perl-1.230.0 - ?
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-21 05:06 UTC by Vladimir
Modified: 2014-10-27 19:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-perl:libintl-perl-1.230.0:20141020-213718.log (dev-perl:libintl-perl-1.230.0:20141020-213718.log,14.23 KB, text/plain)
2014-10-21 05:06 UTC, Vladimir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2014-10-21 05:06:10 UTC
Created attachment 387104 [details]
dev-perl:libintl-perl-1.230.0:20141020-213718.log

dev-perl/libintl-perl-1.230.0 fails to build with this error message:

make[1]: Entering directory '/var/tmp/portage/dev-perl/libintl-perl-1.230.0/work/libintl-perl-1.23/gettext_xs'

cp gettext_xs.pm ../blib/lib/Locale/gettext_xs.pm

/usr/bin/perl5.20.1 /usr/lib64/perl5/vendor_perl/5.16.0/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.20.1/ExtUtils/typemap  gettext_xs.xs > gettext_xs.xsc && mv gettext_xs.xsc gettext_xs.c

make[1]: *** No rule to make target '/usr/lib64/perl5/5.20.1/x86_64-linux/CORE/fakethr.h', needed by 'gettext_xs.o'.  Stop.

make[1]: Leaving directory '/var/tmp/portage/dev-perl/libintl-perl-1.230.0/work/libintl-perl-1.23/gettext_xs'
Comment 1 Jeroen Roovers gentoo-dev 2014-10-21 08:06:14 UTC
1) Please post your `emerge --info' output in a comment.
2) Please post your `emerge -vpq dev-lang/perl' output in a comment.
Comment 2 Jeroen Roovers gentoo-dev 2014-10-21 08:07:30 UTC
Actually this line explains it:

/usr/bin/perl5.20.1 /usr/lib64/perl5/vendor_perl/5.16.0/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.20.1/ExtUtils/typemap  gettext_xs.xs > gettext_xs.xsc && mv gettext_xs.xsc gettext_xs.c

It's mixing perl versions. You need to run perl-cleaner.

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 3 Vladimir 2014-10-22 05:45:46 UTC
(In reply to Jeroen Roovers from comment #2)
> Actually this line explains it:
> 
> /usr/bin/perl5.20.1 /usr/lib64/perl5/vendor_perl/5.16.0/ExtUtils/xsubpp 
> -typemap /usr/lib64/perl5/5.20.1/ExtUtils/typemap  gettext_xs.xs >
> gettext_xs.xsc && mv gettext_xs.xsc gettext_xs.c
> 
> It's mixing perl versions. You need to run perl-cleaner.
> 
Now I am trying to run perl-cleaner, but I get this:

/usr/bin/perl5.20.1 /usr/lib64/perl5/vendor_perl/5.20.1/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.20.1/ExtUtils/typemap  gettext_xs.xs > gettext_xs.xsc && mv gettext_xs.xsc gettext_xs.c

make[1]: *** No rule to make target '/usr/lib64/perl5/5.20.1/x86_64-linux/CORE/fakethr.h', needed by 'gettext_xs.o'.  Stop.

So, now there is only one perl version, but still the error is there. It looks similar to the one described in the Gentoo forum: http://forums.gentoo.org/viewtopic-t-1001790-start-0-postdays-0-postorder-asc-highlight-.html
Comment 4 Jeroen Roovers gentoo-dev 2014-10-23 18:16:29 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 5 Jeroen Roovers gentoo-dev 2014-10-23 18:17:55 UTC
There should be no possible way for this to happen:

/usr/bin/perl5.20.1 /usr/lib64/perl5/vendor_perl/5.16.0/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.20.1/ExtUtils/typemap  gettext_xs.xs > gettext_xs.xsc && mv gettext_xs.xsc gettext_xs.c

Maybe you should try re-emerging perl-core/ExtUtils-ParseXS first.
Comment 6 Vladimir 2014-10-23 21:59:10 UTC
(In reply to Jeroen Roovers from comment #5)
> There should be no possible way for this to happen:
> 
> /usr/bin/perl5.20.1 /usr/lib64/perl5/vendor_perl/5.16.0/ExtUtils/xsubpp 
> -typemap /usr/lib64/perl5/5.20.1/ExtUtils/typemap  gettext_xs.xs >
> gettext_xs.xsc && mv gettext_xs.xsc gettext_xs.c
> 
There are no mixed perl versions in my case any more. Please note the '5.20.1' version everywhere. The exact error message is this:

/usr/bin/perl5.20.1 /usr/lib64/perl5/vendor_perl/5.20.1/ExtUtils/xsubpp  -typemap /usr/lib64/perl5/5.20.1/ExtUtils/typemap  gettext_xs.xs > gettext_xs.xsc && mv gettext_xs.xsc gettext_xs.c
make[1]: *** No rule to make target '/usr/lib64/perl5/5.20.1/x86_64-linux/CORE/fakethr.h', needed by 'gettext_xs.o'.  Stop.

> Maybe you should try re-emerging perl-core/ExtUtils-ParseXS first.
I did re-emerged this package, but still I get what I quoted above.
Comment 7 Vladimir 2014-10-27 16:48:13 UTC
So is this really a duplicate of the bug 41124 if it is not solved by the recipe given there?
Comment 8 Vladimir 2014-10-27 18:14:52 UTC
It looks like perl-5.20.1 is missing a fakethr.h file. I created it like it was suggested here: http://buildroot-busybox.2317881.n4.nabble.com/PATCH-1-3-perl-bump-to-version-5-20-1-td80554.html

touch /usr/lib/perl5/5.20.1/x86_64-linux/CORE/fakethr.h

and after that I am able to build the perl packages without any problem. So is it a bug of perl-5.20.1 or something else?

Thank you.
Comment 9 Jeroen Roovers gentoo-dev 2014-10-27 18:19:58 UTC
Comment on attachment 387104 [details]
dev-perl:libintl-perl-1.230.0:20141020-213718.log

Please attach that new (presumably failing) build log to this bug report.
Comment 10 Vladimir 2014-10-27 18:58:01 UTC
(In reply to Jeroen Roovers from comment #9)
> Comment on attachment 387104 [details]
> dev-perl:libintl-perl-1.230.0:20141020-213718.log
> 
> Please attach that new (presumably failing) build log to this bug report.
After performing the perl-cleaner with 

  /usr/lib/perl5/5.20.1/x86_64-linux/CORE/fakethr.h

file present I cannot reproduce such error any more, so now it does not seem to be a problem of libintl-perl itself, but rather something strange about perl-5.20.1. And as I mentioned above, a number of similar complains may be easily found in google, and on Gentoo forums in particular.
Comment 11 Jeroen Roovers gentoo-dev 2014-10-27 19:05:35 UTC
(In reply to Vladimir from comment #10)
> (In reply to Jeroen Roovers from comment #9)
> > Comment on attachment 387104 [details]
> > dev-perl:libintl-perl-1.230.0:20141020-213718.log
> > 
> > Please attach that new (presumably failing) build log to this bug report.
> After performing the perl-cleaner with 
> 
>   /usr/lib/perl5/5.20.1/x86_64-linux/CORE/fakethr.h
> 
> file present I cannot reproduce such error any more

We can't fix it if you work around the package manager.