Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 525928 - [gnome-overlay] x11-libs/gtk+-3.14.3 fails to compile with dash as /bin/sh
Summary: [gnome-overlay] x11-libs/gtk+-3.14.3 fails to compile with dash as /bin/sh
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
Depends on:
Blocks: nonbash gnome-3.14
  Show dependency tree
 
Reported: 2014-10-20 02:21 UTC by Maciej Piechotka
Modified: 2014-11-30 15:54 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (x11-libs:gtk+-3.14.3:20141020-004417.log.gz,18.40 KB, application/x-gzip)
2014-10-20 02:21 UTC, Maciej Piechotka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2014-10-20 02:21:44 UTC
Created attachment 386998 [details]
Build log

/usr/bin/glib-mkenums: gtktextview.h:59: Failed to parse `  /*< private >*/ '
/usr/bin/glib-mkenums: gtktextview.h:61: Failed to parse `  /*< public >*/ '
glib-compile-resources gtk.gresource.xml \
        --target=gtkresources.c --sourcedir=./resources --c-name _gtk --generate-source --manual-register
glib-compile-resources gtk.gresource.xml \
        --target=gtkresources.h --sourcedir=./resources --c-name _gtk --generate-header --manual-register
gtk.gresource.xml: Error on line 1 char 1: Document must begin with an element (e.g. <book>).
Makefile:6663: recipe for target 'gtkresources.c' failed
make[2]: *** [gtkresources.c] Error 1
make[2]: *** Waiting for unfinished jobs....
gtk.gresource.xml: Error on line 1 char 1: Document must begin with an element (e.g. <book>).
Makefile:6660: recipe for target 'gtkresources.h' failed

Portage 2.2.14_rc1 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-4.9.1, glibc-2.19-r1, 3.16.0-pf1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.16.0-pf1-x86_64-Intel-R-_Core-TM-_i7-3820QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    16051524 total,   5192392 free
KiB Swap:   20971484 total,  20964296 free
Timestamp of tree: Sun, 19 Oct 2014 21:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r1
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.2
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3, 4.9.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.1
sys-kernel/linux-headers: 3.17 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo crossdev gentoo-haskell vala steam-overlay bumblebee rust x11 gnome local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -ggdb -Wa,--compress-debug-sections -fgcse-sm -fgcse-las -fgcse-after-reload -floop-block -floop-interchange -ftree-loop-distribution -floop-strip-mine"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -ggdb -Wa,--compress-debug-sections -fgcse-sm -fgcse-las -fgcse-after-reload -floop-block -floop-interchange -ftree-loop-distribution -floop-strip-mine"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="-j8 --load-average=7"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs clean-logs compress-build-logs compressdebug config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.hoobly.com/ http://gentoo.mirrors.easynews.com/linux/gentoo/ http://gentoo.llarian.net/"
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common -Wl,--no-keep-memory"
MAKEOPTS="-j4 -l7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-crossdev /var/lib/layman/haskell /var/lib/layman/vala /var/lib/layman/steam /var/lib/layman/bumblebee /var/lib/layman/rust /var/lib/layman/x11 /var/lib/layman/gnome /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 avx berkdb bluetooth branding bzip2 bzr c++0x cairo caps cdda cdr cli clutter colord cracklib crypt cryptsetup cups cxx dbus dconf debugger device-mapper dri dri3 dts dvd dvdr eds egl emacs emboss encode evo exif fam ffmpeg firefox flac flash fontconfig fortran fprint fuse g3dvl gbm gdbm gdm gif git glamor gmp gnome gnome-keyring gnome-online-accounts gnuplot google gpm grilo gsettings gstreamer gtk gtk3 gtkstyle gui iconv inotify introspection iproute2 ipsec ipv6 ipython irc ithreads jabber jemalloc jit jpeg kerberos laptop latex lcms ldap libkms libnotify libproxy libsecret llvm lvm lzma mad map mercurial mmx mng modules mp3 mp4 mpeg multilib nautilus ncurses networking networkmanager nls nptl nsplugin nss ogg opencl opengl openmp oss pam pango parted pch pcre pdf perl pkcs11 plotutils png policykit ppds profiler pulseaudio python python3 qemu qt4 readline realtime rss samba scanner sdl session smartcard sna socialweb spell spice sqlite sse sse2 sse4_1 sse4_2 ssl ssse3 startup-notification steamruntime subversion svg symlink systemd tcpd telepathy theora threads tiff tracker truetype udev udisks unicode upnp upower usb v4l vaapi vala vdpau virt-network virtfs vorbis vpx webkit wxwidgets x264 xattr xcb xcomposite xinerama xml xrandr xv xvid zeitgeist zlib zsh-completion" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="caps crypt lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="evdev synaptics mouse mutouch" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en pl en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python3_4 python3_3 pypy python2_7" QEMU_SOFTMMU_TARGETS="arm x86_64 i386" QEMU_USER_TARGETS="arm x86_64 i386" RUBY_TARGETS="ruby20 ruby21" SANE_BACKENDS="gt68xx" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC

=================================================================
                        Package Settings
=================================================================

x11-libs/gtk+-3.12.2 was built with the following:
USE="X colord cups introspection xinerama (-aqua) -cloudprint -debug -examples -test -vim-syntax -wayland" ABI_X86="64"
CFLAGS="-O2 -march=native -pipe -ggdb -Wa,--compress-debug-sections"
CXXFLAGS="-O2 -march=native -pipe -ggdb -Wa,--compress-debug-sections"

Compiling gtk+ 'by hand' as user works so one of the flags is causing this problem.
Comment 1 Maciej Piechotka 2014-10-20 02:30:15 UTC
After looking it looks like each line is prefixed by -e. It's side effect of using eselect-sh with dash enabled, which does not support -e. I'll report it upstream.
Comment 2 Alexander Tsoy 2014-10-23 07:11:24 UTC
Hmm.. On my system configure sets SHELL=/bin/bash despite the fact that /bin/sh is symlinked to dash. And I don't see any related patches in debian (where dash is a default /bin/sh implementation).

vm2450 gtk+-3.14.3 # ls -l /bin/sh 
lrwxrwxrwx 1 root root 4 Oct 20 14:16 /bin/sh -> dash
vm2450 gtk+-3.14.3 # grep ^SHELL config.log
SHELL='/bin/bash'
vm2450 gtk+-3.14.3 # grep ^SHELL gtk/Makefile.in 
SHELL = @SHELL@
vm2450 gtk+-3.14.3 # grep ^SHELL gtk/Makefile    
SHELL = /bin/bash
Comment 3 Alexander Tsoy 2014-10-24 08:17:30 UTC
OK. I successfuly reproduced this bug after upgrade from dash-0.5.7.4 to -0.5.8.1.
Comment 4 Alexander Tsoy 2014-10-24 09:28:04 UTC
@gnome: it seems upstream do not care about shells other than bash. Given the number of bugs Maciej filed recently, maybe it make sense to set CONFIG_SHELL in gnome2.eclass?

-    econf ${G2CONF} "$@"
+    CONFIG_SHELL=${BASH} econf ${G2CONF} "$@"
Comment 5 Gilles Dartiguelongue gentoo-dev 2014-10-24 22:56:16 UTC
Most of the errors of this kind we reported over the years got nicely patched upstream as we reported them. If you have patches, please forward it to them.

You just eventually need to remind them that autotools documentation explicitely state that shell must be POSIX compliant, not bash specific.
Comment 6 Alexander Tsoy 2014-10-31 18:16:32 UTC
(In reply to Alexander Tsoy from comment #3)
> OK. I successfuly reproduced this bug after upgrade from dash-0.5.7.4 to
> -0.5.8.1.

See bug 527644
Comment 7 Rémi Cardona gentoo-dev 2014-11-30 15:54:26 UTC
Fixed in the overlay without a revbump.