Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 525420 - [gnome-overlay] x11-libs/vte-0.38.1 fails to update from x11-libs/vte-0.36.3
Summary: [gnome-overlay] x11-libs/vte-0.38.1 fails to update from x11-libs/vte-0.36.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2014-10-14 15:33 UTC by nE0sIghT
Modified: 2014-12-26 21:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nE0sIghT 2014-10-14 15:33:03 UTC
* Messages for package x11-libs/vte-0.38.1:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). See
 * http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
 * solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 * 
 * Detected file collision(s):
 * 
 * 	/usr/share/glade/pixmaps/hicolor/22x22/actions/widget-vte-terminal.png
 * 	/usr/share/glade/pixmaps/hicolor/16x16/actions/widget-vte-terminal.png
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * x11-libs/vte-0.36.3:2.90::gentoo
 * 	/usr/share/glade/pixmaps/hicolor/16x16/actions/widget-vte-terminal.png
 * 	/usr/share/glade/pixmaps/hicolor/22x22/actions/widget-vte-terminal.png
 * 
 * Package 'x11-libs/vte-0.38.1' NOT merged due to file collisions. If
 * necessary, refer to your elog messages for the whole content of the
 * above message.
 * One or more packages are either masked or have missing dependencies:
 * 
 *   ~x11-libs/gnome-pty-helper-0.36.3 pulled in by:
 *     (x11-libs/vte-0.36.3::gentoo, installed)
 * 
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.
 * 
 * The following package has failed to build or install:
 * 
 *  (x11-libs/vte-0.38.1::gnome, ebuild scheduled for merge)
 * 

emerge --info
Portage 2.2.8-r2 (default/linux/amd64/13.0, gcc-4.8.3, glibc-2.19-r1, 3.16.3-gentoo x86_64)
=================================================================
System uname: Linux-3.16.3-gentoo-x86_64-Intel-R-_Core-TM-_i5-2400_CPU_@_3.10GHz-with-gentoo-2.2
KiB Mem:    16391316 total,   7886044 free
KiB Swap:    2095100 total,   2095100 free
Timestamp of tree: Tue, 14 Oct 2014 00:45:01 +0000
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r1
dev-lang/python:          2.7.7, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo vortex systemd qutim gnome
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=native -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/vortex /var/lib/layman/systemd /var/lib/layman/qutim /var/lib/layman/gnome"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a-like-o a52 aac aacplus aacs aalib acl acpi alsa amd64 apng applet archive artworkextra audacious audiofile automount avx bazaar berkdb bidi bittorrent bittorrent-external bluray branding bsf bzip2 cairo caps chardet chdir cjk cli collada colord cover cracklib crypt css cuda cue cupsddk curl cvs cxx dbus dconf device-mapper dga dhcp dhcpcd dht diff dirac disk-partition divx djvu dnsretry dos drawing dri dv eap-tls enca encode exif experimental extensions extras facedetect fat fbcondecor ffmpeg fftw fileinfo firefox firmware flac fontconfig fortran frei0r fts3 fuse g3dvl gd gdbm gdm geoip gif glade glib glitz gnome gnome-keyring gnome-online-accounts gnome-shell gphoto2 gpm graphite grp grub gstreamer gtk gtk3 gtkstyle gudev gzip hddtemp highlight histman hog hvm hwdb iconsets iconv icq id3tag idle idn infinality inifile intl introspection ioemu ipv6 iso jabber java javascript jingle joystick jpeg jpeg2k kate keymap kinetic kvm ladspa lame lcms libass libcaca libkms libnotify libsamplerate libsecret libtiger lights lm_sensors loop-aes lto lucene lyrics lzma lzo mad matroska melt mercurial minizip mmx mmxext mng modules mp2 mp3 mp4 mp4live mpeg mpeg2 mpg123 mplayer mpris mpu401 mtp mudflap multilib multimedia musepack mvl mysql mysqli nautilus ncurses netplay network nls nptl nsplugin nss ntfs ntfsprogs nvidia offensive ofx ogg ogm oodict openal opencore-amr opengl openmp openssl opensslcrypt optimization optimized-qmake oscar pam parse-clocks pcf pch pcre pcre16 pdf pdo pgo php pipelight player plugins png policykit ppds pppd projectm psf pulseaudio purple qml qpak quicktime rar readline realmedia realtime reiserfs resolvconf romio rtsp ru-dv ru-g ru-i ru-k sasl scale0tilt screen screenshot sdl secure-delete sendto session skins slp smp sndfile socialweb sound sounds speex spell sqlite sqlite3 sse sse2 sse2_4way sse3 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification stream stroke strong-optimization subtitles subversion svg system-cairo system-icu system-jpeg system-sqlite systemd t1lib taglib tcpd textures theora threads thunderbird tiff tint2conf tk tls toolbar trayicon truetype tta tweak-mode twolame udev udisks unicode unzip upower usb utils uvm v4l2 vaapi vala vamp vdpau verse vkontakte vorbis vorbis-psy vpx wad wav wavpack webgl webkit webp webphoto whiteboarding winbind wma wmp x264 x265 xanim xattr xcb xcomposite xhtml xinetd xkb xml xmlreader xmlrpc xmlwriter xorg xosd xpm xsl xslt xulrunner xv xvfb xvid zip zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="plymouth systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru ru_RU en" NETBEANS_MODULES="apisupport cnd enterprise harness ide j2ee java nb php profiler webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Gilles Dartiguelongue gentoo-dev 2014-10-15 22:03:45 UTC
Hum, I am not getting that conflict but I guess you have USE="glade" right ?
If so, we could workaround this by just making the flag mutually exclusive for both slots, would that be good for you ?
Comment 2 Gilles Dartiguelongue gentoo-dev 2014-10-15 22:05:42 UTC
Hum, I am not getting that conflict but I guess you have USE="glade" right ?
If so, we could workaround this by just making the flag mutually exclusive for both slots, would that be good for you ?
Comment 3 nE0sIghT 2014-10-16 03:29:51 UTC
(In reply to Gilles Dartiguelongue from comment #1)
> Hum, I am not getting that conflict but I guess you have USE="glade" right ?

That's right

> If so, we could workaround this by just making the flag mutually exclusive
> for both slots, would that be good for you ?

For me this is not problem. I do not need both versions installed at the same time
Comment 4 Gilles Dartiguelongue gentoo-dev 2014-11-03 23:35:57 UTC
commit 766cbf8a809aa8c0998ab47dffd4e23998f13196
Author: Gilles Dartiguelongue <eva@gentoo.org>
Date:   Tue Nov 4 00:35:14 2014 +0100

    x11-libs/vte: add a blocker for conflicting glade integration
    
    Fixes bug #525420.
Comment 5 Gilles Dartiguelongue gentoo-dev 2014-12-26 21:44:11 UTC
*** Bug 533574 has been marked as a duplicate of this bug. ***