Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 525300 - x11-libs/cairo-1.12.16-r4 stabilization request
Summary: x11-libs/cairo-1.12.16-r4 stabilization request
Status: RESOLVED DUPLICATE of bug 540676
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexandre Rostovtsev (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 510782
Blocks:
  Show dependency tree
 
Reported: 2014-10-13 15:58 UTC by Arfrever Frehtes Taifersar Arahesis
Modified: 2015-02-19 15:20 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis 2014-10-13 15:58:56 UTC
x11-libs/cairo-1.12.16-r3 stabilization is needed due to multilib.
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-10-13 18:27:02 UTC
X11 team is going to make a big stabilization bug for all packages in the herd again. If the other maintainers wish to proceed earlier, please go ahead.
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-11-25 15:44:04 UTC
Please continue in the x11 stabilization bug.

If the other maintainers wish to proceed with stabilization before the x11 stabilization bug is ready, re-open this bug and CC: arches.

*** This bug has been marked as a duplicate of bug 530652 ***
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-11-26 02:19:56 UTC
I want to fix build failure with recent gcc before stabilizing (bug #510782)
Comment 4 Pacho Ramos gentoo-dev 2014-11-26 09:59:21 UTC
(In reply to Alexandre Rostovtsev from comment #3)
> I want to fix build failure with recent gcc before stabilizing (bug #510782)

Looks like it fail with gcc-4.9, not 4.8 (the latest stable one) :/
Comment 5 Matt Turner gentoo-dev 2014-12-11 06:30:02 UTC
Depending on how long we wait, we might want to jump straight to 1.12.18.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2014-12-13 22:20:40 UTC
People, you are slacking and emul-linux-x86 are eating puppies!
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2014-12-23 20:16:27 UTC
(In reply to Alexandre Rostovtsev from comment #3)
> I want to fix build failure with recent gcc before stabilizing (bug #510782)

Is there any fix undergoing? If not, I'd rather see cairo stabilized and USE=lto p.u.masked. Adding lto semi-implicitly to random packages in the tree is a bad idea anyway.
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2014-12-23 21:33:20 UTC
(In reply to Michał Górny from comment #7)
> (In reply to Alexandre Rostovtsev from comment #3)
> > I want to fix build failure with recent gcc before stabilizing (bug #510782)
> 
> Is there any fix undergoing? If not, I'd rather see cairo stabilized and
> USE=lto p.u.masked. Adding lto semi-implicitly to random packages in the
> tree is a bad idea anyway.

Ok, I see that upstream reverted LTO support. Disabled it in 1.2.16-r[34] as well.
Comment 9 Pacho Ramos gentoo-dev 2014-12-24 09:46:22 UTC
*cairo-1.12.16-r4 (29 Nov 2014)

  29 Nov 2014; Michał Górny <mgorny@gentoo.org> +cairo-1.12.16-r4.ebuild:
  Stop wrapping cairo-features.h. Now that we pass consistent configure options,
  it should be the same on all ABIs. Fixes compatibility with dev-haskell/cairo
  hackery, bug #531120.


Maybe -r4 would be a better stable candidate, and it shouldn't add any delay as we are near a month since it was added to the tree
Comment 10 Markus Meier gentoo-dev 2015-01-08 20:47:17 UTC
arm stable
Comment 11 Jeroen Roovers gentoo-dev 2015-01-09 11:42:42 UTC
Stable for HPPA.
Comment 12 Agostino Sarubbo gentoo-dev 2015-01-31 14:14:48 UTC
amd64 stable
Comment 13 Alexandre Rostovtsev (RETIRED) gentoo-dev 2015-02-19 15:20:31 UTC
Superseded by bug #540676 - please stabilize 1.12.18 now, it fixes lots of bugs.

*** This bug has been marked as a duplicate of bug 540676 ***