Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 524364 (CVE-2014-7295) - <www-apps/mediawiki-{1.19.20,1.22.12,1.23.5}: emove separation of css and js module allowance issue (CVE-2014-7295)
Summary: <www-apps/mediawiki-{1.19.20,1.22.12,1.23.5}: emove separation of css and js ...
Status: RESOLVED FIXED
Alias: CVE-2014-7295
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard: B4 [glsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-03 10:03 UTC by Agostino Sarubbo
Modified: 2015-02-07 17:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2014-10-03 10:03:59 UTC
From ${URL} :

he MediaWiki 1.19.20, 1.22.12, and 1.23.5 releases fix the following security issue:

"(bug 70672) SECURITY: OutputPage: Remove separation of css and js module allowance."

References:

https://bugzilla.wikimedia.org/show_bug.cgi?id=70672
https://gerrit.wikimedia.org/r/#/c/164271/
https://lists.wikimedia.org/pipermail/mediawiki-announce/2014-October/000163.html


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Sean Amoss gentoo-dev Security 2014-12-15 00:23:52 UTC
Adding to existing GLSA draft.
Comment 2 GLSAMaker/CVETool Bot gentoo-dev 2014-12-15 01:13:29 UTC
CVE-2014-7295 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-7295):
  The (1) Special:Preferences and (2) Special:UserLogin pages in MediaWiki
  before 1.19.20, 1.22.x before 1.22.12 and 1.23.x before 1.23.5 allows remote
  authenticated users to conduct cross-site scripting (XSS) attacks or have
  unspecified other impact via crafted CSS, as demonstrated by modifying
  MediaWiki:Common.css.
Comment 3 GLSAMaker/CVETool Bot gentoo-dev 2015-02-07 17:54:26 UTC
This issue was resolved and addressed in
 GLSA 201502-04 at http://security.gentoo.org/glsa/glsa-201502-04.xml
by GLSA coordinator Kristian Fiskerstrand (K_F).