Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 524040 - app-portage/layman-2.2.0 app-portage/g-sorcery re-keyword request
Summary: app-portage/layman-2.2.0 app-portage/g-sorcery re-keyword request
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Layman Overlay Manager project
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks:
 
Reported: 2014-09-29 15:35 UTC by Jauhien Piatlicki (RETIRED)
Modified: 2018-10-16 09:20 UTC (History)
6 users (show)

See Also:
Package list:
app-portage/layman-2.4.2-r1 app-portage/g-sorcery-0.2.1-r1
Runtime testing required: ---
slyfox: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jauhien Piatlicki (RETIRED) gentoo-dev 2014-09-29 15:35:10 UTC
Please, keword app-portage/g-sorcery for these arches:

~alpha ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~ppc-aix ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris

It is a dependency of app-portage/layman with USE g-sorcery set. When keywording, please, unmask g-sorcery USE for layman on per-arch basis.
Comment 1 Jeroen Roovers gentoo-dev 2014-09-29 15:43:56 UTC
(In reply to Jauhien Piatlicki from comment #0)
> Please, keword app-portage/g-sorcery for these arches:
> 
> ~alpha ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
> ~ppc-aix ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux
> ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris
> ~x86-solaris
> 
> It is a dependency of app-portage/layman with USE g-sorcery set. When
> keywording, please, unmask g-sorcery USE for layman on per-arch basis.

Why didn't you drop the layman keywords as you should have?
Comment 2 Jeroen Roovers gentoo-dev 2014-09-29 15:49:55 UTC
Fixed that for you.
Comment 3 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-09-29 16:26:27 UTC
@Jeroen Roovers: I'm not a maintainer of layman, so I do not touch its keywords. Devan Franchini has masked g-sorcery USE instead, so this USE can be unmasked only on the arches g-sorcery is keyworded on.
Comment 4 Brian Dolbec gentoo-dev 2014-09-29 16:38:51 UTC
Yeah, since it was an optional dep, I thought the USE flag should be masked rather than drop all keywords in layman.  g-sorcery needs layman for it to be keyworded, but layman didn't need g-sorcery except for the overlay types it creates ebuilds for.

Either way, Keyword please  :)
Comment 5 Devan Franchini (RETIRED) gentoo-dev 2014-09-29 16:49:13 UTC
Also, I'm on the tools-portage mailing list/herd, so no need for me to get dup emails. :)
Comment 6 Jeroen Roovers gentoo-dev 2014-09-29 17:00:52 UTC
(In reply to Brian Dolbec from comment #4)
> Yeah, since it was an optional dep, I thought the USE flag should be masked
> rather than drop all keywords in layman.  g-sorcery needs layman for it to
> be keyworded, but layman didn't need g-sorcery except for the overlay types
> it creates ebuilds for.

I really don't get why this needs to be repeated over and over on such a regular basis:

Keywording new dependencies that are masked by USE flags can be done in two ways, whichever is MORE EFFICIENT:

A) Drop the keywords on the ebuild that requires the new dependency. This touches a
   SINGLE file (disregarding ChangeLog): the ebuild that requires the new dependency.
B) If that is inconvenient, because many other ebuilds in turn rely on the new ebuild,
   THEN you mask the USE flag instead, which involves touching a couple more files in
   profiles/ but is more efficient than touch all those other ebuilds.

Resolving the bug means that for each arch, testing requires:

A1) adding two atoms to package.keywords (or whatever its "nom du jour" is)
A2) enabling the new USE flag.

B1) adding two atoms to package.keywords (or whatever its "nom du jour" is) (since
    usually the new parent ebuild is still unstable)
B2) enabling the new USE flag.
B3) unmasking the new USE flag

Keywording itself requires:

A1) keywording two ebuilds. (ekeyword(1) does this very quickly and reliably)

B1) keywording one ebuild and manually editing package.use.mask in one (or more) (sub-)profiles to mask
    the new USE flag (which might need to be revised later and adds to the general cruft in profiles),
    or alternatively
B2) manually editing package.use.mask in one (or more) (sub-)profiles to mask the new USE flag
    (overlaying the general package.use.mask already in place, which might need to be revised later and
    adds to the general cruft in profiles).

In this case the former is obviously the preferable solution, as it involves no manual editing of profiles, no cruft in the profiles, and touches as few files as possible.
Comment 7 Jeroen Roovers gentoo-dev 2014-09-29 22:45:39 UTC
Marked ~hppa.
Comment 8 Anthony Basile gentoo-dev 2014-10-04 14:08:14 UTC
keyworded ~ppc and ~ppc64
Comment 9 Manuel Rüger gentoo-dev 2014-10-16 00:19:36 UTC
Added ~arm keyword.
Comment 10 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-11-09 07:52:19 UTC
~ia64 done
Comment 11 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-11-23 11:52:32 UTC
~alpha done
Comment 12 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-11-23 16:33:26 UTC
~sparc done
Comment 13 Sergey Popov gentoo-dev Security 2015-02-18 14:01:56 UTC
~s390 added to 2.3 during bug #539366

USE="g-sorcery" is masked on s390
Comment 14 Markus Meier gentoo-dev 2017-03-01 19:56:43 UTC
~arm64 is already there.
Comment 15 Matt Turner gentoo-dev 2018-03-17 06:14:56 UTC
missing latest g-sorcery keywords for ~alpha and ~ia64. readding.
Comment 16 Stabilization helper bot gentoo-dev 2018-03-17 07:00:42 UTC
An automated check of this bug failed - repoman reported dependency errors (9 lines truncated): 

> dependency.bad app-portage/g-sorcery/g-sorcery-0.2.1-r1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0) ['dev-python/pymongo[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad app-portage/g-sorcery/g-sorcery-0.2.1-r1.ebuild: RDEPEND: ~ia64(default/linux/ia64/17.0) ['dev-python/pymongo[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad app-portage/g-sorcery/g-sorcery-0.2.1-r1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop) ['dev-python/pymongo[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 17 Stabilization helper bot gentoo-dev 2018-03-17 12:00:39 UTC
An automated check of this bug failed - repoman reported dependency errors (19 lines truncated): 

> dependency.bad dev-python/pymongo/pymongo-3.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['dev-python/pykerberos[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-db/mongodb-2.6.0']
> dependency.bad dev-python/pymongo/pymongo-3.5.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['dev-python/pykerberos[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pymongo/pymongo-3.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['dev-python/pykerberos[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-db/mongodb-2.6.0']
Comment 18 Sergei Trofimovich gentoo-dev 2018-03-17 12:53:29 UTC
Dropping dev-python/pymongo-3.5.1 back as it needs mongo (and dev-lang/go).
Comment 19 Stabilization helper bot gentoo-dev 2018-03-17 13:00:34 UTC
An automated check of this bug failed - repoman reported dependency errors (9 lines truncated): 

> dependency.bad app-portage/g-sorcery/g-sorcery-0.2.1-r1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0) ['dev-python/pymongo[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad app-portage/g-sorcery/g-sorcery-0.2.1-r1.ebuild: RDEPEND: ~ia64(default/linux/ia64/17.0) ['dev-python/pymongo[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad app-portage/g-sorcery/g-sorcery-0.2.1-r1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop) ['dev-python/pymongo[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 20 Larry the Git Cow gentoo-dev 2018-03-18 11:00:22 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f61a029c373747c08fc51a0fc27d70a31fb9479a

commit f61a029c373747c08fc51a0fc27d70a31fb9479a
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-03-18 10:58:15 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-03-18 10:58:15 +0000

    profiles/arch/ia64: mask app-portage/g-sorcery[bson], bug #524040
    
    app-portage/g-sorcery[bson] requires dev-lang/go
    in it's toolchain dependency (via app-admin/mongo-tools).
    
    Bug: https://bugs.gentoo.org/524040
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 profiles/arch/ia64/package.use.mask | 4 ++++
 1 file changed, 4 insertions(+)}
Comment 21 Sergei Trofimovich gentoo-dev 2018-03-18 11:00:58 UTC
~ia64 keyworded
Comment 22 Matt Turner gentoo-dev 2018-03-28 05:43:15 UTC
added ~mips
Comment 23 Tobias Klausmann gentoo-dev 2018-10-16 09:20:14 UTC
Keyworded on ~alpha.